Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 688352 - net-misc/netifrc-0.5.1: Using dhclient for DHCP connections causes exit after IP renewal failure
Summary: net-misc/netifrc-0.5.1: Using dhclient for DHCP connections causes exit after...
Status: RESOLVED DUPLICATE of bug 417365
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: netifrc (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: netifrc Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-19 10:24 UTC by Tiago Marques
Modified: 2020-05-31 05:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tiago Marques 2019-06-19 10:24:07 UTC
I've had issues with WAN IPs and dhcpcd causing me to not have internet after a shutdown. This led me to try out 'dhclient' module for DHCP and it has been working much better.

The issue I found is that due to some ISP downtime, an IP renewal failed, which caused 'dhclient' to exit for that interface.

Upon further examination, the '/lib/netifrc/net/dhclient.sh' script calls the binary with "-1" parameter, which causes an exit after failure to renew or acquire an IP.

This is highly undesirable, as it will mean 'dhclient' will not keep retrying to acquire IP and the box will need to be manually intervened to restore connectivity.
Comment 1 Ben Kohler gentoo-dev 2019-07-10 14:47:06 UTC
Without this -1 param, starting the service with cable unplugged still reports "received address  [ok]".  Do you have any ideas to exit with failure code for the initial startup but not exit later for a temporary failure to renew?
Comment 2 Tiago Marques 2019-12-04 15:10:29 UTC
I think you're correct, this is almost certainly a bug in DHCPCd.

The issue was that a renewal failed a couple of minutes after ACK the IP used before the downtime. So, the interface was properly configured which should not exit after subsequent errors:

-1, --oneshot
             Exit after configuring an interface.  Use the -w, --waitip option
             to specify which protocol(s) to configure before exiting.

Should I submit this as a bug on DHCPCd?

Best regards
Comment 3 Tiago Marques 2019-12-31 17:48:20 UTC
Forget when I mentioned 'DHCPCDd' on the previous comment, should have read 'dhclient'.

I see the following: '-1', by the manual is supposed to fail with failure code 2 - so what you mention is a bug somewhere.

In the manual, I don't see any other options worth mentioning.
Comment 4 Mihai Moldovan 2020-05-22 11:05:21 UTC
Duplicate of #417365, if I'm not mistaken.
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2020-05-31 05:15:26 UTC

*** This bug has been marked as a duplicate of bug 417365 ***