Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 687876 - app-portage/unsymlink-lib - One or more files are both in /usr/lib/ and /usr/lib32/: libc3pl.so libcnlbcm.so
Summary: app-portage/unsymlink-lib - One or more files are both in /usr/lib/ and /usr/...
Status: RESOLVED DUPLICATE of bug 687514
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michał Górny
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-11 17:34 UTC by bugs.reporter
Modified: 2019-06-11 22:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugs.reporter 2019-06-11 17:34:25 UTC
# unsymlink-lib --analyze
Analyzing files installed into lib & lib64...

directories that will be moved to /lib/:
        bootchart
        firmware
        gentoo
        modprobe.d
        modules
        netifrc
        rc
        systemd
        udev
        (+ 0 files)

directories whose contents will be split between /lib/ and /lib64/:
        dhcpcd

orphan dirs/files (not owned by any package) that will be moved to /lib/:
        cpp

directories that will be moved to /usr/lib/:
        clang
        crda
        debug
        gcc
        grub
        llvm
        mypaint
        polkit-1
        portage
        pypy2.7
        pypy3.6
        python-exec
        python3.7
        systemd
        tmpfiles.d
        upower
        (+ 3 files)

directories whose contents will be split between /usr/lib/ and /usr/lib64/:
        ConsoleKit
        cmake
        go

orphan dirs/files (not owned by any package) that will be moved to /usr/lib/:
        ccache
        cracklib_dict.hwm
        cracklib_dict.pwd
        cracklib_dict.pwi
        libglade
        libxslt-plugins
        ntfs-3g
        openldap
        pango
        ppx_deriving
        pypy
        python3.3
        python3.4

orphan dirs/files (not owned by any package) that will be kept in /usr/lib64/:
        libcblas.a
        libcblas.so
        libcblas.so.0
        libdb.a
        libdb.so
        libdb_cxx.a
        libdb_cxx.so
        libdb_stl.a
        libdb_stl.so
        libfreebl3.chk
        libnssdbm3.chk
        libsoftokn3.chk


One or more files are both in /usr/lib/ and /usr/lib32/, making the conversion impossible.

        libc3pl.so
        libcnlbcm.so

Please report a bug at https://bugs.gentoo.org/, and do not proceed with
the migration until a proper solution is found.
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2019-06-11 18:18:15 UTC
(In reply to bugs.reporter from comment #0)
> # unsymlink-lib --analyze
> Analyzing files installed into lib & lib64...
> One or more files are both in /usr/lib/ and /usr/lib32/, making the
> conversion impossible.
> 
>         libc3pl.so
>         libcnlbcm.so
> 
> Please report a bug at https://bugs.gentoo.org/, and do not proceed with
> the migration until a proper solution is found.

This sounds as if /usr/lib is a real directory already.  It should be a symlink to /usr/lib64.

Could you please show the output of 'emerge --info' and 'ls -ld {,/usr}/lib{,32,64}'
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2019-06-11 18:19:21 UTC

*** This bug has been marked as a duplicate of bug 687514 ***
Comment 3 bugs.reporter 2019-06-11 22:09:57 UTC
emerge --info
Portage 2.3.66 (python 3.6.8-final-0, default/linux/amd64/17.0/desktop, gcc-8.2.0, glibc-2.29-r2, 4.19.8-gentoo x86_64)
=================================================================
System uname: Linux-4.19.8-gentoo-x86_64-Intel-R-_Core-TM-_i3-4130T_CPU_@_2.90GHz-with-gentoo-2.6
KiB Mem:     3708096 total,     46892 free
KiB Swap:    4194300 total,   4001532 free
Timestamp of repository gentoo: Tue, 11 Jun 2019 21:30:01 +0000
Head commit of repository gentoo: dcf95f5a9856420c70ed55a77d2ab5eec7959c76
sh bash 5.0_p7
ld GNU ld (Gentoo 2.31.1 p7) 2.31.1
ccache version 3.7.1 [disabled]
app-shells/bash:          5.0_p7::gentoo
dev-lang/perl:            5.28.2-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.4.8-r1::gentoo, 3.5.7::gentoo, 3.6.8::gentoo, 3.7.3::gentoo
dev-util/ccache:          3.7.1::gentoo
dev-util/cmake:           3.14.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.17::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r6::gentoo, 2.32-r1::gentoo
sys-devel/gcc:            8.2.0-r6::gentoo, 9.1.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-metamanifest: yes
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-max-age: 24

Installed sets: @audio, @doc, @editors, @file, @fonts, @games, @gfx, @gui, @hs, @im, @lang, @lib, @mail, @misc, @ml, @network, @portage, @py, @shell, @sys, @themes, @tui, @utils, @vcs, @video, @vim, @www, @x11
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write y --keep-going y --quiet-build y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs candy collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cjk cli consolekit crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg lcms ldap libnotify libtirpc mad mmx mng mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt5 readline sdl seccomp spell sse sse2 ssl ssse3 startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vim-syntax vorbis wxwidgets x264 xattr xcb xinerama xml xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-2" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_5 python3_6 python3_7 pypy pypy3" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 4 bugs.reporter 2019-06-11 22:12:06 UTC
Thanks Brian, `emerge --info` above and this is `ls -ld {,/usr}/lib{,32,64}`

# ls -ld {,/usr}/lib{,32,64}
lrwxrwxrwx   1 root root      5 May 15 14:56 /lib -> lib64
drwxr-xr-x   3 root root   4096 May 15 14:57 /lib32
drwxr-xr-x  15 root root  12288 May 15 15:00 /lib64
lrwxrwxrwx   1 root root      5 Sep 10  2014 /usr/lib -> lib64
drwxr-xr-x  54 root root 110592 May 15 16:01 /usr/lib32
drwxr-xr-x 302 root root 184320 May 15 16:17 /usr/lib64