Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 687468 - sys-devel/gcc-7.3.0-r3 fails to build after profile change to 17.1
Summary: sys-devel/gcc-7.3.0-r3 fails to build after profile change to 17.1
Status: RESOLVED DUPLICATE of bug 685348
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-05 18:50 UTC by Thomas Albers
Modified: 2019-06-06 06:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of emerge --info (emerge-info,6.40 KB, text/plain)
2019-06-05 18:51 UTC, Thomas Albers
Details
build log (gcc-build-logs.tar.bz2,477.00 KB, application/x-bzip2)
2019-06-05 18:53 UTC, Thomas Albers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Albers 2019-06-05 18:50:59 UTC
After changing the profile to from 17.0 to 17.1 (default/linux/amd64/17.1/desktop) rebuilding the gcc-7.3.0-r3 fails. gcc-8.3.0 could be built.

pythia /home/ta # emerge -pqv '=sys-devel/gcc-7.3.0-r3::gentoo'
[ebuild   R   ] sys-devel/gcc-7.3.0-r3  USE="cxx fortran (multilib) nls nptl openmp pch (pie) sanitize ssp vtv (-altivec) -cilk -debug -doc (-fixed-point) -go -graphite (-hardened) (-jit) (-libssp) -mpx -objc -objc++ -objc-gc -pgo -regression-test -vanilla"

pythia /home/ta # emerge -1 gcc:7.3.0
...
libtool: link: /usr/x86_64-pc-linux-gnu/bin/ar rc .libs/libquadmath.a  math/x2y2m1q.o math/isinf_nsq.o math/acoshq.o math/fmodq.o math/acosq.o math/frexpq.o math/rem_pio2q.o math/asinhq.o math/hypotq.o math/remainderq.o math/asinq.o math/rintq.o math/atan2q.o math/isinfq.o math/roundq.o math/atanhq.o math/isnanq.o math/scalblnq.o math/atanq.o math/j0q.o math/scalbnq.o math/cbrtq.o math/j1q.o math/signbitq.o math/ceilq.o math/jnq.o math/sincos_table.o math/complex.o math/ldexpq.o math/sincosq.o math/copysignq.o math/lgammaq.o math/sincosq_kernel.o math/coshq.o math/llroundq.o math/sinhq.o math/cosq.o math/log10q.o math/sinq.o math/cosq_kernel.o math/log1pq.o math/sinq_kernel.o math/erfq.o math/logq.o math/sqrtq.o math/expm1q.o math/lroundq.o math/tanhq.o math/expq.o math/modfq.o math/tanq.o math/fabsq.o math/nanq.o math/tgammaq.o math/finiteq.o math/nextafterq.o math/truncq.o math/floorq.o math/powq.o math/fmaq.o math/logbq.o math/cacoshq.o math/cacosq.o math/casinhq.o math/casinq.o math/catanhq.o math/catanq.o math/cimagq.o math/conjq.o math/cprojq.o math/crealq.o math/fdimq.o math/fmaxq.o math/fminq.o math/ilogbq.o math/llrintq.o math/log2q.o math/lrintq.o math/nearbyintq.o math/remquoq.o math/ccoshq.o math/cexpq.o math/clog10q.o math/clogq.o math/csinq.o math/csinhq.o math/csqrtq.o math/ctanq.o math/ctanhq.o printf/addmul_1.o printf/add_n.o printf/cmp.o printf/divrem.o printf/flt1282mpn.o printf/fpioconst.o printf/lshift.o printf/mul_1.o printf/mul_n.o printf/mul.o printf/printf_fphex.o printf/printf_fp.o printf/quadmath-printf.o printf/rshift.o printf/submul_1.o printf/sub_n.o strtod/strtoflt128.o strtod/mpn2flt128.o strtod/tens_in_limb.o
libtool: link: /usr/x86_64-pc-linux-gnu/bin/ranlib .libs/libquadmath.a
libtool: link: ( cd ".libs" && rm -f "libquadmath.la" && ln -s "../libquadmath.la" "libquadmath.la" )
make[3]: Leaving directory '/var/tmp/portage/sys-devel/gcc-7.3.0-r3/work/build/x86_64-pc-linux-gnu/libquadmath'
make[2]: Leaving directory '/var/tmp/portage/sys-devel/gcc-7.3.0-r3/work/build/x86_64-pc-linux-gnu/libquadmath'
make[1]: Leaving directory '/var/tmp/portage/sys-devel/gcc-7.3.0-r3/work/build'
make: *** [Makefile:22523: bootstrap-lean] Error 2
 * ERROR: sys-devel/gcc-7.3.0-r3::gentoo failed (compile phase):
 *   emake failed
Comment 1 Thomas Albers 2019-06-05 18:51:36 UTC
Created attachment 578952 [details]
Output of emerge --info
Comment 2 Thomas Albers 2019-06-05 18:53:00 UTC
Created attachment 578954 [details]
build log
Comment 3 Kiwon Um 2019-06-05 21:02:45 UTC
The same error to me:
"fatal error: sys/ustat.h: No such file or directory"
glibc doesn't seem to have this file anymore.
Comment 4 Jonas Stein gentoo-dev 2019-06-05 22:03:11 UTC

*** This bug has been marked as a duplicate of bug 643302 ***
Comment 5 Thomas Albers 2019-06-05 22:14:14 UTC
I suspect it's a duplicate of bug 685348
Comment 6 Andreas K. Hüttel gentoo-dev 2019-06-06 06:12:40 UTC

*** This bug has been marked as a duplicate of bug 685348 ***