Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 686202 - media-libs/gegl-0.3.26 and 0.3.34 : test-svg-abyss failed
Summary: media-libs/gegl-0.3.26 and 0.3.34 : test-svg-abyss failed
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sergey Torokhov
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2019-05-18 09:08 UTC by Alexey
Modified: 2020-05-25 02:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,905.09 KB, text/plain)
2019-05-18 09:08 UTC, Alexey
Details
emerge --info (file_686202.txt,19.50 KB, text/plain)
2019-05-18 09:09 UTC, Alexey
Details
new build.log (build.log,945.61 KB, text/x-log)
2020-03-06 08:39 UTC, Alexey
Details
ls -lR in work/ (filelist.txt,134.23 KB, text/plain)
2020-03-06 08:44 UTC, Alexey
Details
build.log (0.3.34, ppc64) (gegl-0.3.34:20200407-211908.log,881.22 KB, text/plain)
2020-04-07 23:17 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey 2019-05-18 09:08:46 UTC
Created attachment 577162 [details]
build.log

PASS test-scaled-blit                                                                                                                                                                                                                                                             
./test-svg-abyss                                                                                                                                                                                                                                                                  
testing abyss handling of svg blends                                                                                                                                                                                                                                              
....                                                                                                                                                                                                                                                                              
 svg:src-in ... FAIL                                                                                                                                                                                                                                                              
...                                                                                                                                                                                                                                                                               
 svg:src-atop ... FAIL                                                                                                                                                                                                                                                            
...                                                                                                                                                                                                                                                                              
FAIL test-svg-abyss
Comment 1 Alexey 2019-05-18 09:09:33 UTC
Created attachment 577164 [details]
emerge --info
Comment 2 Alexey 2019-05-18 10:47:19 UTC
> Component: Eclasses → Current packages

Oops, sorry, misclicked.
Comment 3 Sebastian Pipping gentoo-dev 2019-05-18 12:17:11 UTC
Confirming, fails on amd64.
Comment 4 ernsteiswuerfel 2019-07-15 14:59:09 UTC
Fails on ppc64 too.
Comment 5 Sergey Torokhov 2020-01-20 13:14:36 UTC
Does this issue still reproduce for you for gegl-0.3.34?
Comment 6 Alexey 2020-01-20 20:19:04 UTC
Yes, still fails on 0.3. Tests pass on 0.4.16 though.
Comment 7 Sergey Torokhov 2020-03-06 00:01:29 UTC
(In reply to Alexey from comment #6)
> Yes, still fails on 0.3. Tests pass on 0.4.16 though.

For me on gegl-0.3.34 this test is passed:

> ./test-svg-abyss
> testing abyss handling of svg blends
> ............
> PASS test-svg-abyss

Could you try to find additional test log file somewhere in /var/tmp/portage/media-libs/gegl-0.3.34/work/* ?
Comment 8 Alexey 2020-03-06 08:37:57 UTC
I don't know what has changed, but not this particular test passes, but the whole test suite still fails on 0.3.34:
/bin/sh: line 1: ../../examples/gegl-video: No such file or directory
Comment 9 Alexey 2020-03-06 08:38:09 UTC
*now
Comment 10 Alexey 2020-03-06 08:39:23 UTC
Created attachment 617274 [details]
new build.log
Comment 11 Alexey 2020-03-06 08:44:13 UTC
Created attachment 617276 [details]
ls -lR in work/
Comment 12 Sergey Torokhov 2020-03-07 22:31:26 UTC
(In reply to Alexey from comment #8)
> I don't know what has changed, but not this particular test passes, but the
> whole test suite still fails on 0.3.34:
> /bin/sh: line 1: ../../examples/gegl-video: No such file or directory

I have the same error now but I didn't notice it early because of another one later fail:

> 0 0.00% [vp8_v4l2m2m @ 0x5568d9fd1c10] Could not find a valid device
> [vp8_v4l2m2m @ 0x5568d9fd1c10] can't configure encoder
> could not open codec
> make[2]: *** [Makefile:613: vids] Error 1
> make[2]: Leaving directory '/var/tmp/portage/media-libs/gegl-0.3.34/work/gegl-0.3.34/tests/ff-load-save'
The first one is due to the 'gegl-video' executable is built only 'with-gexiv2' option is enabled
while as mentioned in gegl-0.3.34.ebuild (as mentioned by previous maintainer):

> - mrg is not in tree and gexiv2 support only has effect when mrg support is enabled

but enabling of 'gexiv2' option on test phase allows to built 'gegl-video' executable and then this part passed:

> Making check in ff-load-save
> make[2]: Entering directory '/var/tmp/portage/media-libs/gegl-0.3.34-r2/work/gegl-0.3.34/tests/ff-load-save'
> GEGL_PATH=../../operations ../../examples/frame-counter \
>            --video-codec mpeg4 --video-bit-rate 128 mpeg4-128kb.avi
> for a in *.avi *.mp4 *.ogv ;do \
>             GEGL_PATH=../../operations ../../examples/gegl-video \
>             $a -s 74 -e 74 -of $a- ;\
>         done
> frames: 74 - 74


But as this option is disabled for build without USE="test" (or FEATURES="test") and therethore isn't used in provided package
I see no reason to fix compilation instead of disabling this part of test.


-------

The second error seems due to my hardware just doesn't support vp8 hardware encoding
(intel core i3 550).
As I know vp8 hardware support is presented for intel since Broadwell (2014 year),
I didn't find if it's support by AMD CPUs.
I also think about disable this part of test.


P.S. 
I still didn't never run OpenCL tests as it isn't enabled on my system :(
Comment 13 ernsteiswuerfel 2020-04-07 23:17:56 UTC
Created attachment 631220 [details]
build.log (0.3.34, ppc64)

Same on ppc64.