Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 685952 - sci-electronics/eagle-7.7.0 should depend on =dev-libs/openssl-1.0*:* instead of :0
Summary: sci-electronics/eagle-7.7.0 should depend on =dev-libs/openssl-1.0*:* instead...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks:
 
Reported: 2019-05-14 14:04 UTC by Christian Schmidt
Modified: 2019-05-14 14:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for eagle-7.7.0.ebuild (eagle-7.7.0.ebuild.patch,312 bytes, patch)
2019-05-14 14:04 UTC, Christian Schmidt
Details | Diff
Patch for eagle-7.6.0.ebuild (eagle-7.6.0.ebuild.patch,312 bytes, patch)
2019-05-14 14:05 UTC, Christian Schmidt
Details | Diff
Patch for eagle-7.4.0.ebuild (eagle-7.4.0.ebuild.patch,312 bytes, patch)
2019-05-14 14:05 UTC, Christian Schmidt
Details | Diff
Patch for eagle-7.3.0.ebuild (eagle-7.3.0.ebuild.patch,312 bytes, patch)
2019-05-14 14:05 UTC, Christian Schmidt
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Schmidt 2019-05-14 14:04:19 UTC
Created attachment 576646 [details, diff]
Patch for eagle-7.7.0.ebuild

Eagle is a binary package that is linked against openssl-1.0. It thus will need the compatibility version on ~amd64/~x86 systems, which have 

I have only tested the patched 7.7.0 version, but I'll add patches for all existing ebuilds for convenience (though I am not sure if all versions are worth keeping).

Poly-C suggested on IRC that these alternatives are available instead of depending on dev-libs/openssl:1.0.0, which is reasonable especially for eagle-7.3.0, which is stable and thus shouldn't depend on it:

=dev-libs/openssl-1.0*:*
|| ( dev-libs/openssl:1.0.0 =dev-libs/openssl-1.0*:0 )

As grknight suggested the second term might cause issues with dependency resolving, I chose the former.
Comment 1 Christian Schmidt 2019-05-14 14:05:05 UTC
Created attachment 576648 [details, diff]
Patch for eagle-7.6.0.ebuild
Comment 2 Christian Schmidt 2019-05-14 14:05:29 UTC
Created attachment 576650 [details, diff]
Patch for eagle-7.4.0.ebuild
Comment 3 Christian Schmidt 2019-05-14 14:05:53 UTC
Created attachment 576652 [details, diff]
Patch for eagle-7.3.0.ebuild