Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 685064 - dev-util/valgrind-3.14.0 USE='mpi' - libmpiwrap.c: In function ‘showTy’: libmpiwrap.c:281:19: error: expected expression before ‘_Static_assert’
Summary: dev-util/valgrind-3.14.0 USE='mpi' - libmpiwrap.c: In function ‘showTy’: libm...
Status: RESOLVED DUPLICATE of bug 683778
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-04 20:37 UTC by ernsteiswuerfel
Modified: 2019-05-05 00:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (valgrind-3.14.0:20190504-200816.log,287.92 KB, text/x-log)
2019-05-04 20:37 UTC, ernsteiswuerfel
Details
emerge --info (file_685064.txt,5.91 KB, text/plain)
2019-05-04 22:02 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2019-05-04 20:37:33 UTC
Created attachment 575186 [details]
build.log

[...]
In file included from /usr/include/mpi.h:38,
                 from libmpiwrap.c:116:
libmpiwrap.c: In function ‘showTy’:
libmpiwrap.c:281:19: error: expected expression before ‘_Static_assert’
    else if (ty == MPI_UB)             fprintf(f,"UB");
                   ^~~~~~
libmpiwrap.c:282:19: error: expected expression before ‘_Static_assert’
    else if (ty == MPI_LB)             fprintf(f,"LB");
                   ^~~~~~
libmpiwrap.c: In function ‘extentOfTy’:
libmpiwrap.c:462:8: warning: implicit declaration of function ‘PMPI_Type_extent’; did you mean ‘MPI_Type_extent’? [-Wimplicit-function-declaration]
    r = PMPI_Type_extent(ty, &n);
        ^~~~~~~~~~~~~~~~
        MPI_Type_extent
In file included from /usr/include/mpi.h:38,
                 from libmpiwrap.c:116:
libmpiwrap.c: In function ‘walk_type’:
libmpiwrap.c:736:17: error: expected expression before ‘_Static_assert’
       if (ty == MPI_LB || ty == MPI_UB)
                 ^~~~~~
make[2]: *** [Makefile:653: libmpiwrap_ppc32_linux_so-libmpiwrap.o] Error 1
Comment 1 ernsteiswuerfel 2019-05-04 22:02:03 UTC
Created attachment 575222 [details]
emerge --info
Comment 2 Arfrever Frehtes Taifersar Arahesis 2019-05-05 00:12:10 UTC

*** This bug has been marked as a duplicate of bug 683778 ***