Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 684884 - x11-misc/shared-mime-info without LFS - update-mime-database will silently fail on (at least qemu, maybe also chroot) 32bit versions running against a 64bit kernel
Summary: x11-misc/shared-mime-info without LFS - update-mime-database will silently fa...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-lfs
  Show dependency tree
 
Reported: 2019-05-01 14:56 UTC by David Flogeras
Modified: 2019-05-02 15:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Flogeras 2019-05-01 14:56:48 UTC
See blocker parent bug.  Basically, due to changes in glibc, update-mime-database will silently fail on (at least qemu, maybe also chroot) 32bit versions running against a 64bit kernel.

I tested this by adding 'flag-o-matic', then calling 'append-lfs-flags' in src_configure().  Without that, the mime database files are empty without any warning.

Reproducible: Always
Comment 1 Larry the Git Cow gentoo-dev 2019-05-01 15:51:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=82f9268b82645f711f349f656c4e2b5520bdbc5e

commit 82f9268b82645f711f349f656c4e2b5520bdbc5e
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2019-05-01 15:51:04 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2019-05-01 15:51:04 +0000

    x11-misc/shared-mime-info: enable LFS
    
    Closes: https://bugs.gentoo.org/684884
    Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 .../shared-mime-info-1.10-r1.ebuild                | 58 ++++++++++++++++++++++
 1 file changed, 58 insertions(+)
Comment 2 Larry the Git Cow gentoo-dev 2019-05-02 15:37:44 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=82829612a8463a037daa81d0390f37b3e02cc672

commit 82829612a8463a037daa81d0390f37b3e02cc672
Author:     Mike Gilbert <floppym@gentoo.org>
AuthorDate: 2019-05-02 15:37:21 +0000
Commit:     Mike Gilbert <floppym@gentoo.org>
CommitDate: 2019-05-02 15:37:21 +0000

    x11-misc/shared-mime-info: ensure LFS workaround is removed
    
    Bug: https://bugs.gentoo.org/684884
    Package-Manager: Portage-2.3.62_p4, Repoman-2.3.12_p87
    Signed-off-by: Mike Gilbert <floppym@gentoo.org>

 x11-misc/shared-mime-info/shared-mime-info-1.10-r1.ebuild | 10 ++++++++--
 1 file changed, 8 insertions(+), 2 deletions(-)