Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 684070 - app-emulation/sen-0.6.1 : [TEST] pluggy.manager.PluginValidationError: Plugin relaxed could not be loaded: (pytest 4.4.0 (/usr/lib64/python3.6/site-packages), Requirement.parse( pytest<4,>=3 ))!
Summary: app-emulation/sen-0.6.1 : [TEST] pluggy.manager.PluginValidationError: Plugin...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Nelo-T. Wallus (ntnn)
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2019-04-21 21:55 UTC by Toralf Förster
Modified: 2019-04-21 21:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.79 KB, text/plain)
2019-04-21 21:55 UTC, Toralf Förster
Details
app-emulation:sen-0.6.1:20190421-212959.log (app-emulation:sen-0.6.1:20190421-212959.log,10.66 KB, text/plain)
2019-04-21 21:55 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,201.65 KB, text/plain)
2019-04-21 21:55 UTC, Toralf Förster
Details
environment (environment,108.26 KB, text/plain)
2019-04-21 21:55 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.41 KB, application/x-bzip)
2019-04-21 21:55 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,25.64 KB, application/x-bzip)
2019-04-21 21:55 UTC, Toralf Förster
Details
tests.tbz2 (tests.tbz2,9.41 KB, application/x-bzip)
2019-04-21 21:55 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-04-21 21:55:13 UTC
  File "/usr/lib64/python3.6/site-packages/pluggy/manager.py", line 280, in load_setuptools_entrypoints
    message="Plugin %r could not be loaded: %s!" % (ep.name, e),
pluggy.manager.PluginValidationError: Plugin 'relaxed' could not be loaded: (pytest 4.4.0 (/usr/lib64/python3.6/site-packages), Requirement.parse('pytest<4,>=3'))!
 * ERROR: app-emulation/sen-0.6.1::gentoo failed (test phase):
 *   pytest failed
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-no-multilib-hardened_libressl-test_20190417-081848

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.6
  [3]   python2.7 (fallback)


java-config:
The following VMs are available for generation-2:


emerge -qpvO app-emulation/sen
[ebuild  N    ] app-emulation/sen-0.6.1  USE="test" PYTHON_TARGETS="python3_6 -python3_5"
Comment 1 Toralf Förster gentoo-dev 2019-04-21 21:55:16 UTC
Created attachment 573742 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-04-21 21:55:19 UTC
Created attachment 573744 [details]
app-emulation:sen-0.6.1:20190421-212959.log
Comment 3 Toralf Förster gentoo-dev 2019-04-21 21:55:21 UTC
Created attachment 573746 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-04-21 21:55:24 UTC
Created attachment 573748 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-04-21 21:55:27 UTC
Created attachment 573750 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-04-21 21:55:30 UTC
Created attachment 573752 [details]
temp.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-04-21 21:55:33 UTC
Created attachment 573754 [details]
tests.tbz2