Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 683822 - sys-libs/glibc FEATURES=nostrip - ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../lib64/crti.o: bad reloc symbol index (0x475f0074 >= 0x11) for offset 0x5f5f7472617473 in section `_ranges'
Summary: sys-libs/glibc FEATURES=nostrip - ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/...
Status: RESOLVED DUPLICATE of bug 666954
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-19 06:56 UTC by paradox_ptr
Modified: 2019-06-22 08:11 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description paradox_ptr 2019-04-19 06:56:05 UTC
Building glibc with nostrip FEATURE raises QA warning:
 * QA Notice: The following files contain writable and executable sections
 *  Files with such sections will not work properly (or at all!) on some
 *  architectures/operating systems.  A bug should be filed at
 *  https://bugs.gentoo.org/ to make sure the issue is fixed.
 *  For more information, see:
 *
 *    https://wiki.gentoo.org/wiki/Hardened/GNU_stack_quickstart
 *
 *  Please include the following list of files in your report:
 *  Note: Bugs should be filed for the respective maintainers
 *  of the package in question and not hardened@gentoo.org.
 * -AX --- --- usr/lib64/crti.o
 * !WX --- --- usr/lib64/crtn.o
 * !WX --- --- usr/lib64/libmcheck.a

Add gcc stops working after install:
$ g++ main.cpp
/usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../lib64/crti.o: bad reloc symbol index (0x475f0074 >= 0x11) for offset 0x5f5f7472617473 in section `_ranges'
/usr/lib/gcc/x86_64-pc-linux-gnu/8.2.0/../../../../lib64/crti.o: error adding symbols: Bad value
collect2: error: ld returned 1 exit status

2.28-r6 and 2.29-r2 confirmed to break in this way.
2.28-r5 works fine with nostrip.


Reproducible: Always

Steps to Reproduce:
1. Create /etc/portage/env/devel with
CFLAGS="${CFLAGS} -g"
FEATURES="${FEATURES} nostrip installsources"
2. Add glibc to devel in package.env
3. Rebuild glibc (2.28-r6 and 2.29-r2 confirmed)
4. Use gcc or emerge anything that needs gcc

Actual Results:  
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `...':
configure: error: C compiler cannot create executables
Comment 1 paradox_ptr 2019-04-19 06:57:24 UTC
> 2.28-r5 works fine with nostrip.
Actually, scratch that part.
I can not confirm nostrip with glibc has ever used to work.
Comment 2 Sergei Trofimovich gentoo-dev 2019-04-26 03:35:13 UTC
Please post your `emerge --info` output.
Comment 3 Sergei Trofimovich gentoo-dev 2019-06-22 08:11:27 UTC

*** This bug has been marked as a duplicate of bug 666954 ***