Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 683796 - kde-apps/ktp-call-ui - ninja: error: '/usr/lib/libtelepathy-farstream.so', needed by 'src/ktp-call-ui', missing and no known rule to make it
Summary: kde-apps/ktp-call-ui - ninja: error: '/usr/lib/libtelepathy-farstream.so', ne...
Status: RESOLVED DUPLICATE of bug 644538
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://github.com/TelepathyIM/telepa...
Whiteboard: solution: rebuild net-libs/telepathy-qt
Keywords:
: 687702 (view as bug list)
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-04-18 20:31 UTC by Alexey Shvetsov
Modified: 2020-07-01 22:04 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,6.98 KB, text/plain)
2019-04-18 20:32 UTC, Alexey Shvetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Shvetsov gentoo-dev 2019-04-18 20:31:49 UTC
kde-apps/ktp-call-ui wants to have /usr/lib/libtelepathy-farstream.so while it in /usr/lib64/libtelepathy-farstream.so
error: '/usr/lib/libtelepathy-farstream.so', needed by 'src/ktp-call-ui', missing and no known rule to make it


$ emerge --info kde-apps/ktp-call-ui
Portage 2.3.63 (python 3.6.8-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-8.3.0, glibc-2.29-r2, 5.0.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.0.1-gentoo-x86_64-Intel-R-_Core-TM-_i7-8700K_CPU_@_3.70GHz-with-gentoo-2.6
KiB Mem:    32692492 total,    645068 free
KiB Swap:   33554428 total,  33551612 free
Timestamp of repository gentoo: Thu, 18 Apr 2019 18:00:01 +0000
Head commit of repository gentoo: 6e7d509afb587df33950c1c26da3c11f6df3ba64
sh bash 5.0_p3-r1
ld GNU ld (Gentoo 2.32 p1) 2.32.0
app-shells/bash:          5.0_p3-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.0-r1::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.8::gentoo, 3.7.3::gentoo
dev-util/cmake:           3.14.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.17::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32::gentoo
sys-devel/gcc:            8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=haswell -mtune=haswell -mfpmath=sse -mavx2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.3/ext-active/ /etc/php/cgi-php7.3/ext-active/ /etc/php/cli-php7.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=haswell -mtune=haswell -mfpmath=sse -mavx2"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe -march=haswell -mtune=haswell -mfpmath=sse -mavx2"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance buildpkg candy config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles ipc-sandbox merge-sync metadata-transfer multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync webrsync-gpg xattr"
FFLAGS="-O2 -pipe -march=haswell -mtune=haswell -mfpmath=sse -mavx2"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"
LINGUAS="ru en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo caps cdda cdr cli crypt cups cxx dbus declarative dri dts dvd dvdr elogind emboss encode exif fam ffmpeg flac fortran gdbm gif glamor gmp gpm gstreamer iconv icu ipv6 jpeg kde kipi kwallet lcms ldap libnotify libtirpc lm_sensors lzma mad mng mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit postscript ppds pulseaudio qml qt5 readline sdl seccomp semantic-desktop speex spell sqlite ssl startup-notification svg tcl tcpd theora threads tiff tk truetype udev udisks unicode upnp upower usb v4l vaapi vdpau vim-syntax vorbis wayland widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics libinput" KERNEL="linux" L10N="ru en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" QEMU_SOFTMMU_TARGETS="x86_64" QEMU_USER_TARGETS="arm aarch64" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

kde-apps/ktp-call-ui-18.12.3::gentoo was built with the following:
USE="-debug" ABI_X86="(64)"
Comment 1 Alexey Shvetsov gentoo-dev 2019-04-18 20:32:08 UTC
Created attachment 573400 [details]
build.log
Comment 2 Alexey Shvetsov gentoo-dev 2019-04-18 20:45:21 UTC
Seems like issue caused after migration to 17.1 profiles.
I solve it by rebuilding net-libs/telepathy-qt
Comment 3 John Bowler 2019-06-07 16:58:08 UTC
Note that the rebuild of net-libs/telepathy-qt-0.9.7-r1 (in my case) does not create the library /usr/lib/libtelepathy-farstream.so; both before and after I see:

hippopopus ~ # equery belongs /usr/lib/libtelepathy-farstream.so
 * Searching for /usr/lib/libtelepathy-farstream.so ...
hippopopus ~ # ls /usr/lib/libtelepathy-farstream.so
ls: cannot access '/usr/lib/libtelepathy-farstream.so': No such file or directory

Nevertheless after an emerge -1v on the above package kde-apps/ktp-call-ui-19.04.2 builds just fine with the 17.1 profiles.
Comment 4 John Bowler 2019-06-07 17:08:39 UTC
Should block 506276, but I think a bug wrangler has to do that.
Comment 5 Andreas Sturmlechner gentoo-dev 2019-06-09 10:47:18 UTC
*** Bug 687702 has been marked as a duplicate of this bug. ***
Comment 6 Mathy Vanvoorden 2019-08-18 19:36:18 UTC
Can confirm, rebuilding telepathy-qt manually fixed it
Comment 7 Andreas Sturmlechner gentoo-dev 2020-07-01 22:04:42 UTC
It is probably time to consolidate this with the parent bug.

*** This bug has been marked as a duplicate of bug 644538 ***