Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 682780 - dev-python/pypy - [translation:ERROR] UnsupportedFieldExc: unexpected array(struct(struct))
Summary: dev-python/pypy - [translation:ERROR] UnsupportedFieldExc: unexpected array(s...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2019-04-07 01:58 UTC by Alex Orange
Modified: 2019-04-26 16:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info '=dev-python/pypy-7.1.0::gentoo' (info,5.99 KB, text/plain)
2019-04-07 01:58 UTC, Alex Orange
emerge -pqv '=dev-python/pypy-7.1.0::gentoo' (pqv,144 bytes, text/plain)
2019-04-07 01:58 UTC, Alex Orange
environment (environment,96.53 KB, text/plain)
2019-04-07 02:02 UTC, Alex Orange
build.log (build.log.gz,34.05 KB, application/gzip)
2019-04-07 18:47 UTC, Alex Orange

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Orange 2019-04-07 01:58:12 UTC
Created attachment 572118 [details]
emerge --info '=dev-python/pypy-7.1.0::gentoo'

This appears to be only for pypy (vs pypy3) and I can actually replicate the problem.
Comment 1 Alex Orange 2019-04-07 01:58:25 UTC
Created attachment 572120 [details]
emerge -pqv '=dev-python/pypy-7.1.0::gentoo'
Comment 2 Alex Orange 2019-04-07 02:02:28 UTC
Created attachment 572122 [details]
Comment 3 Alex Orange 2019-04-07 02:04:10 UTC
Can't upload the build.log file because I'm getting "408 Request timed out" with the following message:

Request Timeout

Server timeout waiting for the HTTP request from the client.
Apache Server at Port 443

I've tried gzipping it and it's only about 35k, so I'm not sure why it won't upload.
Comment 4 Alex Orange 2019-04-07 18:47:41 UTC
Created attachment 572198 [details]
Comment 5 Alex Orange 2019-04-07 18:51:03 UTC
Oops, apparently it was a permissions issue that was preventing me from uploading. In other news: this was definitely a very repeatable bug, then I went and installed pypy3 while I was waiting (didn't actually expect it to work), then I came back and tried this again and it builds. I'm not sure what this issue is. It's affecting multiple people it seems (assuming this is the same as the pypy3 issue), but I'm not sure I can reproduce it. The only hints I can give is that installing pypy3 and coming back correlated with the problem going away. Also, this is a first install of pypy (i.e. it wasn't an upgrade).
Comment 6 Alex Orange 2019-04-26 16:56:28 UTC
I've got this on another machine. I'm checking that it's repeatable but this seems to be a problem.