Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 681720 - dev-libs/openssl-1.1.0j fails to emerge on musl due to a perl bug
Summary: dev-libs/openssl-1.1.0j fails to emerge on musl due to a perl bug
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
Depends on:
Blocks: 677012
  Show dependency tree
Reported: 2019-03-25 10:45 UTC by Marvin
Modified: 2019-06-13 00:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (,6.03 KB, text/plain)
2019-03-25 10:56 UTC, Marvin
Build log (build.log,572.88 KB, text/plain)
2019-03-25 10:57 UTC, Marvin
perl-5.28.1 upstream patches (perl-5.28.1-upstream.tar.xz,2.93 KB, application/x-xz)
2019-03-25 19:08 UTC, Jory A. Pratt
perl-5.26.3 upstream patches (perl-5.26.3-upstream.tar.xz,2.91 KB, application/x-xz)
2019-03-25 19:10 UTC, Jory A. Pratt

Note You need to log in before you can comment on or make changes to this bug.
Description Marvin 2019-03-25 10:45:56 UTC
Emerging openssl > 1.0.2 fails on musl systems due to a bug in the perl index function. The letter at the end gets truncated causing a version mismatch. This happens on every version later than 1.0.2.

Reproducible: Always

Steps to Reproduce:
1. Emerge openssl-1.1.* on musl
Actual Results:  
Emerge fails close to the end.

Expected Results:  
Emerge succeeds.

The index function shouldn't truncate the letter e.g. 1.1.0"j"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2019-03-25 10:49:03 UTC
Could you please attach the entire build log to this bug report?
Comment 2 Marvin 2019-03-25 10:56:32 UTC
Created attachment 570698 [details]
emerge --info
Comment 3 Marvin 2019-03-25 10:57:01 UTC
Created attachment 570700 [details]
Build log
Comment 4 Marvin 2019-03-25 12:13:47 UTC
This is the same bug, also tried with different gcc options and also with profile 42 and 43 (current).
Comment 5 Thomas Deutschmann (RETIRED) gentoo-dev 2019-03-25 18:55:55 UTC
Some other musl user I talked to were able to confirm problem.

Applying fixed the issue.
Comment 6 Jory A. Pratt gentoo-dev 2019-03-25 19:08:25 UTC
Created attachment 570790 [details]
perl-5.28.1 upstream patches
Comment 7 Jory A. Pratt gentoo-dev 2019-03-25 19:10:01 UTC
Created attachment 570792 [details]
perl-5.26.3 upstream patches

upstream patches that need to be applied to both 5.26.x and 5.28.x are being attached in a tarball. This should speed up the inclusion into the tree hopefully.
Comment 8 Marvin 2019-03-26 11:32:39 UTC
Can confirm, the patches solved it.
Comment 9 Jory A. Pratt gentoo-dev 2019-04-13 19:24:11 UTC
5.26.3/5.28.1 added to musl overlay with appropriate patches.
Comment 10 Jory A. Pratt gentoo-dev 2019-06-13 00:50:18 UTC
5.28.2 is now stable and works as expected with musl so closing.