Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 681234 - dev-tcltk/tcllib-1.19 : [TEST] make: *** [Makefile:<snip>: test_batch] Error 1
Summary: dev-tcltk/tcllib-1.19 : [TEST] make: *** [Makefile:<snip>: test_batch] Error 1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: TCL/TK Project
URL:
Whiteboard:
Keywords: TESTFAILURE
: 699118 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-03-22 07:38 UTC by Toralf Förster
Modified: 2019-11-02 21:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.84 KB, text/plain)
2019-03-22 07:38 UTC, Toralf Förster
Details
dev-tcltk:tcllib-1.19:20190321-215159.log.bz2 (dev-tcltk:tcllib-1.19:20190321-215159.log.bz2,130.98 KB, application/x-bzip)
2019-03-22 07:38 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,265.87 KB, text/plain)
2019-03-22 07:38 UTC, Toralf Förster
Details
environment (environment,18.80 KB, text/plain)
2019-03-22 07:38 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,17.18 KB, application/x-bzip)
2019-03-22 07:38 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,1.74 KB, application/x-bzip)
2019-03-22 07:38 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,138.77 KB, application/x-bzip)
2019-03-22 07:38 UTC, Toralf Förster
Details
emerge-info.txt (emerge-info.txt,15.15 KB, text/plain)
2019-06-28 16:50 UTC, Toralf Förster
Details
dev-tcltk:tcllib-1.19:20190628-103200.log.bz2 (dev-tcltk:tcllib-1.19:20190628-103200.log.bz2,130.76 KB, application/x-bzip)
2019-06-28 16:50 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,182.98 KB, text/plain)
2019-06-28 16:50 UTC, Toralf Förster
Details
environment (environment,17.99 KB, text/plain)
2019-06-28 16:50 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,15.89 KB, application/x-bzip)
2019-06-28 16:50 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,1.75 KB, application/x-bzip)
2019-06-28 16:50 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,138.24 KB, application/x-bzip)
2019-06-28 16:50 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-03-22 07:38:07 UTC
#Errors      0

make: *** [Makefile:85: test_batch] Error 1
emake failed
 * ERROR: dev-tcltk/tcllib-1.19::gentoo failed (test phase):
 *   Failed to run 'emake test_batch'

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-desktop_test_20190313-190226

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
  [3]   pypy3 (fallback)

Available Rust versions:
  [1]   rust-bin-1.32.0 *
  [2]   rust-1.32.0
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.10.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO dev-tcltk/tcllib
[ebuild  N    ] dev-tcltk/tcllib-1.19  USE="test -examples"
Comment 1 Toralf Förster gentoo-dev 2019-03-22 07:38:11 UTC
Created attachment 570292 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-03-22 07:38:14 UTC
Created attachment 570294 [details]
dev-tcltk:tcllib-1.19:20190321-215159.log.bz2
Comment 3 Toralf Förster gentoo-dev 2019-03-22 07:38:17 UTC
Created attachment 570296 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2019-03-22 07:38:20 UTC
Created attachment 570298 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2019-03-22 07:38:23 UTC
Created attachment 570300 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-03-22 07:38:26 UTC
Created attachment 570302 [details]
logs.tbz2
Comment 7 Toralf Förster gentoo-dev 2019-03-22 07:38:29 UTC
Created attachment 570304 [details]
temp.tbz2
Comment 8 Larry the Git Cow gentoo-dev 2019-05-15 20:15:01 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b275765716178c97ab294eaf6199fd1b6af24b76

commit b275765716178c97ab294eaf6199fd1b6af24b76
Author:     Tupone Alfredo <tupone@gentoo.org>
AuthorDate: 2019-05-15 20:14:41 +0000
Commit:     Tupone Alfredo <tupone@gentoo.org>
CommitDate: 2019-05-15 20:14:41 +0000

    dev-tcltk/tcllib: Fix some test with newer tcl
    
    Closes: https://bugs.gentoo.org/681234
    Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
    Package-Manager: Portage-2.3.62, Repoman-2.3.11

 dev-tcltk/tcllib/tcllib-1.19.ebuild | 12 ++++++++++++
 1 file changed, 12 insertions(+)
Comment 9 Toralf Förster gentoo-dev 2019-06-28 16:50:04 UTC
it is still an issue at unstable amd64 tinderbox image 17.1-systemd_libressl-test_20190623-103445
Comment 10 Toralf Förster gentoo-dev 2019-06-28 16:50:06 UTC
Created attachment 581278 [details]
emerge-info.txt
Comment 11 Toralf Förster gentoo-dev 2019-06-28 16:50:09 UTC
Created attachment 581280 [details]
dev-tcltk:tcllib-1.19:20190628-103200.log.bz2
Comment 12 Toralf Förster gentoo-dev 2019-06-28 16:50:11 UTC
Created attachment 581282 [details]
emerge-history.txt
Comment 13 Toralf Förster gentoo-dev 2019-06-28 16:50:14 UTC
Created attachment 581284 [details]
environment
Comment 14 Toralf Förster gentoo-dev 2019-06-28 16:50:16 UTC
Created attachment 581286 [details]
etc.portage.tbz2
Comment 15 Toralf Förster gentoo-dev 2019-06-28 16:50:19 UTC
Created attachment 581288 [details]
logs.tbz2
Comment 16 Toralf Förster gentoo-dev 2019-06-28 16:50:22 UTC
Created attachment 581290 [details]
temp.tbz2
Comment 17 Jeroen Roovers gentoo-dev 2019-11-02 07:40:09 UTC
*** Bug 699118 has been marked as a duplicate of this bug. ***
Comment 18 Larry the Git Cow gentoo-dev 2019-11-02 21:44:07 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ebf94e7aefeceab36a9245b1e91197a4df0ef4b3

commit ebf94e7aefeceab36a9245b1e91197a4df0ef4b3
Author:     Tupone Alfredo <tupone@gentoo.org>
AuthorDate: 2019-11-02 21:42:54 +0000
Commit:     Tupone Alfredo <tupone@gentoo.org>
CommitDate: 2019-11-02 21:43:46 +0000

    dev-tcltk/tcllib: Removing a test dependent on time
    
    Closes: https://bugs.gentoo.org/681234
    Package-Manager: Portage-2.3.76, Repoman-2.3.16
    Signed-off-by: Alfredo Tupone <tupone@gentoo.org>

 dev-tcltk/tcllib/files/tcllib-1.19-test.patch | 18 ++++++++++++++++++
 dev-tcltk/tcllib/tcllib-1.19.ebuild           |  2 ++
 2 files changed, 20 insertions(+)