Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 680862 - =net-misc/putty-0.71: saving config results in: putty: ./../conf.c:287: conf_get_int: Assertion `entry' failed.
Summary: =net-misc/putty-0.71: saving config results in: putty: ./../conf.c:287: conf_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jeroen Roovers (RETIRED)
URL:
Whiteboard:
Keywords: PATCH, REGRESSION
Depends on:
Blocks: 675524
  Show dependency tree
 
Reported: 2019-03-18 15:14 UTC by Lars Wendler (Polynomial-C)
Modified: 2019-03-18 16:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
files/putty-0.71-no-gssapi.patch (putty-0.71-no-gssapi.patch,8.33 KB, patch)
2019-03-18 16:11 UTC, Jeroen Roovers (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2019-03-18 15:14:23 UTC
> LANG=C gdb putty
GNU gdb (Gentoo 8.3.50.20190312 p1) 8.3.50.20190312-git
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://bugs.gentoo.org/>.
Find the GDB manual and other documentation resources online at:
    <http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from putty...
(gdb) run
Starting program: /usr/bin/putty 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[Detaching after fork from child process 19929]
[Detaching after fork from child process 19931]
Gtk-Message: 16:11:42.788: (for origin information, set GTK_DEBUG): failed to retrieve property `gtk-primary-button-warps-slider' of type `gboolean' from rc file value "((GString*) 0x5555556f77a0)" of type `gboolean'
[New Thread 0x7ffff0c31700 (LWP 19934)]
putty: ./../conf.c:287: conf_get_int: Assertion `entry' failed.

Thread 1 "putty" received signal SIGABRT, Aborted.
0x00007ffff74644bb in raise () from /lib64/libc.so.6
(gdb) bt full
#0  0x00007ffff74644bb in raise () from /lib64/libc.so.6
No symbol table info available.
#1  0x00007ffff744d515 in abort () from /lib64/libc.so.6
No symbol table info available.
#2  0x00007ffff744d3ef in ?? () from /lib64/libc.so.6
No symbol table info available.
#3  0x00007ffff745bea2 in __assert_fail () from /lib64/libc.so.6
No symbol table info available.
#4  0x00005555555703cb in conf_get_int (conf=conf@entry=0x55555574a170, primary=primary@entry=42) at ./../conf.c:287
        key = {primary = 42, secondary = {i = -2004318071, s = 0x88888889 <error: Cannot access memory at address 0x88888889>}}
        entry = <optimized out>
        __PRETTY_FUNCTION__ = "conf_get_int"
#5  0x000055555558beaf in save_open_settings (sesskey=sesskey@entry=0x555555b1d040, conf=conf@entry=0x55555574a170) at ./../settings.c:601
        i = <optimized out>
        p = <optimized out>
#6  0x000055555558d16b in save_settings (section=<optimized out>, conf=conf@entry=0x55555574a170) at ./../settings.c:533
        sesskey = 0x555555b1d040
        errmsg = 0x0
#7  0x000055555557398e in sessionsaver_handler (ctrl=<optimized out>, dlg=0x55555570dc80, data=0x55555574a170, event=<optimized out>) at ./../config.c:748
        errmsg = <optimized out>
        isdef = <optimized out>
        mbl = false
        conf = 0x55555574a170
        ssd = 0x55555574da80
#8  0x00005555555de85d in button_clicked (button=0x555555789660, data=0x55555570dc80) at ./../unix/gtkdlg.c:1227
        dp = 0x55555570dc80
        uc = <optimized out>
#9  0x00007ffff774dbbd in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#10 0x00007ffff77609a3 in ?? () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#11 0x00007ffff7769912 in g_signal_emit_valist () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#12 0x00007ffff7769f67 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#13 0x00007ffff7a8dcd5 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#14 0x00007ffff774dbbd in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#15 0x00007ffff7760b4e in ?? () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#16 0x00007ffff7769912 in g_signal_emit_valist () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#17 0x00007ffff7769f67 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#18 0x00007ffff7a8cc29 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#19 0x00007ffff7b31deb in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#20 0x00007ffff774dbbd in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#21 0x00007ffff77601e4 in ?? () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#22 0x00007ffff7768fa4 in g_signal_emit_valist () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#23 0x00007ffff7769f67 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
No symbol table info available.
#24 0x00007ffff7c47a9c in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#25 0x00007ffff7b3058c in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#26 0x00007ffff7b3097b in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
--Type <RET> for more, q to quit, c to continue without paging--c
#27 0x00007ffff79a569c in ?? () from /usr/lib64/libgdk-x11-2.0.so.0
No symbol table info available.
#28 0x00007ffff766b84e in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
No symbol table info available.
#29 0x00007ffff766bae8 in ?? () from /usr/lib64/libglib-2.0.so.0
No symbol table info available.
#30 0x00007ffff766bdf2 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
No symbol table info available.
#31 0x00007ffff7b2f9e7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#32 0x00005555555eb4de in main (argc=<optimized out>, argv=<optimized out>) at ./../unix/gtkmain.c:667
        conf = 0x55555574a170
        need_config_box = <optimized out>
        __PRETTY_FUNCTION__ = "main"
(gdb)


# emerge --info putty
Portage 2.3.62 (python 3.6.8-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-8.3.0, glibc-2.27-r6, 4.19.29 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.19.29-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.6
KiB Mem:    32940492 total,  15002628 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 18 Mar 2019 07:00:01 +0000
Head commit of repository gentoo: 9a180e538999b5bac3cde893a56cb335c3cc1ab0
Timestamp of repository poly-c: Mon, 18 Mar 2019 11:40:08 +0000
sh dash 0.5.10.2
ld GNU ld (Gentoo 2.32 p1) 2.32.0
app-shells/bash:          5.0_p2-r2::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.8::gentoo, 3.7.2::gentoo
dev-util/cmake:           3.14.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::poly-c
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.17::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.32::gentoo
sys-devel/gcc:            7.3.0-r6::gentoo, 8.3.0::poly-c
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /var/portage
    sync-type: rsync
    sync-uri: rsync://192.168.0.254/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: --new-compress
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

thabairne
    location: /var/lib/layman/thabairne
    masters: gentoo
    priority: 0

poly-c
    location: /var/lib/layman/poly-c
    masters: gentoo
    priority: 1

Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O1 -ggdb -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ConsoleKit /etc/X11/Sessions /etc/X11/app-defaults /etc/X11/xinit /etc/bonobo-activation /etc/ca-certificates /etc/ca-certificates.conf /etc/dbus-1 /etc/dconf /etc/env.d /etc/fonts /etc/fonts/fonts.conf /etc/foomatic /etc/games /etc/gconf /etc/gentoo-release /etc/gimp /etc/gnome-vfs-2.0 /etc/gre.d /etc/gtk-2.0 /etc/hp /etc/hsqldb /etc/htdig /etc/init.d /etc/iproute2 /etc/java-config-2 /etc/lftp /etc/logrotate.d /etc/ntop /etc/opt /etc/pango /etc/polkit-1 /etc/profile.d /etc/qt4 /etc/revdep-rebuild /etc/sandbox.d /etc/sasl2 /etc/sensors.d /etc/sgml /etc/sound /etc/ssl /etc/ssmtp /etc/t1lib /etc/terminfo /etc/usb_modeswitch.d /etc/vbox /etc/xdg /etc/xinetd.d /etc/xml"
CXXFLAGS="-march=native -O1 -ggdb -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --with-bdeps=y --misspell-suggestions=n --autounmask=n --quiet-build=n --binpkg-respect-use=n --verbose-slot-rebuilds=n --keep-going --fuzzy-search=n --dynamic-deps=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox keeptemp keepwork merge-sync multilib-strict network-sandbox news nostrip parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms sign strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
INSTALL_MASK="/etc/systemd /lib/systemd /lib32/systemd /lib64/systemd /usr/lib/systemd /usr/lib32/systemd /usr/lib64/systemd /etc/init.d/functions.sh /usr/lib64/firefox/browser/features/firefox@getpocket.com.xpi"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -Wl,--as-needed"
LINGUAS="de de@1901 en"
MAKEOPTS="-j4"
PKGDIR="/opt/portage/packages"
PORTAGE_BZIP2_COMMAND="lbzip2"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--new-compress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 branding brotli bzip2 cairo caps cdda cdr cli consolekit crypt cups cxx dbus debug declarative dts dvd dvdr emboss encode exif fam ffmpeg flac gcrypt gdbm gif glamor gmp gnutls gtk iconv icu idn inotify ipv6 jpeg jpeg2k kde kipi kwallet lame lcms libinput libnotify libtirpc lzma mad matroska midi mmap mmx mmxext mng mp3 mp4 mpeg mpfr multilib ncurses nls nptl nsplugin ogg opengl openmp opus pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt5 quicktime readline rtmp sdl seccomp slang spell split-usr sse sse2 ssl startup-notification svg theora threads tiff tinfo truetype twolame udev udisks unicode upower usb vaapi vcd vdpau vorbis vpx vulkan wayland webp widgets wxwidgets x264 x265 xattr xcb xcomposite xinerama xml xrandr xv xvid zlib zstd" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx f16c mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="libinput" KERNEL="linux" L10N="de de-1901 en" LIBREOFFICE_EXTENSIONS="pdfimport presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6 python3_7" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="radeon radeonsi"
Unset:  CC, CPPFLAGS, CTARGET, CXX, LANG, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

=================================================================
                        Package Settings
=================================================================

net-misc/putty-0.71::gentoo was built with the following:
USE="-doc -gssapi gtk gtk2 ipv6" ABI_X86="(64)"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2019-03-18 15:35:10 UTC
Looks like I missed a few CONF_gcc* in settings.c.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2019-03-18 16:11:06 UTC
Created attachment 569604 [details, diff]
files/putty-0.71-no-gssapi.patch

Does this fix USE=-gssapi for you?
Comment 3 Larry the Git Cow gentoo-dev 2019-03-18 16:13:52 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=1e1673a4b55e11f7ecc5aa57c6695d040a890d99

commit 1e1673a4b55e11f7ecc5aa57c6695d040a890d99
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2019-03-18 16:13:29 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2019-03-18 16:13:47 +0000

    net-misc/putty: Fix USE=-gssapi some more
    
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Bug: https://bugs.gentoo.org/680862
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 net-misc/putty/files/putty-0.71-no-gssapi.patch | 62 +++++++++++++++++++++++--
 1 file changed, 58 insertions(+), 4 deletions(-)
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2019-03-18 16:16:58 UTC
(In reply to Jeroen Roovers from comment #2)
> Created attachment 569604 [details, diff] [details, diff]
> files/putty-0.71-no-gssapi.patch
> 
> Does this fix USE=-gssapi for you?

Yes it does. Thank you very much.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2019-03-18 16:22:21 UTC
Patch sent upstream.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2019-03-18 16:28:02 UTC
May I request a revision bump for people who already installed 0.71-r0?
Comment 7 Larry the Git Cow gentoo-dev 2019-03-18 16:40:12 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=4be9d4591ac64e30820b18821654ef9b1018eb48

commit 4be9d4591ac64e30820b18821654ef9b1018eb48
Author:     Jeroen Roovers <jer@gentoo.org>
AuthorDate: 2019-03-18 16:39:38 +0000
Commit:     Jeroen Roovers <jer@gentoo.org>
CommitDate: 2019-03-18 16:40:07 +0000

    net-misc/putty: Revision bump to catch runtime failures
    
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=680862
    Signed-off-by: Jeroen Roovers <jer@gentoo.org>

 net-misc/putty/{putty-0.71.ebuild => putty-0.71-r1.ebuild} | 0
 1 file changed, 0 insertions(+), 0 deletions(-)