Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 680034 - sys-apps/sandbox-2.16: error: Unable to determine LIBC PATH (/lib64/libc.so.6")
Summary: sys-apps/sandbox-2.16: error: Unable to determine LIBC PATH (/lib64/libc.so.6")
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Sandbox (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Sandbox Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-11 13:09 UTC by Mike Lothian
Modified: 2019-03-13 10:12 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,12.82 KB, text/plain)
2019-03-11 13:09 UTC, Mike Lothian
Details
Config log (config.log,173.52 KB, text/plain)
2019-03-11 13:27 UTC, Mike Lothian
Details
0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch (0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch,1.92 KB, patch)
2019-03-11 21:35 UTC, Sergei Trofimovich
Details | Diff
v2-0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch (v2-0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch,2.11 KB, patch)
2019-03-11 21:59 UTC, Sergei Trofimovich
Details | Diff
v3-0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch (v3-0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch,2.15 KB, patch)
2019-03-12 07:28 UTC, Sergei Trofimovich
Details | Diff
sandbox-2.16-LIBC_PATH-gold.patch (sandbox-2.16-LIBC_PATH-gold.patch,1.79 KB, patch)
2019-03-13 07:31 UTC, Sergei Trofimovich
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Lothian 2019-03-11 13:09:20 UTC
Created attachment 568562 [details]
Build log

Portage 2.3.62 (python 3.7.2-final-0, default/linux/amd64/17.1/no-multilib, gcc-8.3.0, glibc-2.29, 4.4.0-17134-Microsoft x86_64)
=================================================================
System uname: Linux-4.4.0-17134-Microsoft-x86_64-Intel-R-_Core-TM-_i5-7300U_CPU_@_2.60GHz-with-gentoo-2.6
KiB Mem:     8312092 total,   2297268 free
KiB Swap:   25165824 total,  24741092 free
Head commit of repository gentoo: 541e96f90d3ff61c4cf1424028c102d0a3737e50

Head commit of repository FireBurn: 6cd9b9eaa4f07cc5ee45f2b6db487fc3e6c9c798

Head commit of repository gamerlay: b2b14ab99ae8273cf4cf1cf15458294663d444c5

Head commit of repository kde: 990ec2517004441e2dfce5efc446f67c7ce0d438

Timestamp of repository qt: Mon, 11 Mar 2019 07:26:53 +0000
Head commit of repository qt: 30791980f4abf846730fd86f2d83a516ec161d96

Timestamp of repository steam-overlay: Sun, 03 Mar 2019 22:04:16 +0000
Head commit of repository steam-overlay: 4bf299c79436ca643cd1fffc6f2b4084491b7696

Timestamp of repository x11: Sun, 03 Mar 2019 22:04:16 +0000
Head commit of repository x11: cdd9a63601ee9295028d533c8ed63fe646345cf5

sh bash 5.0_p2-r2
ld GNU gold (Gentoo 2.32 p1 2.32.0) 1.16
app-shells/bash:          5.0_p2-r2::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.28.0::gentoo
dev-lang/python:          2.7.16::gentoo, 3.6.8::gentoo, 3.7.2::gentoo
dev-util/cmake:           3.13.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.15::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.32::gentoo
sys-devel/gcc:            8.3.0::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 5.0-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo/gentoo
    priority: -1000

FireBurn
    location: /home/fireburn/Overlay
    sync-type: git
    sync-uri: https://github.com/FireBurn/Overlay
    sync-user: fireburn:users
    masters: gentoo

gamerlay
    location: /var/db/repos/gamerlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gamerlay.git
    masters: gentoo

kde
    location: /var/db/repos/kde
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/kde.git
    masters: gentoo

qt
    location: /var/db/repos/qt
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/qt.git
    masters: gentoo

steam-overlay
    location: /var/db/repos/steam-overlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/steam-overlay.git
    masters: gentoo

x11
    location: /var/db/repos/x11
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/x11.git
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.6/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O3 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write --with-bdeps y --complete-graph y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed"
LINGUAS="en_GB en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 apng berkdb bluetooth branding brightness-control bzip2 cairo cdda cdr cli connection-sharing consolekit crypt cups custom-cflags cxx dav1d dbus declarative default-gold dri dri3 drm dts egl emboss encode exif fam ffmpeg flac fortran gbm gdbm gif glamor gold googledrive gpm graphite gstreamer gtk harfbuzz http2 iconv icu ipv6 ithreads javafx jce jpeg kde kipi kwallet lcms ldap legacy-systray libkms libnotify libtirpc lm_sensors lzma lzo mad mng mp3 mp4 mpeg mpris mpx ncurses networkmanager nls nptl nsplugin ogg openal opengl openmp openssl opus pam pango pba pcre pdf pdfimport phonon plasma png policykit postproc ppds pulseaudio qml qt5 readline seccomp spell ssl startup-notification svg sync-plugin-portage systemd tcpd theora threads thumbnail tiff touchpad truetype udev udisks unicode upower usb user-session v4l vorbis vpx wayland webp widgets wifi wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias access_compat" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics libinput" KERNEL="linux" L10N="en-GB en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7 python2_7" RUBY_TARGETS="ruby25" USERLAND="GNU" VIDEO_CARDS="modesetting virgl" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Lothian 2019-03-11 13:10:16 UTC
lrwxrwxrwx 1 root root 12 Mar 11 10:36 /lib64/libc.so.6 -> libc-2.29.so
Comment 2 Andreas K. Hüttel gentoo-dev 2019-03-11 13:25:20 UTC
Does sandbox-2.15 configure correctly?
Comment 3 Andreas K. Hüttel gentoo-dev 2019-03-11 13:26:17 UTC
Also, please attach /var/tmp/portage/sys-apps/sandbox-2.16/work/sandbox-2.16-abi_x86_64.amd64/config.log
Comment 4 Mike Lothian 2019-03-11 13:27:57 UTC
Created attachment 568568 [details]
Config log
Comment 5 Mike Lothian 2019-03-11 13:32:26 UTC
sandbox 2.15 configures, builds and installs just fine
Comment 6 Andrei Slavoiu 2019-03-11 19:48:07 UTC
I just hit the same issue. Using ld.gold as well. Builds fine with ld.bfd.
Comment 7 Sergei Trofimovich gentoo-dev 2019-03-11 21:23:32 UTC
This likely broke at
    https://gitweb.gentoo.org/proj/sandbox.git/commit/?id=3c001036637930152c038d084334d9a7311ffc6e

The 'try_link -Wl,--verbose && grep -q attempt libctest.log' does not trigger for you because gold (or other binutils version?) has uppercase 'Attempt':

> /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: Attempt to open /lib64/libc.so.6 succeeded

and falls back to lld handling. Should be easy to tweak.
Comment 8 Sergei Trofimovich gentoo-dev 2019-03-11 21:35:13 UTC
Created attachment 568738 [details, diff]
0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch

0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch is a tweak to restore gold handling.
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-03-11 21:37:24 UTC
Maybe I'm silly but any reason not to match case-insensitively (or use [Aa]ttempt) instead?  'ttempt' looks a bit silly.
Comment 10 Sergei Trofimovich gentoo-dev 2019-03-11 21:47:31 UTC
(In reply to Michał Górny from comment #9)
> Maybe I'm silly but any reason not to match case-insensitively (or use
> [Aa]ttempt) instead?  'ttempt' looks a bit silly.

Both would work. "ttempt" matches closer to existing "$AWK '/ttempt to open/...". I can change grep to [Aa] (m4 will make it a bit uglier).
Comment 11 Sergei Trofimovich gentoo-dev 2019-03-11 21:59:59 UTC
Created attachment 568740 [details, diff]
v2-0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch

v2 matches explicitly on [Aa]ttempt in both 'grep' and 'awk' calls.
Comment 12 Xavier Miller gentoo-dev 2019-03-12 06:50:00 UTC
attachment #568740 [details, diff] is not working for me (ld.gold)
Comment 13 Mart Raudsepp gentoo-dev 2019-03-12 06:52:57 UTC
Did you add an eautoreconf call?
Comment 14 Xavier Miller gentoo-dev 2019-03-12 06:53:29 UTC
(In reply to Xavier Miller from comment #12)
> attachment #568740 [details, diff] [details, diff] is not working for me (ld.gold)

and attachment #568738 [details, diff] is not working too
Comment 15 Sergei Trofimovich gentoo-dev 2019-03-12 07:28:10 UTC
Created attachment 568746 [details, diff]
v3-0001-configure.ac-fix-libc.so.6-detection-on-ld.gold.patch

v3 fixed a 'lg.gold' typo in v2 noticed by Arfrever.
Comment 16 Sergei Trofimovich gentoo-dev 2019-03-13 07:31:08 UTC
Created attachment 568944 [details, diff]
sandbox-2.16-LIBC_PATH-gold.patch

an equivalent patch directly usable as /etc/portage/patches/sys-apps/sandbox/
Comment 17 Larry the Git Cow gentoo-dev 2019-03-13 10:09:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0286baaa56a2f94b5c29ea06963f91273a3ad770

commit 0286baaa56a2f94b5c29ea06963f91273a3ad770
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2019-03-13 10:08:08 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2019-03-13 10:09:23 +0000

    sys-apps/sandbox: Version bump
    
    Closes: https://bugs.gentoo.org/680034
    Package-Manager: Portage-2.3.62, Repoman-2.3.12
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 sys-apps/sandbox/Manifest                                     | 2 +-
 sys-apps/sandbox/{sandbox-2.16.ebuild => sandbox-2.17.ebuild} | 0
 2 files changed, 1 insertion(+), 1 deletion(-)
Comment 18 Larry the Git Cow gentoo-dev 2019-03-13 10:12:37 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/sandbox.git/commit/?id=18b1979734f57726c0a601ade0505c2e4615947d

commit 18b1979734f57726c0a601ade0505c2e4615947d
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2019-03-11 21:27:08 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2019-03-13 09:56:33 +0000

    configure.ac: fix libc.so.6 detection on ld.gold
    
    As reported by Mike Lothian below failed as:
        $ ./configure LDFLAGS=-fuse-ld=gold
    > checking libc path... configure: error: Unable to determine LIBC PATH (/lib64/libc.so.6")
    
    The regression happened in 3c0010366
    ("configure.ac: add lld detection support")
    where "attempt" keyword in verbose linker log was used as a hint
    to use bfd or gold output parser. Unfortunately ld.gold uses
    "Attempt" spelling.
    
    The change is to use the "[Aa]ttempt" substring matcher.
    Tweak the parser to also match on "[Aa]ttempt" explicitly.
    
    Tested on bfd, gold and lld.
    
    Reported-by: Mike Lothian
    Bug: https://bugs.gentoo.org/680034
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 configure.ac | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)