Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67913 - app-text/ghostscript-7.07.1-r7 has bad search path settings
Summary: app-text/ghostscript-7.07.1-r7 has bad search path settings
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Printing Team
Depends on:
Reported: 2004-10-17 11:40 UTC by dynamotwain
Modified: 2004-10-18 12:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description dynamotwain 2004-10-17 11:40:38 UTC
This ebuild causes ghostscript to be installed with a search path of
instead of /usr/share/ghostscript/7.07/lib.

As a result, gs cannot find, causing gs to abort upon every file I've tried to print.

Reproducible: Always
Steps to Reproduce:
1. Emerge cups and ghostscript. Add printers to cups
2. Set the cups log level to debug is cupsd.conf
3. Print a test page
4. Read the error log.

Actual Results:  
"ESP Ghostscript 7.07.1: Cannot find initialization file"
is in error log.

Expected Results:  
I'm expecting hundreds of pages of important documents to print.
Comment 1 dynamotwain 2004-10-17 11:48:57 UTC
As a temporary fix, one can just run the following hack:

> mkdir -p var/tmp/portage/ghostscript-7.07.1-r7/image//usr/share/ghostscript/7.07

> ln -s /usr/share/ghostscript/7.07/lib /var/tmp/portage/ghostscript-7.07.1-r7/image//usr/share/ghostscript/7.07/lib

as long as you don't routinely delete /var/tmp/portage.
Comment 2 Michele Noberasco (RETIRED) gentoo-dev 2004-10-17 14:48:40 UTC
I'm hit by this bug, too...
Comment 3 Heinrich Wendel (RETIRED) gentoo-dev 2004-10-18 11:13:08 UTC
please remerge ghostscript, that should fix the searchpath
Comment 4 Michele Noberasco (RETIRED) gentoo-dev 2004-10-18 12:28:10 UTC
Yup, problem solved :-)