Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 678914 - app-arch/star-??? version bump
Summary: app-arch/star-??? version bump
Status: RESOLVED DUPLICATE of bug 672060
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Shell Tools Herd Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-27 11:05 UTC by joerg.schilling
Modified: 2019-02-27 11:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joerg.schilling 2019-02-27 11:05:41 UTC
It seems that Gentoo ships star-1.5.3 which is 5 years old and meanwhile, a lot of new code has been added and a lof of problems have been fixed.

        Short overview for what changed since the last "stable" version: 
 
        -       Support for "infinitely" long path names has been added. 
 
        -       Support for comparing timestamps with nanosecond granularity 
 
        -       -secure-links has been made the default when extracting 
                archived (except when doing an incremental restore). 
 
        -       Added Support for NFSv4 ACLs on FreeBSD. Solaris has been 
                supported since 2013.

                BTW: Are there plans to add the standard NFSv4 ACLs to Linux?
 
        -       Added Support to archive SELinix attributes. 
 
        -       Allow to configure whether "star -fsync" is the default in 
                order to support filesystems that are slow with granted 
                transactions (like ZFS) or platforms that are genrally 
                slow with fsync() (like Linux). 
 
        -       Full UNICODE support has been added for tar headers. 
 
        -       Support for -zstd compression has been added. 
 
        -       Some rare FIFO problems have been fixed. 
                Note that we did recently run more than a billion tests to 
                verify the FIFO after we identified a method to trigger the 
                problem on Linux. 

Since many platforms today are interested in installing shared libraries instead of linking statically against project specific libs, it is recommended to use schilytools as the source since this is the only way to get all libraries in a consistent up-to date state.

BTW: There are other intreresting programs in schilytools that seem to miss on Gentoo, like e.g. the POSIX certified SunPro Make implementation, SCCS, ...
Comment 1 Jeroen Roovers gentoo-dev 2019-02-27 11:11:14 UTC
I suppose you will give us a URL for the tarballs next?
Comment 2 joerg.schilling 2019-02-27 11:18:48 UTC
OK, the download URL has been added three years ago and your version is older.

http://sourceforge.net/projects/schilytools/files/

The current version is schily-2019-02-18 updates are typically bi-weekly.
Comment 3 Jeroen Roovers gentoo-dev 2019-02-27 11:29:27 UTC

*** This bug has been marked as a duplicate of bug 672060 ***