Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 678774 - =net-analyzer/gspoof-3.2-r3 stabilization (was: net-analyzer/gspoof-3.2-r2 : configure: error:)
Summary: =net-analyzer/gspoof-3.2-r3 stabilization (was: net-analyzer/gspoof-3.2-r2 : ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: STABLEREQ
: 688026 (view as bug list)
Depends on:
Blocks: no-symlink-lib
  Show dependency tree
 
Reported: 2019-02-25 18:14 UTC by Toralf Förster
Modified: 2019-06-21 11:08 UTC (History)
2 users (show)

See Also:
Package list:
net-analyzer/gspoof-3.2-r3
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
emerge-info.txt (emerge-info.txt,16.22 KB, text/plain)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details
emerge-history.txt (emerge-history.txt,114.67 KB, text/plain)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details
environment (environment,84.58 KB, text/plain)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details
etc.portage.tbz2 (etc.portage.tbz2,11.33 KB, application/x-bzip)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details
logs.tbz2 (logs.tbz2,3.06 KB, application/x-bzip)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details
net-analyzer:gspoof-3.2-r2:20190224-224759.log (net-analyzer:gspoof-3.2-r2:20190224-224759.log,3.51 KB, text/plain)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details
temp.tbz2 (temp.tbz2,21.71 KB, application/x-bzip)
2019-02-25 18:14 UTC, Toralf Förster
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-02-25 18:14:18 UTC
checking whether x86_64-pc-linux-gnu-gcc needs -traditional... no
checking for /usr/lib/libnet.so... no
configure: error: 
Libnet-1.1.1 Packet Shaping Library is required!
Verify to have installed it and pass --with-libnet-prefix to configure.
Or download it from http://www.packetfactory.net/libnet 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-developer_libressl_20190222-111847

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-8.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby24 (with Rubygems)
  [2]   ruby25 (with Rubygems)
  [3]   ruby26 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.32.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.10.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO net-analyzer/gspoof
[ebuild  N    ] net-analyzer/gspoof-3.2-r2
Comment 1 Toralf Förster gentoo-dev 2019-02-25 18:14:20 UTC
Created attachment 566420 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-02-25 18:14:23 UTC
Created attachment 566422 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-02-25 18:14:26 UTC
Created attachment 566424 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-02-25 18:14:29 UTC
Created attachment 566426 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-02-25 18:14:32 UTC
Created attachment 566428 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-02-25 18:14:34 UTC
Created attachment 566430 [details]
net-analyzer:gspoof-3.2-r2:20190224-224759.log
Comment 7 Toralf Förster gentoo-dev 2019-02-25 18:14:37 UTC
Created attachment 566432 [details]
temp.tbz2
Comment 8 Pacho Ramos gentoo-dev 2019-06-15 07:00:15 UTC
*** Bug 688026 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2019-06-15 17:25:46 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d51d28c951e9be435fa4f5f94871ef6f1e655076

commit d51d28c951e9be435fa4f5f94871ef6f1e655076
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2019-06-15 17:25:28 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2019-06-15 17:25:39 +0000

    net-analyzer/gspoof: fix on libdir=lib64 systems, bug #678774
    
    ./configure script checked manually for /usr/lib/libnet.a presence.
    That does not work in libdir=lib64 systems like amd64. Let's drop
    the check intirely.
    
    Reported-by: Toralf Förster
    Bug: https://bugs.gentoo.org/678774
    Package-Manager: Portage-2.3.67, Repoman-2.3.14
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 net-analyzer/gspoof/files/gspoof-3.2-icon.patch   |  8 ++---
 net-analyzer/gspoof/files/gspoof-3.2-libdir.patch | 17 +++++++++
 net-analyzer/gspoof/gspoof-3.2-r3.ebuild          | 43 +++++++++++++++++++++++
 3 files changed, 64 insertions(+), 4 deletions(-)
Comment 10 Sergei Trofimovich gentoo-dev 2019-06-15 19:06:43 UTC
Let's stabilize it while at it. Arches, please stabilize
    =net-analyzer/gspoof-3.2-r3
for
    KEYWORDS="amd64 x86"
Comment 11 Agostino Sarubbo gentoo-dev 2019-06-18 11:10:59 UTC
amd64 stable
Comment 12 Agostino Sarubbo gentoo-dev 2019-06-21 11:08:02 UTC
x86 stable. Closing.