Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67834 - dev-lang/R-2.0.1-r1.ebuild (cjk, fortran)
Summary: dev-lang/R-2.0.1-r1.ebuild (cjk, fortran)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: Gentoo Science Related Packages
Keywords: EBUILD, InVCS
Depends on:
Reported: 2004-10-16 19:01 UTC by MATSUU Takuto (RETIRED)
Modified: 2005-04-29 11:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

R-2.0.0-r1.patch (R-2.0.0-r1.patch,2.43 KB, patch)
2004-10-16 19:04 UTC, MATSUU Takuto (RETIRED)
Details | Diff
R-2.0.1.ebuild (R-2.0.1.ebuild,4.31 KB, text/plain)
2005-01-08 22:36 UTC, MATSUU Takuto (RETIRED)
R-2.0.1.ebuild (R-2.0.1.ebuild,4.33 KB, text/plain)
2005-01-09 05:17 UTC, MATSUU Takuto (RETIRED)
R-2.0.1.ebuild (R-2.0.1.ebuild,4.33 KB, text/plain)
2005-02-12 10:19 UTC, MATSUU Takuto (RETIRED)
R-2.0.1-r1.diff (R-2.0.1-r1.diff,3.17 KB, patch)
2005-03-05 02:00 UTC, MATSUU Takuto (RETIRED)
Details | Diff
R-2.1.0.diff (R-2.1.0.diff,2.04 KB, patch)
2005-04-20 15:14 UTC, MATSUU Takuto (RETIRED)
Details | Diff
R-2.1.0-r1.diff (R-2.1.0-r1.diff,2.01 KB, patch)
2005-04-22 08:11 UTC, MATSUU Takuto (RETIRED)
Details | Diff
R-2.1.0-r1.diff (R-2.1.0-r1.diff,2.01 KB, patch)
2005-04-22 08:15 UTC, MATSUU Takuto (RETIRED)
Details | Diff
R-2.1.0-r1.diff (R-2.1.0-r1.diff,2.01 KB, patch)
2005-04-22 08:18 UTC, MATSUU Takuto (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description MATSUU Takuto (RETIRED) gentoo-dev 2004-10-16 19:01:13 UTC
Added i18n patch.
Fixed some use flags.
Comment 1 MATSUU Takuto (RETIRED) gentoo-dev 2004-10-16 19:04:56 UTC
Created attachment 41998 [details, diff]
Comment 2 Danny van Dyk (RETIRED) gentoo-dev 2004-12-09 14:45:29 UTC
This seems to be FIXED. (Patch already in CVS)
Comment 3 MATSUU Takuto (RETIRED) gentoo-dev 2005-01-08 22:35:11 UTC
It does NOT be FIXED.
Comment 4 MATSUU Takuto (RETIRED) gentoo-dev 2005-01-08 22:36:01 UTC
Created attachment 47999 [details]

new version.
Comment 5 Danny van Dyk (RETIRED) gentoo-dev 2005-01-09 02:43:41 UTC
Sorry. Didn't see that this is a tracker BUG. :-)
Comment 6 MATSUU Takuto (RETIRED) gentoo-dev 2005-01-09 05:17:01 UTC
Created attachment 48013 [details]
Comment 7 Mark Fenner 2005-02-06 08:20:14 UTC
The 2.0.1 ebuild posted here has some issue.  I have f77 in my USE and g77 is available at the command line.  However, this ebuild insists on some other Fortran satisfaction.

>>> emerge (1 of 1) dev-lang/R-2.0.1 to /
>>> md5 src_uri ;-) R-2.0.1.tar.gz
QA Notice: USE Flag '' not in IUSE for dev-lang/R-2.0.1
 * None of the needed Fortran Compilers (f77 f2c) is installed.
 * To install one of these, choose one of the following steps:
 * [2] emerge dev-lang/f2c

!!! ERROR: dev-lang/R-2.0.1 failed.
!!! Function need_fortran, Line 99, Exitcode 0
!!! Install a Fortran Compiler !
!!! If you need support, post the topmost build error, NOT this status message.
Comment 8 MATSUU Takuto (RETIRED) gentoo-dev 2005-02-12 10:19:25 UTC
Created attachment 51070 [details]
Comment 9 M. Edward Borasky 2005-02-12 13:32:14 UTC
I believe the "f77" USE flag has been removed and the "fortran" USE flag has been added. In any event, R-2.0.1 builds just fine from the CRAN source on my machine. 

R-2.0.1 has been available for some time, and Portage needs an ebuild for it. While you're at it, I'm not sure the "f2c" Fortran to C option to build R is viable any more. I can check with the R folks to be sure, but nobody I know builds R with any Fortran other than the one out of gcc.

If you're really interested in tracking R with the latest "stable" code, there is a source tarball on CRAN with the latest patches. The URI is

This has all the latest R bugfixes at any point in time and is updated daily.

Also, I highly recommend all Gentoo developers who work with/on dev-lang/R read the document at

This is the only place where R gotchas like "lapack" being deprecated are documented.
Comment 10 Björn Michaelsen 2005-02-20 05:39:19 UTC
R-2.0.0 fails to install here witha sandbox violation:
mkdir -p -- /usr/lib/R/afm
ACCESS DENIED  mkdir:     /usr/lib/R/afm

bjoern@lord ~ % emerge info
Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.3.5, glibc-, 2.6.10-rc3 i686)
System uname: 2.6.10-rc3 i686 AMD Athlon(tm) XP 2400+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.1.3-r1,dev-lang/python-2.2.3-r5,dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb 20 2005, 13:42:38)]
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.1.3-r1, 2.2.3-r5, 2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/libtool:   1.5.10-r4
CFLAGS="-O2 -march=athlon-xp -mmmx -m3dnow -fomit-frame-pointer -fforce-addr -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -mmmx -m3dnow -fomit-frame-pointer -fforce-addr -pipe"
FEATURES="autoaddcvs autoconfig candy ccache distlocks sandbox sfperms"
USE="x86 3dnow 3ds X Xaw3d aalib acpi acpi4linux alsa avi berkdb bitmap-fonts blas bzlib cdr crypt cscope cups curl dga dvd editor emboss encode esd f2c fam fbcon ffmpeg font-server foomaticdb fortran gdbm gif glut gstreamer gtk gtk2 guile imagemagick imlib java jikes joystick jpeg junit ldap libg++ libwww ltsp mad maildir mcal mikmod mmx mng motif mozilla moznocompose moznoirc moznomail mozp3p mozsvg mozxmlterm mpeg mpeg4 nas ncurses network nls nptl nvidia offensive oggvorbis openal opengl oscar oss pam pcre pdflib perl physfs pic plotutils png ppds python readline rtc sasl sdl server slang softmmu spell sqlite sse ssl tcpd tetex tiff tools transcode truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vim-with-x xinerama xml xml2 xmms xsl xv xvid zlib"
Comment 11 M. Edward Borasky 2005-02-20 11:10:42 UTC
Warning: long story coming:

I ran into this last night myself. I was attempting to create an ebuild for R-2.0.1. So I unmerged R-2.0.0, created a Portage overlay directory, copied the R-2.0.0 ebuild into it, and renamed it R-2.0.1.ebuild. I looked at it and it didn't look like it needed any changes, so I went ahead and built the digest and manifest files with "ebuild". It found the source tarball on the CRAN archive just fine. But when I tried to emerge it, I got the same sandbox issue Bjorn just posted.

At this point, I figured I had messed things up somehow, so I disabled the Portage overlay in "make.conf" and tried to re-emerge R-2.0.0. That didn't work either; I got the same sandbox problems. Then I tried to "emerge inject" R; that didn't work either:

*** --inject has been deprecated.
*** If you manage a piece of software yourself, add it's name and
*** version (eg foo/bar-1.0) to /etc/portage/profile/package.provided.
*** If you want to prevent portage from upgrading a package, add it to
*** /etc/portage/package.mask prepending it with '>' (eg >foo/bar-1.0)
*** For more information on fine-grained portage control, please see
*** the portage man page.

So I did all that, then manually installed the latest patched R from the CRAN repository. All is well on the system now.


1. Did I mess up the Portage tree somehow, or is the sandbox violation something that's coming from the mirrors and needs to be fixed? I don't know enough about the guts of Portage to even begin looking for this answer. Until I saw Bjorn's post, my assumption was that I broke it, but now I'm not so sure.

2. Given all of the above, is my system still broken in a way I haven't yet realized?

I'm going to do an "emerge sync" later today, and if I get a chance I'll see if I can "emerge R" and downgrade back to the R-2.0.0 out of Portage, now that I know how to force an upgrade without confusing Portage.
Comment 12 Martin Mokrejš 2005-02-21 17:03:07 UTC
I have same problem on another host:

  pdIdnot                           text    html    latex   example
  pdTens                            text    html    latex   example
  place.knots                       text    html    latex   example
  plot.gam                          text    html    latex   example
  predict.gam                       text    html    latex   example
  print.gam                         text    html    latex
  residuals.gam                     text    html    latex
  s                                 text    html    latex   example
  smooth.construct                  text    html    latex   example
  step.gam                          text    html    latex   example
  summary.gam                       text    html    latex   example
  te                                text    html    latex   example          text    html    latex   example
  uniquecombs                       text    html    latex   example
  vis.gam                           text    html    latex   example
* DONE (mgcv)
make[2]: Leaving directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/src/library/Recommended'
make[1]: Leaving directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/src/library/Recommended'
>>> Test phase [not enabled]: dev-lang/R-2.0.0

>>> Install R-2.0.0 into /var/tmp/portage/R-2.0.0/image/ category dev-lang
make[1]: Entering directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/m4'
make[1]: Nothing to be done for `install'.
make[1]: Leaving directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/m4'
make[1]: Entering directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/tools'
make[1]: Nothing to be done for `install'.
make[1]: Leaving directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/tools'
make[1]: Entering directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/afm'
installing afm ...
mkdir -p -- /usr/lib/R/afm
ACCESS DENIED  mkdir:     /usr/lib/R/afm
mkdir: cannot create directory `/usr/lib/R/afm': Permission denied
make[1]: *** [installdirs] Error 1
make[1]: Leaving directory `/var/tmp/portage/R-2.0.0/work/R-2.0.0/afm'
make: *** [install] Error 1

!!! ERROR: dev-lang/R-2.0.0 failed.
!!! Function src_install, Line 93, Exitcode 2
!!! Installation Failed
!!! If you need support, post the topmost build error, NOT this status message.

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/tmp/sandbox-dev-lang_-_R-2.0.0-24133.log"

mkdir:     /usr/lib/R/afm

# ls -la /usr/lib/R/
total 124
drwxr-xr-x    3 root root    20 Feb 17 00:10 .
drwxr-xr-x  138 root root 69632 Feb 21 10:29 ..
drwxr-xr-x  150 root root  8192 Feb 17 00:10 library

Portage 2.0.51-r15 (default-linux/x86/2004.0, gcc-3.3.4, glibc-, 2.4.30-pre1-bk4 i686)
System uname: 2.4.30-pre1-bk4 i686 Intel(R) Xeon(TM) CPU 3.06GHz
Gentoo Base System version 1.6.9
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 18 2005, 20:07:19)]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.5, 1.4_p6, 1.8.5-r3, 1.9.4
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.4.22-r1
CFLAGS="-march=pentium4 -mcpu=pentium4 -mmmx -msse -msse2 -msse3 -O3 -fomit-frame-pointer -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -mcpu=pentium4 -mmmx -msse -msse2 -msse3 -O3 -fomit-frame-pointer -funroll-loops -pipe"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="x86 FFmpeg X Xaw3d aalib acpi afs alsa apache2 apm arts ati avi berkdb bidi bitmap-fonts caca cdparanoia cdr crypt cscope cups curl dba dga directfb divx divx4 divx4linux divx5 divx5linux doc dvb dvd dvdr dvdread emacs emacs-w3 emboss encode esd ethereal evo f77 faad faad2 fam fame fbcon ffmpeg flac flash font-server foomaticdb fortran fvwm fvwm2 g77 gb gcj gd gdbm ggi gif gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile i8x0 icc imagemagick imlib imlib2 innodb ipv6 java jpeg junit lcms leim libg++ libwww live lzo mad mcal mesa mikmod mmx mmx2 motif mozilla mpeg mule mysql ncurses network nls oggvorbis opengl oss pam pda pdflib perl php php4 plotutils png postgres ppds pthread pthreads python qt qtx quicktime readline rtc samba sdl slang slp spell sse sse2 sse3 ssl svga tcltk tcpd tetex theora thread threads tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 win32 winvidix wmf xml xml2 xmms xosd xv xvid xvmc zeo zlib video_cards_radeon"

Comment 13 MATSUU Takuto (RETIRED) gentoo-dev 2005-03-05 02:00:45 UTC
Created attachment 52707 [details, diff]
Comment 14 M. Edward Borasky 2005-03-26 04:55:18 UTC
R-2.1.0 is in the alpha/beta test cycle now and should be released some time in April. I don't have the exact dates handy, but I've been downloading and building the test releases on my Gentoo boxes for some time now without any incidents. As far as I know, the ebuild will just be a version bump, but I'll check the R-admin manual to make sure nothing has sneaked in. Here's the "release notes" as of March  23:

Comment 15 Marcus D. Hanwell (RETIRED) gentoo-dev 2005-04-20 11:31:16 UTC
OK, 2.1.0 is out now and I am testing it right now. Just rename of the most recent R-2.0.1 ebuild. Matsuu - do those patches still apply cleanly to the new sources? I don't speak much of anything but English and so would have a hard time doing any real testing.

If so I can integrate them into the version bump ebuild for 2.1.0. The new version seems to work well too.
Comment 16 MATSUU Takuto (RETIRED) gentoo-dev 2005-04-20 15:14:05 UTC
Created attachment 56786 [details, diff]

clean up ebuild.
Comment 17 MATSUU Takuto (RETIRED) gentoo-dev 2005-04-20 15:16:40 UTC
since 2.1.0, we do not need cjk patch :)
Comment 18 Marcus D. Hanwell (RETIRED) gentoo-dev 2005-04-20 16:45:46 UTC
2.1.0 is in CVS now - please test and give me your feedback. I have cleaned it up quite a bit (I think), and it works great here. There are quite a few changes though, so I would appreciate any feedback. Thanks matsuu for the revision suggestions - I think I did most of it but modified it to use cleaner syntax with some extra USE flags too.
Comment 19 M. Edward Borasky 2005-04-20 21:29:45 UTC
R-2.1.0 installed and executed correctly on an Athlon T-bird from Portage tonight. The official release was 18 April -- good work!!
Comment 20 MATSUU Takuto (RETIRED) gentoo-dev 2005-04-22 08:11:45 UTC
Created attachment 56923 [details, diff]
Comment 21 MATSUU Takuto (RETIRED) gentoo-dev 2005-04-22 08:13:08 UTC
from R-2.1.0/NEWS:

    o   Capabilities "bzip2", "GNOME, "libz" and "PCRE" are defunct.
    o   The GNOME GUI is unbundled, now provided as a package on CRAN.
Comment 22 MATSUU Takuto (RETIRED) gentoo-dev 2005-04-22 08:15:18 UTC
Created attachment 56924 [details, diff]
Comment 23 MATSUU Takuto (RETIRED) gentoo-dev 2005-04-22 08:18:09 UTC
Created attachment 56925 [details, diff]

sorry, typo
Comment 24 Marcus D. Hanwell (RETIRED) gentoo-dev 2005-04-29 11:54:19 UTC
Not sure what you diffed against - but I think I have updated it as indicated by hand... They really need to update their ./configure --help which still lists those options (not sure about the gnome one). I have applied the updates and bumped to -r1.

Seems to work just great here - please report on any issues you might have. They are quite minor changes with minimal affect on the ebuild anyway - just want to make sure the deps are still covered properly.