Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 677840 - mail-mta/opensmtpd-6.4.2_p1 version bump
Summary: mail-mta/opensmtpd-6.4.2_p1 version bump
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jason A. Donenfeld
URL: https://www.opensmtpd.org/archives/op...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-13 01:56 UTC by Stefan Strogin
Modified: 2019-08-20 00:00 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Strogin gentoo-dev 2019-02-13 01:56:30 UTC
Released on 2018-12-16, https://opensmtpd.org/announces/release-6.4.1.txt
Comment 1 Georgy Yakovlev gentoo-dev 2019-02-13 05:21:41 UTC
last time I checked newer versions only support libressl.  it will be problematic to bump for general crowd running openssl.

assigning to Jason
Comment 2 Stefan Strogin gentoo-dev 2019-02-13 17:02:29 UTC
Is this the cause of masking 6.4.0? If so, maybe 6.4.1 could stay masked as well?

Unfortunately I use libressl and didn't try to build opensmtpd with openssl.
Comment 3 Reuben Farrelly 2019-08-05 23:38:55 UTC
6.4.2p1 is out now too.  The fix in this release:

------

A reliability issue has been reported yesterday that allows a remote MTA
to crash OpenSMTPD by causing it to hit one of its sanity check and exit
with fatal(). Highly annoying but not dangerous.

------

I had to upgrade to at least 6.4.1p2 to build with the latest LibreSSL.

Note that upstream has posted recently that >= OpenSSL-1.1 should work now:

https://www.mail-archive.com/misc@opensmtpd.org/msg04432.html

So in theory this release should work for both LibreSSL and OpenSSL users.