Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 675742 - app-editors/visual-studio-code-bin-1.30.2 - Multiplatform Visual Studio Code from Microsoft
Summary: app-editors/visual-studio-code-bin-1.30.2 - Multiplatform Visual Studio Code ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL: https://code.visualstudio.com
Whiteboard:
Keywords: EBUILD, PullRequest
: 759634 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-17 22:02 UTC by Brad Laue
Modified: 2021-02-01 19:40 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
visual-studio-code-bin-1.30.2.ebuild (visual-studio-code-bin-1.30.2.ebuild,1.60 KB, text/plain)
2019-01-17 22:02 UTC, Brad Laue
Details
Microsoft-VSCode (Microsoft-VSCode,9.40 KB, text/plain)
2020-01-05 17:21 UTC, Vladimir Pavljuchenkov (SpiderX)
Details
code.appdata.xml (code.appdata.xml,947 bytes, application/xml)
2020-01-05 17:22 UTC, Vladimir Pavljuchenkov (SpiderX)
Details
code.desktop (code.desktop,458 bytes, application/x-desktop)
2020-01-05 17:23 UTC, Vladimir Pavljuchenkov (SpiderX)
Details
code-url-handler.desktop (code-url-handler.desktop,317 bytes, application/x-desktop)
2020-01-05 17:23 UTC, Vladimir Pavljuchenkov (SpiderX)
Details
metadata.xml (metadata.xml,722 bytes, application/xml)
2020-01-05 17:23 UTC, Vladimir Pavljuchenkov (SpiderX)
Details
visual-studio-code-bin-1.41.1.ebuild (visual-studio-code-bin-1.41.1.ebuild,3.85 KB, text/plain)
2020-01-05 17:24 UTC, Vladimir Pavljuchenkov (SpiderX)
Details
visual-studio-code-bin-1.51.1.ebuild (visual-studio-code-bin-1.51.1.ebuild,3.79 KB, text/plain)
2020-12-06 22:30 UTC, Vladimir Pavljuchenkov (SpiderX)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Laue 2019-01-17 22:02:24 UTC
Created attachment 561890 [details]
visual-studio-code-bin-1.30.2.ebuild

Hi Devs,

Please find attached an ebuild for Visual Studio Code 1.30.2 with support for the x86 and amd64 keywords.

Visual Studio Code is a source code editor developed by Microsoft for Windows, Linux and macOS. It includes support for debugging, embedded Git control, syntax highlighting, intelligent code completion, snippets, and code refactoring among other features, and is quite popular among developers.

I suggest this be placed under the app-editors category. This ebuild has no additional out of tree dependencies.

Regards,
Brad
Comment 1 Gaelan Steele 2019-09-01 00:18:54 UTC
The license here is wrong—the VS Code source is MIT, but the official binaries have a EULA [0].

[0]: https://code.visualstudio.com/license
Comment 2 Brad Laue 2019-10-17 13:47:52 UTC
Of note is the visual studio code ebuild in the dotnet overlay. May be worth collaborating with that person
Comment 3 Thomas Capricelli 2019-12-27 16:58:06 UTC
visual studio core is the tool to develop on the longan nano platform.
Comment 4 Vladimir Pavljuchenkov (SpiderX) 2020-01-05 17:21:44 UTC
Created attachment 602600 [details]
Microsoft-VSCode

ebuild license
Comment 5 Vladimir Pavljuchenkov (SpiderX) 2020-01-05 17:22:39 UTC
Created attachment 602602 [details]
code.appdata.xml
Comment 6 Vladimir Pavljuchenkov (SpiderX) 2020-01-05 17:23:03 UTC
Created attachment 602606 [details]
code.desktop
Comment 7 Vladimir Pavljuchenkov (SpiderX) 2020-01-05 17:23:30 UTC
Created attachment 602610 [details]
code-url-handler.desktop
Comment 8 Vladimir Pavljuchenkov (SpiderX) 2020-01-05 17:23:55 UTC
Created attachment 602612 [details]
metadata.xml
Comment 9 Vladimir Pavljuchenkov (SpiderX) 2020-01-05 17:24:32 UTC
Created attachment 602614 [details]
visual-studio-code-bin-1.41.1.ebuild
Comment 10 Marko Steinberger 2020-01-05 19:52:31 UTC
Hope you guys know that there is also an overlay ebuild available:

https://github.com/jorgicio/jorgicio-gentoo-overlay/tree/master/app-editors/vscode-bin

Works absolutely fine for me since more than a year.

Discussion ongoing since quite some time. Feel free to participate:

https://forums.gentoo.org/viewtopic.php?p=8385548#8385548
Comment 11 Thomas Capricelli 2020-04-08 01:14:37 UTC
The dotnet overlay is getting rusty, I now have warning all the time about:

!!! Repository 'dotnet' has sync-type attribute set to unsupported value: 'laymansync'

Could this ebuild be migrated to the official gentoo tree ?
Comment 12 Reva Denis 2020-10-29 13:16:39 UTC
What is current status of that?
Comment 13 Thomas Capricelli 2020-10-31 14:42:44 UTC
i keep on using app-editors/visual-studio-code from the dotnet overlay.
Comment 14 Thomas Capricelli 2020-11-02 19:39:35 UTC
Actually, i would really rather have VSCodium, the expurged version without MS non-free binary blobs. There are even some ebuilds lyring around.
Comment 15 Vladimir Pavljuchenkov (SpiderX) 2020-12-06 22:30:12 UTC
Created attachment 677104 [details]
visual-studio-code-bin-1.51.1.ebuild
Comment 16 Sam James archtester gentoo-dev Security 2020-12-13 04:45:28 UTC
*** Bug 759634 has been marked as a duplicate of this bug. ***
Comment 17 Larry the Git Cow gentoo-dev 2021-01-02 16:57:44 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/proj/guru.git/commit/?id=4e9ac517df5636a55d5f26b02db48378d20a9961

commit 4e9ac517df5636a55d5f26b02db48378d20a9961
Author:     Ross Charles Campbell <rossbridger.cc@gmail.com>
AuthorDate: 2021-01-02 16:13:06 +0000
Commit:     Ross Charles Campbell <rossbridger.cc@gmail.com>
CommitDate: 2021-01-02 16:13:14 +0000

    app-editors/vscodium-bin: New Package
    
    Bug: https://bugs.gentoo.org/675742
    Closes: https://github.com/gentoo/gentoo/pull/18733
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com>

 app-editors/vscodium-bin/Manifest                  |  3 ++
 .../vscodium-bin/files/codium-url-handler.desktop  | 12 +++++
 app-editors/vscodium-bin/files/codium.desktop      | 18 +++++++
 app-editors/vscodium-bin/metadata.xml              | 13 +++++
 .../vscodium-bin/vscodium-bin-1.52.1.ebuild        | 60 ++++++++++++++++++++++
 5 files changed, 106 insertions(+)
Comment 18 Larry the Git Cow gentoo-dev 2021-01-03 15:48:24 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/proj/guru.git/commit/?id=c9b686ac6825352c6b626ba8c9c9d91400114d94

commit c9b686ac6825352c6b626ba8c9c9d91400114d94
Author:     Ross Charles Campbell <rossbridger.cc@gmail.com>
AuthorDate: 2021-01-03 15:28:56 +0000
Commit:     Ross Charles Campbell <rossbridger.cc@gmail.com>
CommitDate: 2021-01-03 15:31:57 +0000

    app-editors/visual-studio-code-bin: New Package
    
    Closes: https://bugs.gentoo.org/675742
    Closes: https://github.com/gentoo/gentoo/pull/11674
    Package-Manager: Portage-3.0.12, Repoman-3.0.2
    Signed-off-by: Gino McCarty <onigino@protonmail.com>
    Signed-off-by: Ross Charles Campbell <rossbridger.cc@gmail.com>

 app-editors/visual-studio-code-bin/Manifest        |  3 +
 .../files/code-url-handler.desktop                 | 12 ++++
 .../visual-studio-code-bin/files/code.desktop      | 18 ++++++
 app-editors/visual-studio-code-bin/metadata.xml    | 23 +++++++
 .../visual-studio-code-bin-1.52.1.ebuild           | 73 ++++++++++++++++++++++
 licenses/Microsoft-VSCode                          | 41 ++++++++++++
 6 files changed, 170 insertions(+)
Comment 19 Thomas Capricelli 2021-01-09 02:45:28 UTC
Err.. not sure here. It doesn't appear in my tree, though that was 'commited' 6 days ago.
It's been tested on some arcane overalay ?
Comment 20 David Hallas 2021-02-01 19:40:37 UTC
(In reply to Thomas Capricelli from comment #19)
> Err.. not sure here. It doesn't appear in my tree, though that was
> 'commited' 6 days ago.
> It's been tested on some arcane overalay ?

I was wondering about the same thing, but it turns out that this was committed to the guru overlay, and not the main gentoo repository. To use the guru overlay you can add it using this layman command

layman -a guru

This made the package available for me!

Happy emerging!