Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 674696 - net-misc/iputils-20180629 USE='-* idn' depends on but does not use net-dns/libidn2
Summary: net-misc/iputils-20180629 USE='-* idn' depends on but does not use net-dns/li...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-06 16:28 UTC by Jeroen Roovers
Modified: 2019-01-07 01:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2019-01-06 16:28:40 UTC
>>> Compiling source in /home/jer/portage/net-misc/iputils-20180629/work/iputils-s20180629 ...
make -j10 USE_CAP=no USE_IDN=yes IPV4_DEFAULT=yes TARGETS=ping USE_CRYPTO=no USE_GCRYPT=no USE_NETTLE=no
x86_64-pc-linux-gnu-gcc -frecord-gcc-switches -g -pipe -O2 -Wall -march=amdfam10 -mtune=amdfam10 -Wno-comment -fno-strict-aliasing -Wstrict-prototypes -Wall -D_GNU_SOURCE  -c ping.c  -DUSE_IDN   -o ping.o
x86_64-pc-linux-gnu-gcc -frecord-gcc-switches -g -pipe -O2 -Wall -march=amdfam10 -mtune=amdfam10 -Wno-comment -fno-strict-aliasing -Wstrict-prototypes -Wall -D_GNU_SOURCE  -c ping_common.c  -DUSE_IDN   -o ping_common.o
x86_64-pc-linux-gnu-gcc -frecord-gcc-switches -g -pipe -O2 -Wall -march=amdfam10 -mtune=amdfam10 -Wno-comment -fno-strict-aliasing -Wstrict-prototypes -Wall -D_GNU_SOURCE  -c ping6_common.c  -DUSE_IDN   -o ping6_common.o
x86_64-pc-linux-gnu-gcc -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed  -frecord-gcc-switches -g -pipe -O2 -Wall -march=amdfam10 -mtune=amdfam10 -Wno-comment -fno-strict-aliasing -Wstrict-prototypes -Wall ping.o ping_common.o ping6_common.o  -lidn2  -lresolv -lm   -o ping
>>> Source compiled.

It seems to be doing something, but in the end it does not link against libidn2.
Comment 1 Jeroen Roovers gentoo-dev 2019-01-06 18:44:44 UTC
commit 37b39f45fc097f8be6e36bfcd0dcc6495c76ed0c
Author: Thomas Deutschmann <whissi@gentoo.org>
Date:   Mon Oct 30 19:40:06 2017 +0100

    net-misc/iputils: Update live ebuild

    Package-Manager: Portage-2.3.13, Repoman-2.3.4

diff --git a/net-misc/iputils/iputils-99999999.ebuild b/net-misc/iputils/iputils-99999999.ebuild
index 90fcf7f7d8a..84d809667e5 100644
--- a/net-misc/iputils/iputils-99999999.ebuild
+++ b/net-misc/iputils/iputils-99999999.ebuild
@@ -11,10 +11,7 @@ EAPI="6"

 inherit flag-o-matic toolchain-funcs fcaps

-PATCHES=(
-       "${FILESDIR}"/${PN}-99999999-tracepath46.patch
-       "${FILESDIR}"/${PN}-99999999-musl.patch
-)
+PATCHES=()

 if [[ ${PV} == "99999999" ]] ; then
        EGIT_REPO_URI="https://github.com/iputils/iputils.git"
@@ -33,7 +30,7 @@ SLOT="0"
 IUSE="+arping caps clockdiff doc gcrypt idn ipv6 libressl nettle +openssl rarpd rdisc SECURITY_HAZARD ssl static tftpd tracepath traceroute"

 LIB_DEPEND="caps? ( sys-libs/libcap[static-libs(+)] )
-       idn? ( net-dns/libidn[static-libs(+)] )
+       idn? ( net-dns/libidn2[static-libs(+)] )
        ipv6? ( ssl? (
                gcrypt? ( dev-libs/libgcrypt:0=[static-libs(+)] )
                nettle? ( dev-libs/nettle[static-libs(+)] )
Comment 2 Jeroen Roovers gentoo-dev 2019-01-06 18:47:49 UTC
commit 3ee18d29f9d2f245c8a9acda7a767edd247f7558
Author: Thomas Deutschmann <whissi@gentoo.org>
Date:   Wed Jul 11 01:38:13 2018 +0200

    net-misc/iputils: bump to v20180629

    Package-Manager: Portage-2.3.41, Repoman-2.3.9
Comment 3 Thomas Deutschmann gentoo-dev Security 2019-01-07 01:22:55 UTC
It happens in "niquery_option_subject_name_handler" (https://github.com/iputils/iputils/blob/s20180629/ping6_common.c#L441):

So USE="-* idn ipv6 ssl" is the trigger.

To solve this I think we need something like

REQUIRED_USE="idn? ( ipv6 ssl )"