Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 674192 - net-analyzer/dsniff-2.4_beta1-r10 with =>dev-libs/openssl-1.1.0 - ./sshcrypto.c:32:2: error: unknown type name 'des_key_schedule'
Summary: net-analyzer/dsniff-2.4_beta1-r10 with =>dev-libs/openssl-1.1.0 - ./sshcrypto...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2019-04-30
Assignee: Gentoo Netmon project
URL:
Whiteboard:
Keywords: PMASKED
: 588782 674904 (view as bug list)
Depends on:
Blocks: openssl-1.1
  Show dependency tree
 
Reported: 2018-12-31 18:36 UTC by Vincent-Xavier JUMEL
Modified: 2021-12-07 06:44 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge.info (emerge.info,22.01 KB, text/plain)
2018-12-31 18:40 UTC, Vincent-Xavier JUMEL
Details
build.log (build.log,30.42 KB, text/plain)
2018-12-31 18:42 UTC, Vincent-Xavier JUMEL
Details
Updates to dsniff ebuild (dsniff-2.4_beta1-r11.ebuild.patch,882 bytes, patch)
2019-01-18 01:52 UTC, Hank Leininger
Details | Diff
Updated libtirpc support patch. (2.4_beta1-rpc-r1.patch,1.39 KB, patch)
2019-01-18 01:53 UTC, Hank Leininger
Details | Diff
Fix config-file path broken by latest Debian patches (2.4_beta1-sharedir.patch,1.09 KB, patch)
2019-01-18 01:53 UTC, Hank Leininger
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent-Xavier JUMEL 2018-12-31 18:36:34 UTC
./ssh.c: In function 'SSH_accept':
./ssh.c:246:26: error: dereferencing pointer to incomplete type 'RSA' {aka 'struct rsa_st'}
  put_bn(ssh->ctx->servkey->e, &p);  /* servkey exponent */
                          ^~
make: *** [Makefile:76: ssh.o] Error 1
 * ERROR: net-analyzer/dsniff-2.4_beta1-r10::gentoo failed (compile phase):
 *   emake failed
Comment 1 Vincent-Xavier JUMEL 2018-12-31 18:40:34 UTC
Created attachment 559186 [details]
emerge.info
Comment 2 Vincent-Xavier JUMEL 2018-12-31 18:42:00 UTC
Created attachment 559192 [details]
build.log
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2019-01-08 18:47:05 UTC
*** Bug 674904 has been marked as a duplicate of this bug. ***
Comment 4 Hank Leininger 2019-01-18 01:51:37 UTC
Current Debian packages include patches to build against OpenSSL 1.1.x.

Unfortunately they introduced an issue somewhat recently that breaks config file locations.

I will attach my current patch that fixes that, a fix to tirpc support, and a patch to the ebuild that applies the newer Debian patch set plus those fixes and drops one obsolete(?) patch.
Comment 5 Hank Leininger 2019-01-18 01:52:08 UTC
Created attachment 561904 [details, diff]
Updates to dsniff ebuild
Comment 6 Hank Leininger 2019-01-18 01:53:05 UTC
Created attachment 561906 [details, diff]
Updated libtirpc support patch.
Comment 7 Hank Leininger 2019-01-18 01:53:30 UTC
Created attachment 561908 [details, diff]
Fix config-file path broken by latest Debian patches
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-03-31 11:37:09 UTC
*** Bug 588782 has been marked as a duplicate of this bug. ***
Comment 9 Larry the Git Cow gentoo-dev 2019-03-31 11:40:02 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ea6d9d7c5f9ab634b394f2029b23d390af9c8f8d

commit ea6d9d7c5f9ab634b394f2029b23d390af9c8f8d
Author:     Michał Górny <mgorny@gentoo.org>
AuthorDate: 2019-03-31 11:39:27 +0000
Commit:     Michał Górny <mgorny@gentoo.org>
CommitDate: 2019-03-31 11:39:57 +0000

    package.mask: Last rite net-analyzer/dsniff
    
    Bug: https://bugs.gentoo.org/674192
    Signed-off-by: Michał Górny <mgorny@gentoo.org>

 profiles/package.mask | 7 +++++++
 1 file changed, 7 insertions(+)
Comment 10 Matthew Ogilvie 2019-04-07 02:37:56 UTC
Alternatives?

I occasionally use tcpkill (part of this package) to test how my own code handles an uncleanly reset TCP connection (as opposed to cleanly shutdown).

Some quick googling found a couple of potential alternatives:

http://killcx.sourceforge.net/
  - At first glance this looks promising, although it isn't
    in the main gentoo tree at this time.
  - Next time I need tcpkill functionality, I'll probably look
    here first.

http://www.digitage.co.uk/digitage/software/linux-security/cutter
  - Included in gentoo, but the web page has a huge disclaimer that it
    only works on intermediate routers/firewalls, not at local end points.

Does anyone have any thoughts about these or other alternatives for tcpkill (or if any users are using other parts of dsniff, anything for those parts...)?
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-05-02 18:54:35 UTC
Gone.
Comment 12 Larry the Git Cow gentoo-dev 2021-12-07 06:44:50 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ffd19f440039ff1c2b4e4e1234c1f9c89a7ae806

commit ffd19f440039ff1c2b4e4e1234c1f9c89a7ae806
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-12-07 02:56:16 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-12-07 06:44:25 +0000

    net-analyzer/dsniff: initial import (revival)
    
    Removed in 1aa904188ff115f14f6d5fac4e0483152a08ed37. Now
    using (substantial) Debian patchset.
    
    Closes: https://bugs.gentoo.org/643460
    Closes: https://bugs.gentoo.org/674192
    Closes: https://bugs.gentoo.org/571446
    Signed-off-by: Sam James <sam@gentoo.org>

 net-analyzer/dsniff/Manifest                       |   2 +
 net-analyzer/dsniff/dsniff-2.4_beta1_p30.ebuild    |  73 ++++++++++++++
 .../files/dsniff-2.4_beta1_p30-httppostfix.patch   |  21 +++++
 .../dsniff-2.4_beta1_p30-libdir-configure.patch    | 105 +++++++++++++++++++++
 .../files/dsniff-2.4_beta1_p30-respect-AR.patch    |  22 +++++
 net-analyzer/dsniff/metadata.xml                   |  17 ++++
 6 files changed, 240 insertions(+)