Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 674068 - sys-devel/llvm-7.1.0: stablereq
Summary: sys-devel/llvm-7.1.0: stablereq
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: LLVM support project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 666651 667854 669828 671266
Blocks: 664868 689510
  Show dependency tree
 
Reported: 2018-12-30 09:53 UTC by Michał Górny
Modified: 2019-07-28 09:34 UTC (History)
5 users (show)

See Also:
Package list:
sys-devel/llvm-common-7.1.0 amd64 arm arm64 x86 sys-devel/llvm-7.1.0 amd64 arm arm64 x86 sys-devel/llvmgold-7 amd64 arm arm64 x86 dev-python/lit-7.1.0 amd64 arm arm64 x86 dev-libs/libpfm-4.10.1 amd64 arm x86
Runtime testing required: No


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2018-12-30 09:53:52 UTC
Opening early as stabilization blocker tracker.
Comment 1 Matt Turner gentoo-dev 2019-03-11 17:45:59 UTC
mesa-18.3.x stabilization is going to be blocked by this. The bugs this depends on need to be reevaluated from the looks of them.
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-03-16 20:40:37 UTC
For the record, upstream has stated that 7.1.0 will be released shortly after 8.0.0.
Comment 3 Matt Turner gentoo-dev 2019-03-16 20:44:39 UTC
(In reply to Michał Górny from comment #2)
> For the record, upstream has stated that 7.1.0 will be released shortly
> after 8.0.0.

Thanks. FTR, I was wrong about the mesa version that will require this. It's mesa-19, not 18.3, though 18.3 would benefit from llvm-7 as well. :)
Comment 4 Jan Henke 2019-03-17 18:11:00 UTC
Please include dev-util/lldb in the stabilization. The ebuild is in tree for several LLVM releases already, but never got stabilized. It would be very helpful to have an alternative to sys-devel/gdb as stable ebuild in the tree.

LLDB is also used quite widely already, e.g. JetBrains CLion IDE ships a bundled version.
Comment 5 Joakim Tjernlund 2019-04-12 06:53:32 UTC
Have you seen this:
  https://bugs.llvm.org/show_bug.cgi?id=39427
Its an ABI incompat with gcc for 7.0.1
Comment 6 Stabilization helper bot gentoo-dev 2019-05-11 10:06:19 UTC
An automated check of this bug failed - repoman reported dependency errors (147 lines truncated): 

> dependency.bad sys-devel/llvm/llvm-7.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0) ['dev-libs/libpfm:=']
> dependency.bad sys-devel/llvm/llvm-7.1.0.ebuild: RDEPEND: amd64(default/linux/amd64/17.0) ['dev-libs/libpfm:=']
> dependency.bad sys-devel/llvm/llvm-7.1.0.ebuild: DEPEND: amd64(default/linux/amd64/17.0/desktop) ['dev-libs/libpfm:=']
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-05-11 11:23:35 UTC
amd64 stable
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-05-11 11:24:39 UTC
x86 stable
Comment 9 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-05-13 17:43:38 UTC
arm64 stable
Comment 10 Matt Turner gentoo-dev 2019-07-21 21:16:11 UTC
arm@: Ping...
Comment 11 Stabilization helper bot gentoo-dev 2019-07-22 14:01:42 UTC
An automated check of this bug failed - repoman reported dependency errors (61 lines truncated): 

> dependency.bad sys-libs/libcxx/libcxx-7.1.0.ebuild: DEPEND: arm(default/linux/arm/17.0) ['~sys-libs/libcxxabi-7.1.0[libunwind=,static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'sys-libs/libcxxrt[libunwind=,static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=sys-devel/clang-3.9.0']
> dependency.bad sys-libs/libcxx/libcxx-7.1.0.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['~sys-libs/libcxxabi-7.1.0[libunwind=,static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'sys-libs/libcxxrt[libunwind=,static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.badindev sys-libs/libcxx/libcxx-7.1.0.ebuild: DEPEND: arm(default/linux/arm/17.0/armv4) ['~sys-libs/libcxxabi-7.1.0[libunwind=,static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'sys-libs/libcxxrt[libunwind=,static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=sys-devel/clang-3.9.0']
Comment 12 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2019-07-22 14:23:39 UTC
I have no clue what you're doing but clang & co weren't targeted by this on arm.
Comment 13 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-07-28 09:33:54 UTC
arm stable