Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 673224 - app-text/docbook-xml-simple-dtd- - portage.exception.ParseError: "/usr/src/linux/.config", line 1838: Invalid token 'y' (not '=')
Summary: app-text/docbook-xml-simple-dtd- - portage.exception.ParseError: "/...
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Portage team
Keywords: InVCS
Depends on:
Blocks: 671498
  Show dependency tree
Reported: 2018-12-16 04:39 UTC by jplx
Modified: 2019-04-10 04:31 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (emerge_info.txt,6.67 KB, text/plain)
2018-12-16 04:40 UTC, jplx
Macbook Air emerge --info (emerge_info,5.73 KB, text/plain)
2018-12-16 04:44 UTC, jplx
Console history (console,48.70 KB, text/plain)
2018-12-16 04:47 UTC, jplx
Console output after typing CTRL-D, following the error (Console_after_CTRL-D,2.03 KB, text/plain)
2018-12-16 04:48 UTC, jplx
config file (config,161.48 KB, text/plain)
2018-12-16 04:48 UTC, jplx
emerge.log last ~300 lines (emerge.log,27.91 KB, text/plain)
2018-12-16 05:02 UTC, jplx

Note You need to log in before you can comment on or make changes to this bug.
Description jplx 2018-12-16 04:39:42 UTC
New install of "sakaki" gnome-wayland on an Apple MacBook Air. Failure during emerging gnome. It appears to be while emerging app-text/docbook-xml-simple-dtd-
I tried with and without parallelism.

Reproducible: Always

Steps to Reproduce:
1.MAKEOPTS="-j1" EMERGE_DEFAULT_OPTS="--jobs=1" emerge --ask --verbose gnome-base/gnome && echo "GNOME emerged OK" || echo "GNOME emerge not yet completed"
3.emerge --ask --verbose --keep-going gnome-base/gnome && echo "GNOME emerged OK" || echo "GNOME emerge not yet completed"
Actual Results:  
Console messages attached.

Expected Results:  
Normal emerge.

WHen the error message appeared, its last line was "pdb". After a while, I typed CTRL-D and got an additional output.
Comment 1 jplx 2018-12-16 04:40:58 UTC
Created attachment 557884 [details]
emerge --info
Comment 2 jplx 2018-12-16 04:42:30 UTC
Comment on attachment 557884 [details]
emerge --info

This a wrong emerge--info. Please discard
Comment 3 jplx 2018-12-16 04:44:04 UTC
Created attachment 557886 [details]
Macbook Air emerge --info

This is the correct emerge --info output on the Macbook Air failing the gnome emerge.
Comment 4 jplx 2018-12-16 04:44:59 UTC
Comment on attachment 557884 [details]
emerge --info

>Portage 2.3.0 (python 3.4.4-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r2, 4.5.2-aufs-r1 x86_64)
Comment 5 jplx 2018-12-16 04:46:29 UTC
Comment on attachment 557884 [details]
emerge --info

Wrong file. PLease discard.
Comment 6 jplx 2018-12-16 04:47:43 UTC
Created attachment 557888 [details]
Console history
Comment 7 jplx 2018-12-16 04:48:25 UTC
Created attachment 557890 [details]
Console output after typing CTRL-D, following the error
Comment 8 jplx 2018-12-16 04:48:48 UTC
Created attachment 557892 [details]
config file
Comment 9 jplx 2018-12-16 05:02:27 UTC
Created attachment 557894 [details]
emerge.log last ~300 lines
Comment 10 Larry the Git Cow gentoo-dev 2018-12-17 07:09:11 UTC
The bug has been referenced in the following commit(s):

commit d2e1c414c4cec97b1a2d3343d60016c100fe9062
Author:     Zac Medico <>
AuthorDate: 2018-12-17 06:35:28 +0000
Commit:     Zac Medico <>
CommitDate: 2018-12-17 06:44:24 +0000

    ExtractKernelVersion: use KeyValuePairFileLoader (bug 673224)
    Use KeyValuePairFileLoader to parse the kernel config and report errors
    without raising an exception. Silently handle empty settings like the
    CONFIG_UEVENT_HELPER_PATH= setting that triggered the ParseError reported
    in bug 673224.
    Signed-off-by: Zac Medico <>

 lib/portage/util/ | 17 +++++++++++++----
 1 file changed, 13 insertions(+), 4 deletions(-)
Comment 11 Zac Medico gentoo-dev 2018-12-17 07:11:28 UTC
Comment 12 jplx 2018-12-17 18:16:35 UTC
I am getting exactly the same error with eselect-cblas (dependency of gnome-wayland) as illustrated by the test here below:
(1) jplx-airgn2 ~ # emerge --ask --verbose =app-eselect/eselect-cblas-0.1::gentoo

 * IMPORTANT: 5 news items need reading for repository 'sakaki-tools'.
 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-cblas-0.1::gentoo  0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) app-eselect/eselect-cblas-0.1::gentoo
>>> Jobs: 0 of 1 complete, 1 running                Load avg: 0.18, 0.07, 0.02Exception in callback AsynchronousTask.wait()
handle: <Handle AsynchronousTask.wait()>
Traceback (most recent call last):
  File "/usr/lib64/python3.6/asyncio/", line 145, in _run
  File "/usr/lib64/python3.6/site-packages/_emerge/", line 84, in wait
  File "/usr/lib64/python3.6/site-packages/_emerge/", line 195, in _wait_hook
  File "/usr/lib64/python3.6/site-packages/_emerge/", line 79, in _start_with_metadata
    settings=self.settings, db=portdb)
  File "/usr/lib64/python3.6/site-packages/portage/package/ebuild/", line 529, in doebuild_environment
    os.path.join(mysettings['EROOT'], "usr/src/linux"))
  File "/usr/lib64/python3.6/site-packages/portage/proxy/", line 31, in __call__
    return result(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/portage/util/", line 74, in ExtractKernelVersion
    kernelconfig = getconfig(base_dir+"/.config")
  File "/usr/lib64/python3.6/site-packages/portage/util/", line 749, in getconfig
    raise ParseError(msg)
portage.exception.ParseError: "/usr/src/linux/.config", line 1838: Invalid token 'y' (not '=')
> /usr/lib64/python3.6/site-packages/portage/util/_eventloop/>None
-> pdb.set_trace()

--> Line 1838 of .config is:
Looks fine.
Comment 13 Zac Medico gentoo-dev 2018-12-17 19:26:31 UTC
I think this line is the trigger:


It will be fixed by, but you can change the line to this as a workaround:

Comment 14 jplx 2018-12-17 22:31:01 UTC
I made the change and ran:
emerge --ask --verbose --keep-going gnome-base/gnome && echo "GNOME emerged OK" || echo "GNOME emerge not yet completed"
Both docbook-xml-simple-dtd and eselect-cblas emerged and installed fine.
Still running with more than 300 packages to emerge and install for gnome-wayland. Looks fine so far. THANK YOU!
Comment 15 jplx 2018-12-19 19:04:23 UTC
I can confirm that the work-around did solve the problem. The emerge completed successfully. THANK YOU AGAIN!
Comment 16 Zac Medico gentoo-dev 2019-04-10 04:31:54 UTC
Fixed in portage-2.3.62.