Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 672894 - media-libs/harfbuzz-2.0.2 - configure:19835: error: glib support requested but glib-2.0 not found
Summary: media-libs/harfbuzz-2.0.2 - configure:19835: error: glib support requested bu...
Status: RESOLVED DUPLICATE of bug 500338
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-10 19:13 UTC by Tobias Leupold
Modified: 2018-12-12 10:55 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log.xz (config.log.xz,12.02 KB, application/x-xz)
2018-12-10 19:13 UTC, Tobias Leupold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Leupold 2018-12-10 19:13:08 UTC
Created attachment 557546 [details]
config.log.xz

Trying to build harfbuzz 2.0.2, the configure step fails with:

    checking for GLIB... no
    configure: error: glib support requested but glib-2.0 not found

although dev-libs/glib-2.56.2 is installed. Trying without distcc enabled and with MAKEOPTS="-j1" produces the same result.

Here's my emerge --info =media-libs/harfbuzz-2.0.2:

Portage 2.3.51 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-7.3.0, glibc-2.27-r6, 4.14.78-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.78-gentoo-x86_64-Intel-R-_Core-TM-_i5-4440_CPU_@_3.10GHz-with-gentoo-2.6
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 10 Dec 2018 11:00:01 +0000
Head commit of repository gentoo: 7319c4e904277ecc9ec7fb8f0e1e91dbfdd75546
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p5) 2.30.0
distcc 3.2rc1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.15::gentoo, 3.4.8::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.38.3::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.30-r4::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r6::gentoo
Repositories:

gentoo
    location: /var/portage/tree
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts: 
    sync-rsync-verify-jobs: 1

local
    location: /var/portage/local
    masters: gentoo
    priority: 0

Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=haswell -mmmx -mno-3dnow -msse -msse2 -msse3 -mssse3 -mno-sse4a -mcx16 -msahf -mmovbe -maes -mno-sha -mpclmul -mpopcnt -mabm -mno-lwp -mfma -mno-fma4 -mno-xop -mbmi -mbmi2 -mno-tbm -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mno-rtm -mno-hle -mrdrnd -mf16c -mfsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mxsave -mxsaveopt -mno-avx512f -mno-avx512er -mno-avx512cd -mno-avx512pf -mno-prefetchwt1 -mno-clflushopt -mno-xsavec -mno-xsaves -mno-avx512dq -mno-avx512bw -mno-avx512vl -mno-avx512ifma -mno-avx512vbmi -mno-clwb -mno-mwaitx -mno-clzero -mno-pku --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=haswell -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=haswell -mmmx -mno-3dnow -msse -msse2 -msse3 -mssse3 -mno-sse4a -mcx16 -msahf -mmovbe -maes -mno-sha -mpclmul -mpopcnt -mabm -mno-lwp -mfma -mno-fma4 -mno-xop -mbmi -mbmi2 -mno-tbm -mavx -mavx2 -msse4.2 -msse4.1 -mlzcnt -mno-rtm -mno-hle -mrdrnd -mf16c -mfsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mxsave -mxsaveopt -mno-avx512f -mno-avx512er -mno-avx512cd -mno-avx512pf -mno-prefetchwt1 -mno-clflushopt -mno-xsavec -mno-xsaves -mno-avx512dq -mno-avx512bw -mno-avx512vl -mno-avx512ifma -mno-avx512vbmi -mno-clwb -mno-mwaitx -mno-clzero -mno-pku --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -mtune=haswell -O2 -pipe"
DISTDIR="/var/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="        http://ftp.uni-erlangen.de/pub/mirrors/gentoo/  http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/      http://mirror.netcologne.de/gentoo/ "
LANG="de_DE.UTF-8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de de_DE"
MAKEOPTS="-j5"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify libtirpc mad mng mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qml qt5 readline sdl seccomp semantic-desktop spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="krita flow" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" L10N="de de_DE" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby23 ruby24" SANE_BACKENDS="plustek" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-12-11 09:11:48 UTC
Do you have sys-devel/crossdev package installed?
Comment 2 Tobias Leupold 2018-12-11 14:11:30 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #1)
> Do you have sys-devel/crossdev package installed?

Yes, I use distcc to build for other machines in my network and need crossdev toolchains for that.
Comment 3 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-12-11 14:53:44 UTC

*** This bug has been marked as a duplicate of bug 500338 ***
Comment 4 Tobias Leupold 2018-12-11 14:57:50 UTC
Well ... it's possible that this is a duplicate of that 2014 bug, but I still can't build the package ... so would you mind giving me a hint on how to fix this?
Comment 5 Tobias Leupold 2018-12-11 14:59:36 UTC
... or asking the other way round: Shouldn't the respective ebuild be changed so that it does select the proper toolchain if crossdev is installed?
Comment 6 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-12-12 10:16:23 UTC
I wonder how the ebuild should "fix" your toolchain that got messed up by another package. That simply isn't the job of any ebuild.
The crossdev package is to blame here and the fix needs to go into that package, not any other package that became broken because of a flawed crossdev package.
Comment 7 Tobias Leupold 2018-12-12 10:37:01 UTC
I'm sorry if I offended you, but I'm not a Gentoo dev – I simply installed a stable(!) package that apparently causes a build failure for another package. So – from the point of view of a stable end-user (is anybody running Gentoo an end-user?! ;-) – this bug is definitely not "resolved" because I still can't build harfbuzz 2.0.2 (interestingly, version 1.9.0 could be built without a problem!), and I have no idea how to do so.

I'd really like to help to fix this – in which way it may be necessary or possible! I cross-build for a Raspberry Pi, so I do need the crossdev toolchain.

Is there any way how to ship around this? Can I do something to help?
Comment 8 Lars Wendler (Polynomial-C) (RETIRED) gentoo-dev 2018-12-12 10:55:10 UTC
(In reply to Tobias Leupold from comment #7)
> I'm sorry if I offended you, but I'm not a Gentoo dev – I simply installed a
> stable(!) package that apparently causes a build failure for another
> package. 

Don't worry. I do not feel offended and in case my answer appeared to be a bit snarky, that was merely because I found your second request a bit strange.

> So – from the point of view of a stable end-user (is anybody
> running Gentoo an end-user?! ;-) – this bug is definitely not "resolved"
> because I still can't build harfbuzz 2.0.2 (interestingly, version 1.9.0
> could be built without a problem!), and I have no idea how to do so.
> 
> I'd really like to help to fix this – in which way it may be necessary or
> possible! I cross-build for a Raspberry Pi, so I do need the crossdev
> toolchain.

I haven't used crossdev in a very long time and thus cannot really help you there because of lack of expertise.

> Is there any way how to ship around this? Can I do something to help?

If I were in your situation I'd try to find out if _temporarily_ uninstalling crossdev would fix the issue.
For a final satisfying fix you should perhaps get in touch with our crossdev developers (crossdev@gentoo.org) or perhaps simply commenting on the bug even though it's from 2014.