Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 671112 - app-eselect/eselect-opencl with media-libs/mesa-18.2.4 fails to report mesa opencl profile
Summary: app-eselect/eselect-opencl with media-libs/mesa-18.2.4 fails to report mesa o...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-13 23:27 UTC by Bartosz Krzeszewski
Modified: 2020-09-12 21:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Krzeszewski 2018-11-13 23:27:17 UTC
After upgrade from media-libs/mesa-18.1.9 to media-libs/mesa-18.2.4 my monero mining software stoped to work so I starded to inspect what was the case. I found out that "eselect opencl list" dont report mesa profile. It shoult look like this:

eselect opencl list
Available OpenCL implementations:
  [1]   mesa
  [2]   ocl-icd *

but it was only ocl-icd. So I uninstalled dev-libs/amdgpu-pro-opencl-17.50.552542 to check what will happen but there was still "ocl-icd" profile in "eselect opencl list". I tryed clinfo and it was reporting mesa opencl implementation. So i downgrade mesa back to 18.1.9, installed amdgpu-pro-opencl and all is working fine again:

- xmr-stak (mining software) works
- eselect opencl list show both mesa and ocl-icd
- clinfo shows OpenCL 2.1 AMD-APP (2527.4)

 It looks like there is some problem in mesa 18.2 that is stopping amdgpu-pro-opencl to work.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2018-11-15 14:19:06 UTC

*** This bug has been marked as a duplicate of bug 670266 ***
Comment 2 Bartosz Krzeszewski 2018-11-15 19:04:50 UTC
Problem is that with mesa-18.2.4 I can't use OpenCL 2.1 AMD-APP. So maybe bug title is wrong but it is not a duplicate. How can I change to AMD-APP when there is only one ocl-icd and it defaults to MESA? Before when ocl-icd was selected it was using AMD-APP from amdgpu-pro-opencl. How can I do this now when there is onlu one ocl-icd (no ocl-icd form mesa and other ocl-icd from amdgpu-pro)?