Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 670250 - media-sound/lmms-1.2.0_rc4 - .../work/lmms-1.2.0-rc4/src/gui/EffectSelectDialog.cpp:127:34: error: invalid use of incomplete type 'class QHeaderView'
Summary: media-sound/lmms-1.2.0_rc4 - .../work/lmms-1.2.0-rc4/src/gui/EffectSelectDial...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-11-04 07:46 UTC by Tom
Modified: 2018-11-22 21:48 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
lmms-1.2.0_rc4-info.tar.gz (lmms-1.2.0_rc4-info.tar.gz,39.87 KB, application/gzip-compressed-tar)
2018-11-04 07:46 UTC, Tom
Details
lmms-1.2.0_rc4-qheaderview.patch (lmms-1.2.0_rc4-qheaderview.patch,258 bytes, patch)
2018-11-08 11:44 UTC, Samuel Bauer
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2018-11-04 07:46:03 UTC
Created attachment 554008 [details]
lmms-1.2.0_rc4-info.tar.gz

Hello,

compilation fails according to incomplete type QHeaderView,
while adding USE="fluidsynth" in order to be able to listen
and import midi files.

The attached archive holds all the requested information.

CU Tom
Comment 1 Samuel Bauer 2018-11-08 11:44:21 UTC
Created attachment 554508 [details, diff]
lmms-1.2.0_rc4-qheaderview.patch

The patch adds the required include.
Comment 2 Andreas Sturmlechner gentoo-dev 2018-11-08 16:01:26 UTC
Is this patch from upstream, or did you submit it upstream already?
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2018-11-08 16:13:27 UTC
Could also be a backport. lmms upstream is at version 1.2.0_rc7 but fails to roll sane source tarballs since _rc5:

https://github.com/LMMS/lmms/issues/4100
Comment 4 Samuel Bauer 2018-11-08 16:23:05 UTC
No this is not from upstream, I just recompiled everything and wanted lmms to compile fine. As it's just a missing header, I didn't check further.

I'll may send it, but I need to check this compile issue is still there in latest/live version. Feel free to send it upstream if you know it's still present.

If it's already fixed upstream, sorry for the noise here.
Comment 5 Andreas Sturmlechner gentoo-dev 2018-11-08 16:38:40 UTC
I tried rc6 and rc7, but in both versions upstream seems to have been unable to ship non-broken cmake files.
Comment 6 Andreas Sturmlechner gentoo-dev 2018-11-08 16:41:56 UTC
(In reply to Samuel Bauer from comment #4)
> If it's already fixed upstream, sorry for the noise here.
It's not noise since it is not fixed in any available portage version. :)

Reproduced independently of fluidsynth flag btw.
Comment 7 Samuel Bauer 2018-11-08 23:19:33 UTC
(In reply to Andreas Sturmlechner from comment #6)

> it is not fixed in any available portage version. :)
here lmms-9999 compiles and links fine, so I think the current issue is fixed upstream (thus 9999 fails in src_install because of a sandbox violation for /usr/share/bash-completion/completions/lmms).
Comment 8 Larry the Git Cow gentoo-dev 2018-11-22 21:48:49 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7222b3663c3654fb3159fefff328cbc003733e5d

commit 7222b3663c3654fb3159fefff328cbc003733e5d
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-11-22 21:47:47 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-11-22 21:48:36 +0000

    media-sound/lmms: Fix build with Qt 5.11.0
    
    Using upstream patch from git master (>1.2.0_rc7).
    
    Closes: https://bugs.gentoo.org/670250
    Package-Manager: Portage-2.3.52, Repoman-2.3.12
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../lmms/files/lmms-1.2.0_rc4-qt-5.11.patch        | 22 ++++++++++++++++++++++
 media-sound/lmms/lmms-1.2.0_rc4.ebuild             |  4 +++-
 2 files changed, 25 insertions(+), 1 deletion(-)