Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 669758 - sys-auth/pam_ssh_agent_auth fails to build with >=dev-libs/openssl-1.1.0
Summary: sys-auth/pam_ssh_agent_auth fails to build with >=dev-libs/openssl-1.1.0
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: PAM Gentoo Team (OBSOLETE)
Keywords: PullRequest
Depends on:
Blocks: openssl-1.1
  Show dependency tree
Reported: 2018-10-27 10:12 UTC by Alexander Wetzel
Modified: 2019-05-04 13:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

config.log (config.log,554.21 KB, text/x-log)
2018-10-27 10:12 UTC, Alexander Wetzel

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Wetzel 2018-10-27 10:12:40 UTC
Created attachment 553322 [details]

sys-auth/pam_ssh_agent_auth can't be compiled with openssl 1.1. I tried it some months ago and just again using dev-libs/openssl-1.1.1.

In fact this are two issues:

1) configure detects incorrectly a header/library mismatch
   -->This can be worked around be setting --without-openssl-header-check

2) opaque structures of openssl 1.1 not supported
   --> Upstream got a pull request from Guido Falsi, tested on FreeBSD 

The pull request is currently being evaluated what seems to be the new upstream repository:
The discussion also mentions configure needing --without-openssl-header-check

(Upstream seems to have moved to github, but I can't find an official announcement on sourceforge.)

Setting --without-openssl-header-check and applying the proposed patches from Guido Falsi are working for me, but I also bumped sys-auth/pam_ssh_agent_auth to 0.10.3 (but keeping the old upstream url). (I've not tested other versions with the patches).

The current official version (0.10.2) in portage fails. Here the error message, caused by issue 1) above.:

checking whether snprintf correctly terminates long strings... yes
checking whether snprintf can declare const char *fmt... yes
checking whether system supports SO_PEERCRED getsockopt... yes
checking for (overly) strict mkstemp... yes
checking if openpty correctly handles controlling tty... yes
checking whether getpgrp requires zero arguments... yes
checking OpenSSL header version... 1010100f (OpenSSL 1.1.1  11 Sep 2018)
checking OpenSSL library version... 1010100f (OpenSSL 1.1.1  11 Sep 2018)
checking whether OpenSSL's headers match the library... no
configure: error: Your OpenSSL headers do not match your
library. Check config.log for details.
If you are sure your installation is consistent, you can disable the check
by running "./configure --without-openssl-header-check".
Also see contrib/ for help identifying header/library mismatches.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-auth/pam_ssh_agent_auth-0.10.2/work/pam_ssh_agent_auth-0.10.2/config.log
 * ERROR: sys-auth/pam_ssh_agent_auth-0.10.2::gentoo failed (configure phase):
 *   econf failed
 * Call stack:
 *     , line  124:  Called src_configure
 *             environment, line 2300:  Called econf '--libexecdir=/lib64/security'
 *, line  718:  Called __helpers_die 'econf failed'
 *, line  121:  Called die
 * The specific snippet of code:
 *              die "$@"
Comment 1 Alexander Wetzel 2018-10-27 10:13:49 UTC
Blocks 592438
Comment 2 Larry the Git Cow gentoo-dev 2018-11-02 19:51:03 UTC
The bug has been closed via the following commit(s):

commit 5b085b63dd4fd0a5ef43144ca3f23bb2cf88a4d1
Author:     Craig Andrews <>
AuthorDate: 2018-11-02 16:46:01 +0000
Commit:     Robin H. Johnson <>
CommitDate: 2018-11-02 19:50:53 +0000

    sys-auth/pam_ssh_agent_auth: 0.10.3 version bump
    Include OpenSSL 1.1.1 support patch
    Add -9999 live ebuild
    Update metadata to reference github project site
    Signed-off-by: Craig Andrews <>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11
    (cherry picked from commit 1bd6acd801306f1dadb54637f1e838c0c6dad6a5)
    Signed-off-by: Robin H. Johnson <>

 sys-auth/pam_ssh_agent_auth/Manifest               |    1 +
 .../pam_ssh_agent_auth-0.10.3-openssl-1.1.1.patch  | 1244 ++++++++++++++++++++
 sys-auth/pam_ssh_agent_auth/metadata.xml           |    1 +
 .../pam_ssh_agent_auth-0.10.3.ebuild               |   51 +
 .../pam_ssh_agent_auth-9999.ebuild                 |   48 +
 5 files changed, 1345 insertions(+)