Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 6690 - Font how-to
Summary: Font how-to
Status: RESOLVED DUPLICATE of bug 108642
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Jungmin Seo (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-18 15:46 UTC by Daryl Stimm
Modified: 2005-12-10 05:13 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daryl Stimm 2002-08-18 15:46:25 UTC
I think gentoo needs a good font how-to.  Setting up fonts is pretty annoying,
and even for a person that has been using linux for 3 + years has problems
gettings fonts to look good in mozilla and konqueror.  I think we need a good
font howto that will allow users to get a perfect font setup in linux.

I know there is freetype truetype, microsoft truetype, and tons of other fonts
and every one I talk to always have problems with fonts in linux.

The how-to should talk about xfree86 and how fonts are install and how to get AA
fonts in Mozilla and Konq. 

We have a printer how-to but now we need a font howto:)

And since Microsoft stoped distrubuting the Microsoft TrueType fonts, will it
still be availible to Gentoo?  because some how I got them installed...
in

/usr/X11R6/lib/X11/fonts/truetype/

I think we are allowed to have a ebuild as long as the Licence is displayed....


thanks, 

I would write the how-to but I really wouldnt know where to start..
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2002-08-22 22:57:48 UTC
as Ms. Poppins once said, "start at the very beginning"
Comment 2 Artur Brodowski 2002-09-03 15:46:16 UTC
you might want to check the one I wrote a while ago:
http://www.skrzyp.prv.pl/gnome2_fonts_HOWTO.html
it's a little bit outta date (microsoft issue), but
it could be a start...
Comment 3 Seemant Kulleen (RETIRED) gentoo-dev 2002-09-14 23:54:00 UTC
looks good, for a starting point.  It'd be nice to be able to generalise to
non-gnome windowing environments as well... (also, what are the licenses like on
the M$ fonts?)
Comment 4 John Davis (zhen) (RETIRED) gentoo-dev 2002-11-21 12:21:59 UTC
Eric -
Have fun ;-)
If you *really* cant do this, please tell me, and I will assign it to someone else.

//ZhEN
Comment 5 John Davis (zhen) (RETIRED) gentoo-dev 2002-12-12 12:30:39 UTC
Go at this one -

Happy Hacking,
//ZhEN
Comment 6 Andrew Cooks (RETIRED) gentoo-dev 2003-11-29 12:15:02 UTC
Any progress or changes? Maybe posters to http://forums.gentoo.org/viewtopic.php?t=4825&highlight=font can be involved in writing?
Comment 7 Matteo Visconti di Oleggio Castello 2004-08-08 16:23:45 UTC
Hi all,
I'm the author of a X.org fonts HOWTO, which you can find at this link http://gentoo-wiki.com/HOWTO_Xorg_and_Fonts. I was contacted to make a proper HOWTO for Gentoo.
If you want, I can. That is, I can transfer my HOWTO into a Gentoo HOWTO, but my trouble is that it is only a way to make fonts work almost certainly, because it is based on my tryings and I'm not sure that this will work in every case.
So just tell me if this is ok, I'll be happy to make it a HOWTO for gentoo.org.
Cheers,
solka
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-12-10 05:13:45 UTC

*** This bug has been marked as a duplicate of 108642 ***