Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 66651 - contact-lookup applet ebuild
Summary: contact-lookup applet ebuild
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Low enhancement (vote)
Assignee: Default Assignee for New Packages
URL:
Whiteboard: sunrise suggested
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2004-10-07 07:19 UTC by Jean-François Richard
Modified: 2011-12-18 12:30 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
contact-lookup applet ebuild (contact-lookup-applet-0.9.ebuild,686 bytes, text/plain)
2004-10-07 07:20 UTC, Jean-François Richard
Details
Ebuild for contact-lokup-applet-0.10 (contact-lookup-applet-0.10.ebuild,801 bytes, application/octet-stream)
2005-01-07 03:07 UTC, Mario Witte
Details
Ebuild for contact-lookup-applet-0.14.ebuild (contact-lookup-applet-0.14.ebuild,748 bytes, text/plain)
2006-06-11 03:06 UTC, Gilles Dartiguelongue
Details
contact-lookup-applet-0.15.ebuild (contact-lookup-applet-0.15.ebuild,759 bytes, text/plain)
2007-02-03 21:12 UTC, Gilles Dartiguelongue
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Richard 2004-10-07 07:19:20 UTC
An applet to search the evolution-data-server address book.



Reproducible: Always
Steps to Reproduce:
Comment 1 Jean-François Richard 2004-10-07 07:20:04 UTC
Created attachment 41289 [details]
contact-lookup applet ebuild
Comment 2 foser (RETIRED) gentoo-dev 2004-10-09 05:57:27 UTC
ebuild looks ok only there is version information at all in this bugreport
Comment 3 Jean-François Richard 2004-10-09 06:09:14 UTC
The package "contact-lookup-applet" is version 0.9.
Comment 4 Mario Witte 2005-01-07 03:07:28 UTC
Created attachment 47827 [details]
Ebuild for contact-lokup-applet-0.10

I just built an ebuild for the current 0.10 version of contact-lookup-applet.
Unfortunately I didn't check for existing ebuild in bugzilla before starting,
but at least it's a newer version than the existing one.
Comment 5 Jean-François Richard 2005-12-27 13:27:08 UTC
Last upstream update was on 24-Jul-2005, and it seems the deskbar applet provides the same functionality and then more; [http://raphael.slinckx.net/deskbar/]

I'm all for closing this bug...
Comment 6 Gilles Dartiguelongue gentoo-dev 2006-02-08 02:00:40 UTC
(In reply to comment #5)
> Last upstream update was on 24-Jul-2005, and it seems the deskbar applet
> provides the same functionality and then more;
> [http://raphael.slinckx.net/deskbar/]

In fact, deskbar-applet is not working for me (gnome-2.12) but contact-lookup-applet (0.13) is. Just to mention it. I may provide an updated ebuild for 0.13.
Comment 7 Gilles Dartiguelongue gentoo-dev 2006-02-08 16:37:36 UTC
Ok, I just build the latest version of deskbar (2.13.90.1) and it actually works (was the alt f3 binding bug).

Back to contact-lookup-applet, the latest tar is a little bit outdated because there are some i18n updates in CVS. But appart from that, a simple bump from the attached 0.10 ebuild to 0.13 works perfectly fine.

Some clues about the differences between c-l-a and d-a I found interesting. d-a just allow you to write  emails to somebody. Sure it is scriptable, so you can tune whatever you want but c-l-a presents you all stuff about the selected contact that is in eds, in a single shot (plus it is pure C).
Comment 8 Gilles Dartiguelongue gentoo-dev 2006-06-05 00:31:00 UTC
version 0.14 is out, will post an ebuild when I got back home.

Back to args for/against inclusion of this ebuild, I think (need to check but pretty sure) that cla is ligther on memory than deskbar. Considering the hardware I'm using in a day to day config, I prefer using cla than deskbar :).
Comment 9 Gilles Dartiguelongue gentoo-dev 2006-06-11 03:06:27 UTC
Created attachment 88887 [details]
Ebuild for contact-lookup-applet-0.14.ebuild

Ok here is the ebuild for the last version of contact-lookup-applet. 
I added doc to IUSE because of a QA notice, not sure if it is relevant.

Compiled and actually running without any problems.

emerge --info
Portage 2.1 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.16-suspend2-r8 i686)
=================================================================
System uname: 2.6.16-suspend2-r8 i686 Mobile Intel(R) Pentium(R) III CPU - M   800MHz
Gentoo Base System version 1.12.1
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.93
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -msse -mtune=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf"
CXXFLAGS="-O3 -msse -mtune=pentium-m -pipe"
DISTDIR="/var/tmp/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.gentoo.gr.jp http://85.25.128.62 http://ftp.heanet.ie/pub/gentoo/"
LANG="fr_FR.UTF-8"
LINGUAS="en fr ja zh"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/portage /usr/portage/local/layman/liferea_overlay /usr/portage/local/layman/musicbrainz /usr/portage/local/layman/gentopia /usr/portage/local/layman/flameeyes-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X acl acpi alsa avahi avi bash-completion bitmap-fonts bogofilter bzip2 cairo canna cjk cli crypt cups daap dbus dri drm eds emboss exif firefox foomaticdb freewnn fuse gif glitz gnome gnutls gphoto2 gpm gstreamer gstreamer010 gtk gtk2 gtkhtml hal iproute2 ipv6 irda isdnlog jpeg kde libg++ libnotify libwww logrotate mad matroska mikmod mmx mp3 mpeg musicbrainz nautilus ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl pam pcmcia pcre pdflib perl png pppd python quicktime readline reflection samba sasl sdk session spell spl sse ssl svg tcpd theora threads truetype truetype-fonts type1-fonts udev unicode userlocales vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev input_devices_wacom kernel_linux linguas_en linguas_fr linguas_ja linguas_zh userland_GNU video_cards_i810"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 10 Gilles Dartiguelongue gentoo-dev 2007-02-03 21:12:58 UTC
Created attachment 109039 [details]
contact-lookup-applet-0.15.ebuild

Latest version
Comment 11 Gilles Dartiguelongue gentoo-dev 2007-09-12 22:34:28 UTC
I've talked to ross on #evolution and it seems nobody really got to takeover maintenance of contact-lookup-applet. As such I wouldn't like to add it to the tree since it could very well rot rapidly.
Comment 12 Mart Raudsepp gentoo-dev 2007-11-16 15:34:23 UTC
Bastien maintains it now ;p

http://www.hadess.net/2007/11/ross-is-offically-evil.html
Comment 13 Gilles Dartiguelongue gentoo-dev 2008-11-30 11:15:23 UTC
align ebuild requests to same values
Comment 14 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-14 17:01:56 UTC
(this is an automated message based on filtering criteria that matched this bug)
'EBUILD' is in the KEYWORDS which should mean that there is a ebuild attached to
this bug.
This bug is assigned to maintainer-wanted which means that it is not in the main
tree.

Hello, The Gentoo Team would like to firstly thank you for your ebuild
submission. We also apologize for not being able to accommodate you in a timely
manner. There are simply too many new packages.

Allow me to use this opportunity to introduce you to Gentoo Sunrise. The sunrise
overlay[1] is a overlay for Gentoo which we allow trusted users to commit to and
all users can have ebuilds reviewed by Gentoo devs for entry into the overlay.
So, the sunrise team is suggesting that you look into this and submit your
ebuild to the overlay where even *you* can commit to. =)

Because this is a mass message, we are also asking you to be patient with us. We
anticipate a large number of requests in a short time. 

Thanks,
On behalf of the Gentoo Sunrise Team,
Jeremy.

[1]: http://www.gentoo.org/proj/en/sunrise/
[2]: http://overlays.gentoo.org/proj/sunrise/wiki/SunriseFaq
Comment 15 Gilles Dartiguelongue gentoo-dev 2011-12-18 12:30:06 UTC
Package is dead upstream and applets for gnome panel are deprecated with gnome3. I guess it's time to close this bug.