Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 666324 - =media-gfx/inkscape-0.92.3-r1 depends on >=dev-cpp/glibmm-2.54.1: configure: error: cannot detect whether C++11 is required
Summary: =media-gfx/inkscape-0.92.3-r1 depends on >=dev-cpp/glibmm-2.54.1: configure: ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-16 03:58 UTC by Nick
Modified: 2018-10-28 22:54 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,89.22 KB, text/x-log)
2018-09-16 03:58 UTC, Nick
Details
build.log (build.log,30.01 KB, text/x-log)
2018-09-16 03:59 UTC, Nick
Details
fixed inkscape-0.92.3-r1.ebuild (inkscape-0.92.3-r1.ebuild,3.92 KB, text/plain)
2018-09-16 03:59 UTC, Nick
Details
inkscape-0.92.3-r1.ebuild.diff (inkscape-0.92.3-r1.ebuild.diff,418 bytes, patch)
2018-09-24 06:24 UTC, Nick
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2018-09-16 03:58:32 UTC
Created attachment 547012 [details]
config.log

Fails in configure stage with <dev-cpp/glibmm-2.54.1

/usr/include/glibmm-2.4/glibmm/threads.h:660:29: error: cannot convert 'GPrivate' {aka '_GPrivate'} to 'GPrivate*' {aka '_GPrivate*'} in return
   GPrivate* gobj() { return gobject_; }
Comment 1 Nick 2018-09-16 03:59:03 UTC
Created attachment 547014 [details]
build.log
Comment 2 Nick 2018-09-16 03:59:41 UTC
Created attachment 547016 [details]
fixed inkscape-0.92.3-r1.ebuild
Comment 3 Andreas Sturmlechner gentoo-dev 2018-09-16 09:50:34 UTC
Thanks for your work, please, instead of attaching full ebuilds, make a unified diff so your changes are reviewable on bugzilla.
Comment 4 Nick 2018-09-24 06:24:09 UTC
Created attachment 547750 [details, diff]
inkscape-0.92.3-r1.ebuild.diff
Comment 5 Larry the Git Cow gentoo-dev 2018-10-27 21:12:07 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e297dba99b764ca313955c3d2673dbd435a72bf2

commit e297dba99b764ca313955c3d2673dbd435a72bf2
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-10-27 20:45:09 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-10-27 21:11:54 +0000

    media-gfx/inkscape: Raise dev-cpp/glibmm min dep to 2.54.1
    
    Thanks-to: Nick <nickAristocrates@gmail.com>
    Closes: https://bugs.gentoo.org/666324
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
    Package-Manager: Portage-2.3.51, Repoman-2.3.11

 media-gfx/inkscape/inkscape-0.92.3-r1.ebuild | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)