Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 665560 - dev-python/matplotlib-2.2.2-r1 should depend on dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
Summary: dev-python/matplotlib-2.2.2-r1 should depend on dev-python/pygobject:3[${PYTH...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-09 10:24 UTC by Teika kazura
Modified: 2019-05-03 11:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Teika kazura 2018-09-09 10:24:05 UTC
When dev-python/matplotlib-2.2.2-r1 is built with USE="gtk3 cairo", it requires pygobject built with USE=cairo i.e. RDEPEND should have "dev-python/pygobject:3[${PYTHON_USEDEP}, cairo]", which is lacking in the current ebuild.

If you re-emerge
$ USE="-cairo" emerge -1 dev-python/pygobject
then matplotlib fails with the message "TypeError: Couldn't find foreign struct converter for 'cairo.Context'". Sample code:
------------------------------------------------------------------------
#!/usr/bin/python

import matplotlib.pyplot as plt
plt.plot([1, 2])
plt.show()
------------------------------------------------------------------------

<matplotlib source>//INSTALL.rst says:
  * `cairocffi <https://cairocffi.readthedocs.io/en/latest/>`__ (>= v0.8): for cairo based backends;
  * `pycairo <https://pypi.python.org/pypi/pycairo>`_: for GTK3Cairo;

However, pycairo is not directly relevant; having it installed doesn't help. You need pygobject with USE=cairo.

Thanks maintainers. Best regards.