Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 665020 - sys-block/thin-provisioning-tools undefined reference to `io_getevents'
Summary: sys-block/thin-provisioning-tools undefined reference to `io_getevents'
Status: RESOLVED DUPLICATE of bug 630298
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-01 11:11 UTC by cryptopsy
Modified: 2019-04-21 10:19 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (sys-block:thin-provisioning-tools-0.7.6:20180901-140424.log,90.37 KB, text/x-log)
2018-09-01 11:11 UTC, cryptopsy
Details
emerge --info (info,5.26 KB, text/plain)
2018-09-01 13:26 UTC, cryptopsy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cryptopsy 2018-09-01 11:11:35 UTC
Created attachment 545708 [details]
build.log

Also does not emerge without LTO on this package, though LTO on a dep may have caused it.
Comment 1 cryptopsy 2018-09-01 13:26:37 UTC
Created attachment 545724 [details]
emerge --info
Comment 2 Don Burris 2018-09-15 21:10:47 UTC
This is due to dev-libs/libaio being compiled with LTO, try re-emerging that package w/o LTO and thin-provisioning-tools should compile successfully.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2019-04-21 10:19:31 UTC

*** This bug has been marked as a duplicate of bug 630298 ***