Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 664140 - dev-haskell/hscolour-1.24.4: cannot satisfy -package Cabal-1.24.2.0
Summary: dev-haskell/hscolour-1.24.4: cannot satisfy -package Cabal-1.24.2.0
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Haskell Language team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-20 18:52 UTC by Thomas Deutschmann
Modified: 2018-08-21 13:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev Security 2018-08-20 18:52:23 UTC
After today's  ghc-8.4.3 update:

>>> Configuring source in /var/tmp/portage/dev-haskell/hscolour-1.24.4/work/hscolour-1.24.4 ...                [0/92325]
 * Using cabal-1.24.2.0.
 * Prepending /usr/lib64/ghc-8.4.3 to LD_LIBRARY_PATH
/usr/bin/ghc -package Cabal-1.24.2.0 --make /var/tmp/portage/dev-haskell/hscolour-1.24.4/work/hscolour-1.24.4/Setup.hs -j6 +RTS -A256M -qb0 -RTS -threaded -dynamic -o setup
<command line>: cannot satisfy -package Cabal-1.24.2.0
    (use -v for more information)
/usr/bin/ghc -package Cabal-1.24.2.0 --make /var/tmp/portage/dev-haskell/hscolour-1.24.4/work/hscolour-1.24.4/Setup.hs -j6 +RTS -A256M -qb0 -RTS -threaded -o setup
<command line>: cannot satisfy -package Cabal-1.24.2.0
    (use -v for more information)
 * ERROR: dev-haskell/hscolour-1.24.4::haskell failed (configure phase):
 *   compiling /var/tmp/portage/dev-haskell/hscolour-1.24.4/work/hscolour-1.24.4/Setup.hs failed
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_configure
 *   environment, line 2715:  Called haskell-cabal_src_configure '--ghc-options=-rtsopts'
 *   environment, line 1929:  Called cabal-bootstrap
 *   environment, line  393:  Called die
 * The specific snippet of code:
 *           } || make_setup "$@" || die "compiling ${setupmodule} failed";
Comment 1 Sergei Trofimovich gentoo-dev 2018-08-20 20:59:18 UTC
ghc-8.4.3 will require cabal-2.2.0.1 or later installed.
Comment 2 Thomas Deutschmann gentoo-dev Security 2018-08-21 13:36:52 UTC
My point is, that emerge is unable to detect that. Maybe because the Cabal requirement isn't known...

After manually upgrading dev-haskell/cabal-2.2.0.1:0/2.2.0.1::haskell [1.24.2.0:0/1.24.2.0::haskell] first, world upgrade was finally successful.