Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 663644 - net-analyzer/pchar hard dependency on dev-libs/openssl
Summary: net-analyzer/pchar hard dependency on dev-libs/openssl
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrick McLean
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-14 23:09 UTC by Erik
Modified: 2018-08-15 10:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik 2018-08-14 23:09:38 UTC
Refer also trailing comment to Bug 127389. Starting a new bug, as the reported issue for Bug 127389 has apparently been addressed.

Could we please either remove the hard openssl dependency (if it is not actually used any longer, per the Bug 127389 comment) or amend it to

|| ( >=dev-libs/openssl-0.9.7 dev-libs/libressl )

which seems to work for me.
Comment 1 Andreas Sturmlechner gentoo-dev 2018-08-15 10:13:57 UTC
|| ( ) is an insufficient construct for the libressl/openssl issue. Add USE=libressl to select between the two implementations.