Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 663384 - kde-plasma/kinfocenter-5.13.4 ninja: error: build.ninja:2386: multiple rules generate kinfocenter-5.13.4/Modules/base/config-infocenter.h.cmake
Summary: kde-plasma/kinfocenter-5.13.4 ninja: error: build.ninja:2386: multiple rules ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 677866 685434 (view as bug list)
Depends on: 668020
Blocks: ninja-porting
  Show dependency tree
 
Reported: 2018-08-11 20:07 UTC by Mike Gilbert
Modified: 2019-06-05 19:06 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Gilbert gentoo-dev 2018-08-11 20:07:38 UTC
With CMAKE_MAKEFILE_GENERATOR=ninja.

>>> Working in BUILD_DIR: "/x/portage/kde-plasma/kinfocenter-5.13.4/work/kinfocenter-5.13.4_build"
ninja -v -j6 -l0
ninja: error: build.ninja:2386: multiple rules generate /x/portage/kde-plasma/kinfocenter-5.13.4/work/kinfocenter-5.13.4/Modules/base/config-infocenter.h.cmake [-w dupbuild=err]
Comment 1 Franz Trischberger 2018-09-06 12:27:25 UTC
For me 5.13.4 worked fine, but the issue popped up with 5.13.5.
The failure was caused by ninja-2.8.1-r1, which is the Kitware-fork [1]. Upstream 1.8.2 works fine. No idea how to deal with the Ninja-Tracker-block in this case.

[1] https://github.com/gentoo/gentoo/pull/9183
Comment 2 Andreas Sturmlechner gentoo-dev 2018-09-06 18:18:50 UTC
CCing ninja maintainers then.
Comment 3 Mike Gilbert gentoo-dev 2018-09-06 18:34:37 UTC
(In reply to Andreas Sturmlechner from comment #2)
> CCing ninja maintainers then.

I am the ninja maintainer ;-). I will try to reproduce without the kitware patches; if vanilla ninja works, 1.8.2-r1 is getting masked.
Comment 4 Brad King 2018-09-14 19:00:13 UTC
The Kitware fork is based on a post-1.8.2 version of upstream Ninja from their 'master' branch.  It includes this upstream change:

* make `-w dupbuild` default to `err`
  https://github.com/ninja-build/ninja/pull/1406

That will be released in upstream Ninja 1.9.

A "multiple rules generate" diagnostic from Ninja means that the build.ninja file needs to be fixed.  A packager can pass `-w dupbuild=warn` to ninja to convert the error back to a warning, but the underlying problem needs to be fixed in the build.ninja file eventually.
Comment 5 Mike Gilbert gentoo-dev 2018-09-14 19:35:16 UTC
(In reply to Brad King from comment #4)

Thank you for the information.
Comment 6 Andreas Sturmlechner gentoo-dev 2019-02-13 12:03:23 UTC
*** Bug 677866 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Sturmlechner gentoo-dev 2019-02-16 09:29:09 UTC
Not reproducible anymore for me with:

dev-util/ninja-1.8.2-r2
dev-util/cmake-3.13.4
Comment 8 Michael Palimaka (kensington) gentoo-dev 2019-04-13 04:14:21 UTC
This is passing successfully for me on both stable and testing.
Comment 9 Michael Palimaka (kensington) gentoo-dev 2019-04-13 04:15:37 UTC
(In reply to Michael Palimaka (kensington) from comment #8)
> This is passing successfully for me on both stable and testing.

Just for the sake of clarity, I did force and verify ninja was used.
Comment 10 Andreas Sturmlechner gentoo-dev 2019-05-09 19:46:11 UTC
*** Bug 685434 has been marked as a duplicate of this bug. ***
Comment 11 Larry the Git Cow gentoo-dev 2019-06-05 19:06:36 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/proj/kde.git/commit/?id=f6468d1743f0474433aaf09a1f58ad41053a25bb

commit f6468d1743f0474433aaf09a1f58ad41053a25bb
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-06-05 18:09:48 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-06-05 18:09:48 +0000

    kde-plasma/kinfocenter: Set CMAKE_MIN_VERSION=3.14.3
    
    In an attempt to fix build with ninja.
    
    Bug: https://bugs.gentoo.org/663384
    Package-Manager: Portage-2.3.67, Repoman-2.3.14
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 kde-plasma/kinfocenter/kinfocenter-5.15.90.ebuild      | 1 +
 kde-plasma/kinfocenter/kinfocenter-5.16.49.9999.ebuild | 1 +
 kde-plasma/kinfocenter/kinfocenter-9999.ebuild         | 1 +
 3 files changed, 3 insertions(+)