Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 660566 - app-misc/anki-2.1.0_beta27 requires Qt 5.11.1 (what?)
Summary: app-misc/anki-2.1.0_beta27 requires Qt 5.11.1 (what?)
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-06 23:07 UTC by Michael Mounteney
Modified: 2020-06-12 21:38 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mounteney 2018-07-06 23:07:20 UTC
After emerge @world to-day, when I start Anki it reports:

Error during startup:
Traceback (most recent call last):
  File "/usr/lib64/python3.6/site-packages/aqt/main.py", line 50, in __init__
    self.setupUI()
  File "/usr/lib64/python3.6/site-packages/aqt/main.py", line 75, in setupUI
    self.setupMainWindow()
  File "/usr/lib64/python3.6/site-packages/aqt/main.py", line 566, in setupMainWindow
    tweb = self.toolbarWeb = aqt.webview.AnkiWebView()
  File "/usr/lib64/python3.6/site-packages/aqt/webview.py", line 105, in __init__
    self.focusProxy().installEventFilter(self)
AttributeError: 'NoneType' object has no attribute 'installEventFilter'

According to https://bbs.archlinux.org/viewtopic.php?id=237486 this is because Anki is incompatible with Qt 5.11.1
Comment 1 Andreas Sturmlechner gentoo-dev 2018-07-07 08:01:10 UTC
Your $summary is confusing.
Comment 2 Philipp 2018-07-07 09:16:24 UTC
Unfortunately, the latest version (Beta 42) is also not compatible with Qt-5.11.
Comment 4 Michael Mounteney 2018-07-14 21:52:49 UTC
I've set up a chroot environment just for Anki, until this is resolved.

package.mask:  >=dev-qt/qtwebengine-5.10

etc.

Email me if you want more details.
Comment 5 Andreas Sturmlechner gentoo-dev 2018-07-16 17:57:13 UTC
(In reply to Francesco Turco from comment #3)
> Damien Elmes (Anki developer) said he probably won't work on Qt 5.11 support.
> Instead, he will wait until Qt 5.12 is released in November.
That's a bad decision.
Comment 6 Douglas Harding 2019-04-23 05:43:34 UTC
I have found a workaround for this. If you go to the
official Anki download page, you can scroll to the
bottom and download an older version. It is currently
version 2.0.52 -- I have yet to run into any issues,
and I do not get any errors. It is not perfect because
we cannot use the latest version as of right now, but
this work around should be acceptable to users of
Anki who don't want to rely on the web version or a
downgraded version of qt5.
Comment 7 cburroughs 2020-06-12 17:37:01 UTC
Michael Mounteney, does the 2.1.15 version of anki now in ::gentoo work for you now?
Comment 8 Michael Mounteney 2020-06-12 21:38:25 UTC
I don't know, sorry.  I now use the downloaded tarball from the Anki site for now, whilst transitioning off Anki.  The portage version is too old.  If this bug affects only me, I propose it should be closed.