Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 659772 - app-eselect/eselect-infinality causes problems with fontconfig
Summary: app-eselect/eselect-infinality causes problems with fontconfig
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Fonts Team
URL: https://forums.gentoo.org/viewtopic-p...
Whiteboard:
Keywords:
: 650248 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-01 18:35 UTC by Maxim Koltsov
Modified: 2018-08-02 15:04 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix eselect-infinality to create a symlink to an absolute path (fix-eselect-infinality.patch,653 bytes, patch)
2018-07-30 17:59 UTC, Sven Eden
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim Koltsov gentoo-dev 2018-07-01 18:35:25 UTC
I noticed recently, that all programs that are using fontconfig print this on startup:

> Fontconfig error: failed reading config file 
> Fontconfig error: Cannot load config file "infinality/conf.d" 

This problem was reported on the forum with a proposed solution in eselect-infinality: https://forums.gentoo.org/viewtopic-p-8205494.html

I'm not sure which fontconfig version introduced this, but think we should fix it.
Comment 1 Sven Eden 2018-07-30 17:59:01 UTC
Created attachment 541816 [details, diff]
Fix eselect-infinality to create a symlink to an absolute path

Thanks for reporting this. I just stumbled over the forums thread you linked to, when I had tons of errors when running doxygen.

The attached patch is a simple fix (one-liner):
eselect-infinality must *NOT* create a relative symlink , but link
  /etc/fonts/infinality/conf.d
to an absolute path in
  /etc/fonts/infinality/styles.conf.avail/
Comment 2 Maxim Koltsov gentoo-dev 2018-07-30 18:00:22 UTC
Still waiting for response from fonts team...
Comment 3 Guilherme Amadio gentoo-dev 2018-07-31 06:30:37 UTC
(In reply to Maxim Koltsov from comment #2)
> Still waiting for response from fonts team...

Sorry, the fonts team lacks manpower a bit. I will have a look at a fix for this today.
Comment 4 thunderrd 2018-07-31 17:10:17 UTC
Also, it might be related to this as well; the error message is the same:

https://bugs.gentoo.org/650248

THis is an old bug that has just today become rather important for infinality users, because chromium now depends on =>fontconfig-2.13.0-r4, which completely breaks all ionfinality font settings.

So far, I've survived by masking all versions of fontconfig-2.13.0, but now am not sure what to do with this new dependency.
Comment 5 thunderrd 2018-07-31 17:12:40 UTC
BTW, 2.12.6 is the last version NOT to display that error message, and it's the last version to respect infinality configuration settings.
Comment 6 Larry the Git Cow gentoo-dev 2018-07-31 17:49:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2c53799d22cecefea1b320a6b964bb957351327b

commit 2c53799d22cecefea1b320a6b964bb957351327b
Author:     Guilherme Amadio <amadio@gentoo.org>
AuthorDate: 2018-07-31 17:44:16 +0000
Commit:     Guilherme Amadio <amadio@gentoo.org>
CommitDate: 2018-07-31 17:44:16 +0000

    app-eselect/eselect-infinality: version bump to 1.1
    
    Closes: https://bugs.gentoo.org/659772
    Package-Manager: Portage-2.3.44, Repoman-2.3.10

 app-eselect/eselect-infinality/Manifest            |  1 +
 .../eselect-infinality-1.1.ebuild                  | 27 ++++++++++++++++++++++
 2 files changed, 28 insertions(+)
Comment 7 Guilherme Amadio gentoo-dev 2018-07-31 17:53:23 UTC
I adopted eselect-infinality since the former maintainer Ben de Groot (yngwin) has retired. Please let me know if something is still not working. We can ask for stabilization sooner if fontconfig-2.13 is marked stable.
Comment 8 thunderrd 2018-08-01 15:06:53 UTC
I don't think this is resolved; the error message still exists on my setup, and the fonts are not correct.

I've removed my local masks for fontconfig and pango, and rebuilt them to the latest versions, as well as eselect-infinality.  The error still exists on bootup:

> Fontconfig error: failed reading config file 
> Fontconfig error: Cannot load config file "infinality/conf.d"

I don't know about other users, but it isn't solved for me, and it does not solve https://bugs.gentoo.org/650248 either.

Am I missing something?
Comment 9 Guilherme Amadio gentoo-dev 2018-08-01 15:14:41 UTC
(In reply to thunderrd from comment #8)
> I don't think this is resolved; the error message still exists on my setup,
> and the fonts are not correct.
> 
> I've removed my local masks for fontconfig and pango, and rebuilt them to
> the latest versions, as well as eselect-infinality.  The error still exists
> on bootup:
> 
> > Fontconfig error: failed reading config file 
> > Fontconfig error: Cannot load config file "infinality/conf.d"
> 
> I don't know about other users, but it isn't solved for me, and it does not
> solve https://bugs.gentoo.org/650248 either.
> 
> Am I missing something?

Please rerun eselect infinality and set the configuration to the same thing.
The links are not reset by just reinstalling eselect-infinality. New users will not get a faulty infinality when installing the newer version.
Comment 10 thunderrd 2018-08-01 15:38:34 UTC
Thank you; you are absolutely correct.

Resetting the links again seems to have solved the problem.

Perhaps you can make a comment in https://bugs.gentoo.org/650248 to mention the need for the reset?  Then I think you can close that bug as well.
Comment 11 Guilherme Amadio gentoo-dev 2018-08-02 15:04:28 UTC
*** Bug 650248 has been marked as a duplicate of this bug. ***