Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 657526 - kde-apps/print-manager w/ net-print/cups-2.2.8: numerous errors leading to high system load
Summary: kde-apps/print-manager w/ net-print/cups-2.2.8: numerous errors leading to hi...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
Whiteboard: tracking upstream
: 657606 657638 (view as bug list)
Depends on:
Reported: 2018-06-07 12:31 UTC by Tony
Modified: 2018-06-13 10:16 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---

cups-2.2.8-5325.patch (cups-2.2.8-5325.patch,1.82 KB, patch)
2018-06-09 02:38 UTC, Perfect Gentleman
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2018-06-07 12:31:01 UTC
kde-apps/print-manager doesn't like recent net-print/cups-2.2.8, numerous errors leading to high system load

After a recent update from net-print/cups-2.2.7 to net-print/cups-2.2.8, I'm seeing lots of errors being thrown by libkcups (part of kde-apps/print-manager)
The following 3 error messages are being repeated over and over in the journal

Jun 07 12:44:15 tony-workstation plasmashell[679]: libkcups: 3 "LaserJet8150"
Jun 07 12:44:15 tony-workstation plasmashell[679]: libkcups: CUPS-Get-Printers last error: 0 successful-ok
Jun 07 12:44:15 tony-workstation plasmashell[679]: libkcups: "040B localhost \"requesting-user-name\" attribute with bad value."

This is causing system load to rise significantly
libkcups and plasmashell processes at 70-80% CPU usage

Tried re-emerging kde-apps/print-manager, no dice.
But downgrading from net-print/cups-2.2.8 to net-print/cups-2.2.7 fixes issue

emerge --info below

Portage 2.3.40 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-7.3.0, glibc-2.27-r3, 4.17.0-gentoo x86_64)
System uname: Linux-4.17.0-gentoo-x86_64-Intel-R-_Core-TM-_i5-6500_CPU_@_3.20GHz-with-gentoo-2.6
KiB Mem:     8091596 total,   3643308 free
KiB Swap:    8312828 total,   8312828 free
Timestamp of repository gentoo: Thu, 07 Jun 2018 08:00:01 +0000
Head commit of repository gentoo: 96e4141f44a52757c4ec94b6430bb04b1772c378
sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p2) 2.30.0
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.14-r2::gentoo, 3.5.5-r1::gentoo, 3.6.5-r1::gentoo
dev-util/cmake:           3.11.3::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r2::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.16-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r3::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi activities alsa amd64 atm berkdb bluetooth branding bzip2 cairo caps cdda cdr cli crypt css cups curl cxx dbus declarative dri dts dv dvd dvdr egl emboss encode exif fam ffmpeg flac fontconfig fortran ftp gdbm gif glamor gmp gpm gstreamer iconv imagemagick imap introspection ipv6 javascript jpeg kde kipi kwallet ladspa lash lcms libnotify libsamplerate libtirpc libv4l lm_sensors lzma mad mhash mime mmap mng modules mp3 mp4 mpeg mpi mplayer mtp multilib mysql ncurses nls nptl nsplugin offensive ogg openal opengl openmp pam pango pcre pdf perl phonon plasma png policykit postscript ppds pulseaudio python qml qt3support qt5 quicktime raw readline recode sasl sdl seccomp semantic-desktop smp sockets sound sox spell ssl startup-notification svg symlink syslog systemd tcpd theora threads tiff timidity truetype udev udisks unicode upower usb v4l vala vdpau vim-syntax vorbis wayland widgets wxwidgets x264 xattr xcb xcomposite xft xinerama xml xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby23" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Andreas Sturmlechner gentoo-dev 2018-06-07 17:08:01 UTC
Please report your findings at
Comment 2 Andreas Sturmlechner gentoo-dev 2018-06-08 19:12:41 UTC
*** Bug 657606 has been marked as a duplicate of this bug. ***
Comment 3 Tony 2018-06-08 21:03:05 UTC
This is a bug in CUPS

CUPS maintainers have identified the issue

CUPS is incorrectly parsing UTF8 values passed to it from clients

Can I request a hard-mask of net-print/cups-2.2.8 ?
Issue is likely to be resolved in the next release

Many thanks
Comment 4 Larry the Git Cow gentoo-dev 2018-06-09 01:47:55 UTC
The bug has been referenced in the following commit(s):

commit f1efc4b5035dd0e10dd64e7f2b16d9eed155a83a
Author:     Lars Wendler <>
AuthorDate: 2018-06-09 01:46:16 +0000
Commit:     Lars Wendler <>
CommitDate: 2018-06-09 01:46:16 +0000

    package.mask: Masked =net-print/cups-2.2.8 causing high system load

 profiles/package.mask | 5 +++++
 1 file changed, 5 insertions(+)
Comment 5 Perfect Gentleman 2018-06-09 02:38:45 UTC
Created attachment 535344 [details, diff]

Comment 6 Andreas Sturmlechner gentoo-dev 2018-06-09 06:49:29 UTC
*** Bug 657638 has been marked as a duplicate of this bug. ***
Comment 7 Larry the Git Cow gentoo-dev 2018-06-11 13:26:14 UTC
The bug has been referenced in the following commit(s):

commit 19a3c009970d2a917d4dbf7489508e1ebe41aec0
Author:     Lars Wendler <>
AuthorDate: 2018-06-11 13:24:52 +0000
Commit:     Lars Wendler <>
CommitDate: 2018-06-11 13:26:05 +0000

    net-print/cups: Revbumps to fix high system load. Removed old.
    Package-Manager: Portage-2.3.40, Repoman-2.3.9

 .../{cups-2.2.8.ebuild => cups-2.2.8-r1.ebuild}    |  1 +
 ...s-2.3_beta5.ebuild => cups-2.3_beta5-r1.ebuild} |  1 +
 .../cups/files/cups-2.2.8-validation_fixes.patch   | 60 ++++++++++++++++++++++
 3 files changed, 62 insertions(+)
Comment 8 Andreas Sturmlechner gentoo-dev 2018-06-12 08:00:40 UTC
I guess we consider this as solved then, thanks for reporting.
Comment 9 Andreas Sturmlechner gentoo-dev 2018-06-12 08:05:53 UTC
re-opening, until PR is merged upstream.
Comment 10 Larry the Git Cow gentoo-dev 2018-06-12 08:17:32 UTC
The bug has been closed via the following commit(s):

commit 48bc37017baa171ff6472b384f866cdf64a4edfa
Author:     Lars Wendler <>
AuthorDate: 2018-06-12 08:15:14 +0000
Commit:     Lars Wendler <>
CommitDate: 2018-06-12 08:15:14 +0000

    net-print/cups: Use official upstream fixes.
    Package-Manager: Portage-2.3.40, Repoman-2.3.9

 net-print/cups/cups-2.2.8-r1.ebuild                |  2 +-
 net-print/cups/cups-2.3_beta5-r1.ebuild            |  2 +-
 .../cups/files/cups-2.2.8-validation_fixes.patch   | 79 ++++++++++++----------
 .../files/cups-2.3_beta5-validation_fixes.patch    | 69 +++++++++++++++++++
 4 files changed, 115 insertions(+), 37 deletions(-)