Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 657314 - media-video/ffmpeg-3.4.2-r1[opencl] - src_configure(): ERROR: opencl not found
Summary: media-video/ffmpeg-3.4.2-r1[opencl] - src_configure(): ERROR: opencl not found
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-04 01:31 UTC by Thomas Beutin
Modified: 2019-02-13 15:15 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,5.68 KB, text/plain)
2018-06-04 01:32 UTC, Thomas Beutin
Details
emerge --info 'media-video/ffmpeg' (file_657314.txt,8.75 KB, text/plain)
2018-06-16 16:04 UTC, Thibaud "thican" CANALE
Details
emerge --info (emerge-info,10.05 KB, text/plain)
2018-06-18 18:00 UTC, jeremy mills
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Beutin 2018-06-04 01:31:11 UTC
>>> Source prepared.
>>> Configuring source in /mnt/gentoo/tmp/portage/media-video/ffmpeg-3.4.2-r1/work/ffmpeg-3.4.2 ...
 * abi_x86_32.x86: running multilib-minimal_abi_src_configure
/mnt/gentoo/tmp/portage/media-video/ffmpeg-3.4.2-r1/work/ffmpeg-3.4.2/configure --prefix=/usr --libdir=/usr/lib32 --shlibdir=/usr/lib32 --docdir=/usr/share/doc/ffmpeg-3.4.2-r1/html --mandir=/usr/share/man --enable-shared --cc=x86_64-pc-linux-gnu-gcc -m32 --cxx=x86_64-pc-linux-gnu-g++ -m32 --ar=ar --optflags=-march=sandybridge -fomit-frame-pointer -O2 -pipe --disable-static --enable-avfilter --enable-avresample --disable-stripping --enable-nonfree --enable-version3 --enable-version3 --disable-indev=oss --disable-outdev=oss --disable-outdev=sdl --enable-version3 --enable-version3 --enable-nonfree --enable-bzlib --enable-runtime-cpudetect --disable-debug --disable-gcrypt --disable-gnutls --enable-gmp --enable-gpl --disable-hardcoded-tables --enable-iconv --enable-lzma --enable-network --enable-opencl --enable-openssl --enable-postproc --enable-libsmbclient --disable-ffplay --disable-sdl2 --enable-vaapi --enable-vdpau --enable-xlib --enable-libxcb --enable-libxcb-shm --enable-libxcb-xfixes --enable-zlib --enable-libcdio --disable-libiec61883 --disable-libdc1394 --enable-libcaca --enable-openal --enable-opengl --enable-libv4l2 --enable-libpulse --disable-libdrm --enable-libopencore-amrwb --enable-libopencore-amrnb --enable-libfdk-aac --enable-libopenjpeg --enable-libbluray --enable-libcelt --enable-libgme --disable-libgsm --disable-mmal --disable-libmodplug --enable-libopus --disable-libilbc --disable-librtmp --enable-libssh --enable-libspeex --enable-librsvg --enable-libvorbis --enable-libvpx --enable-libzvbi --disable-appkit --enable-libbs2b --enable-chromaprint --enable-libflite --disable-frei0r --disable-libfribidi --enable-fontconfig --disable-ladspa --enable-libass --enable-libfreetype --enable-librubberband --disable-libzmq --enable-libzimg --enable-libsoxr --enable-pthreads --enable-libvo-amrwbenc --enable-libmp3lame --enable-libkvazaar --disable-nvenc --enable-libopenh264 --enable-libsnappy --enable-libtheora --enable-libtwolame --disable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxvid --disable-frei0r --disable-libzmq --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-vfpv3 --disable-armv8 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-amd3dnow --disable-amd3dnowext --disable-avx2 --disable-fma3 --disable-fma4 --disable-xop --enable-pic --disable-asm --cpu=sandybridge --disable-doc --disable-htmlpages --disable-manpages
ERROR: opencl not found

# eselect opencl list
Available OpenCL implementations:
  [1]   intel *
  [2]   mesa

# nice -n 19 emerge --info =media-video/ffmpeg-3.4.2-r1
Portage 2.3.24 (python 2.7.14-final-0, default/linux/amd64/17.0/desktop, gcc-6.4.0, glibc-2.25-r11, 4.16.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.16.12-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.4.1
KiB Mem:    16350760 total,   1874652 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Fri, 01 Jun 2018 13:00:01 +0000
Head commit of repository gentoo: 0456e59957c02e5018c82a06974010562b82633a
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.8::gentoo, 3.5.5::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.12.6-r2::gentoo, 1.13.4-r2::gentoo, 1.14.1-r2::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r11::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts: 

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

barzog-overlay
    location: /mnt/gentoo/layman/barzog-overlay
    masters: gentoo
    priority: 50

gentoo-mate
    location: /mnt/gentoo/layman/gentoo-mate
    masters: gentoo
    priority: 50

java
    location: /mnt/gentoo/layman/java
    masters: gentoo
    priority: 50

prism-overlay
    location: /mnt/gentoo/layman/prism-overlay
    masters: gentoo
    priority: 50

python
    location: /mnt/gentoo/layman/python
    masters: gentoo
    priority: 50

rion
    location: /mnt/gentoo/layman/rion
    masters: gentoo
    priority: 50

science
    location: /mnt/gentoo/layman/science
    masters: gentoo
    priority: 50

seden
    location: /mnt/gentoo/layman/seden
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=sandybridge -fomit-frame-pointer -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/gnupg/qualified.txt /var/spool/fax/etc /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/apache2-php7.1/ext-active/ /etc/php/apache2-php7.2/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cgi-php7.2/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/php/cli-php7.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=sandybridge -fomit-frame-pointer -O2 -pipe"
DISTDIR="/mnt/gentoo/distfiles/"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
INSTALL_MASK="/usr/lib/systemd/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB en en_US de_DE de"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/mnt/gentoo/tmp"
USE="R X X509 a52 aac aalib accounting acl acpi adns aim aio alsa amd64 amr ansi ao aot apache2 apng applet archive ass audio audiofile automount avahi avx awt bacula-console bash-completion bazaar bcmath berkdb bidi bind-mysql bittorrent blas bluetooth bluray bonobo boost bzip2 cacert cairo caja calendar caps ccache cdb cdda cddb cdio cdparanoia cdr cgi chipcard chroot clang colord command-args consolekit corefonts cpudetection cpulimit cracklib cramfs crypt cscope css csv ctype cups curl curlwrappers customlog cvs cvsgraph cxx cyrus dba dbi dbm dbus dbx devhelp device-mapper devmap dga dhcp dirac directfb djvu dlna dlopen dnsdb dri dri3 drm dts dv dvb dvd dvdr dvi ecc egl enchant encode excel exif expat faad fam fastcgi fat fdk ffmpeg fftw fits flac flash flatfile fltk fontconfig fonts fpx ftp fuse fusefs gallium gd gdal gdbm gdu geoip geos ggi gif gimp ginac git glib glpk glut gmp gnome-keyring gnuplot gpg gphoto2 graphviz gs gsf gsl gssapi gstreamer gtk gtk2 gtk3 gudev gzip h323 hardened hardenedphp hddtemp hdf5 hdri highlight hpn html http hunspell hwdb iconv icq icu idea idled idn imap imlib imlib2 inifile innodb int64 introspection ios ipalias ipc ipod ipv6 iso jabber jack java javascript jbig jingle jit jpeg jpeg2k json kdrive kerberos keymap kmod kpathsea lame lapack latex lcms ldap less libass libcaca libcerf libcxx libnotify libsamplerate libv4l libv4l2 libwww live llvm lm_sensors lmtp logrotate logwatch lua lz4 lzma lzo mad magic matroska mbox mcal md5sum memlimit mercurial metis mgetty mhash midi milter mime mimencode ming mmap mms mmx mmxext mng mp3 mp4 mpeg mplayer msn mtp multilib mumps musepack musicbrainz mysql mysqli nagios-dns nagios-game nagios-ntp nagios-ping nagios-ssh natspec ncurses net netboot netcdf netlink network network-uri networkmanager nfs nis nls nntp nptl nsplugin nss ntfs ntp oav ocaml ocamlopt ocatve octave odbc offensive ogg openal opencl openexr opengl openh264 openmp openrc openssh openssl orc osc oscar pam pam_chroot pam_console pam_timestamp pango parse-clocks pcf pci pcntl pcre pda pdf pdfkit pdflib perl pgo php pic plotutils png policykit portaudio posix postfix postgis postgres postproc postscript ppds procmail ps pulseaudio pwdb python qdbm qt5 quotas quvi radius raw rdesktop rdp readline recode reiserfs rpc rrdtool rss rtmp ruby samba sample sasl scanner schroedinger scotch screen sendfile sensord session sftp sftplogging shaper shared sharedext shorten sieve simplexml slang slp smartcard smime smp sms smtp sna sndfile snmp snortsam soap sockets socks5 sound sox spamassassin sparse spatialite speex spell spice spl sql sqlite sqlite3 sse sse2 sse3 sse4 sse4_1 ssh ssl ssse3 stream subversion svg sysfs syslog sysvipc szip t1lib taglib tcpd telepathy test-programs theora threads tidy tiff timidity tokenizer tools transparent-proxy truetype truetype-fonts tslib twolame type1-fonts udev udisks unicode upnp upnp-av upower usb userlocales utf8 uuid v4l vaapi vala vcd vdpau vhosts video vim-syntax virtual-users virus-scan vnc vorbis vpx vte wayland wddx weather webdav webkit webm webp wifi win32codecs withsamplescripts wmf x264 x265 xattr xcb xcomposite xetex xface xfs xft xinerama xinetd xml xml2 xmlrpc xmp xmpp xorg xosd xpdf-headers xpm xps xrandr xscreensaver xsl xslt xv xvfb xvid xvmc xz yahoo yaml yaz zlib zvbi" ABI_X86="32 64" APACHE2_MODULES="access auth auth_basic auth_digest authn_default authn_core authn_file authn_dbm authn_dbd authn_alias authn_anon authz_core authz_groupfile authz_host authz_user authz_dbd authz_dbm authz_owner authz_default dbd ident imagemap alias echo charset_lite cache file_cache disk_cache mem_cache ext_filter case_filter case-filter-in deflate filter mime_magic cern_meta proxy proxy_connect proxy_ftp http2 proxy_html proxy_http proxy_ajp proxy_balancer proxy_fcgi proxy_wstunnel expires headers usertrack info include cgi cgid dav dav_lock dav_fs vhost_alias speling rewrite log_config logio env setenvif mime status substitute autoindex asis negotiation dir imap actions userdir so unique_id version dumpio log_forensic reqtimeout socache_shmcb unixd slotmem_shm ratelimit remoteip lbmethod_bybusyness lbmethod_byrequests lbmethod_bytraffic lbmethod_heartbeat xml2enc brotli watchdog" APACHE2_MPMS="worker" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4 sse4_1 sse4_2 ssse3" CURL_SSL="openssl" ELIBC="glibc" FFTOOLS="cws2fws ffhash pktdumper sidxindex qt-faststart aviocat ismindex" GPSD_PROTOCOLS="aivdm sirf mtk3301 gpsclock superstar2 timing nmea" GRUB_PLATFORMS="pc multiboot efi coreboot efi-64" INPUT_DEVICES="keyboard mouse evdev wacom synaptics" KERNEL="linux" L10N="en_GB en en_US de_DE de" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer nlpsolver pdfimport wiki-publisher" LLVM_TARGETS="X86 NVPTX" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1 php7-2" POSTGRES_TARGETS="postgres9_6 postgres10" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby23" SANE_BACKENDS="net hp" USERLAND="GNU" VIDEO_CARDS="vga intel i915 i965 fbdev vesa" XFCE_PLUGINS="clock multiload-nandhp power trash"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Thomas Beutin 2018-06-04 01:32:17 UTC
Created attachment 534722 [details]
build.log
Comment 2 Thibaud "thican" CANALE 2018-06-16 16:04:08 UTC
Created attachment 536060 [details]
emerge --info 'media-video/ffmpeg'

Hello everyone,

I met the same compilation failure when I (re)compiled media-video/ffmpeg-3.4.2-r1 after updating media-libs/mesa without "opencl" USE flag (only for Radeon GPU?).

In ffmpeg's ebuild, opencl USE flag only call virtual/opencl for dependency check:
opencl? ( virtual/opencl[${MULTILIB_USEDEP}] )

In virtual/opencl, the dependency check is satisfied even with media-libs/mesa[-opencl]; I guess this virtual ebuild should provide more verification.

Here more information about my system:
% eselect opencl list
Available OpenCL implementations:
  [1]   nvidia *

Note: compiles with success when built without opencl USE flag, if disabled too in mesa.
Comment 3 jeremy mills 2018-06-18 18:00:08 UTC
Created attachment 536250 [details]
emerge --info
Comment 4 jeremy mills 2018-06-18 18:03:51 UTC
I can comfirm this. Its not just ffmpeg with USE=opencl though. all of the wine packages also fail if built with USE=opencl. i use the nvidia opencl implementation which ive always used. and has always worked. up until the change with mesa.

jeremy-laptop ~ # eselect opencl list 
Available OpenCL implementations:
  [1]   nvidia *
Comment 5 Alex Turbov 2018-06-20 04:00:40 UTC
(In reply to jeremy mills from comment #4)
> I can comfirm this. Its not just ffmpeg with USE=opencl though. all of the
> wine packages also fail if built with USE=opencl. i use the nvidia opencl
> implementation which ive always used. and has always worked. up until the
> change with mesa.
> 
> jeremy-laptop ~ # eselect opencl list 
> Available OpenCL implementations:
>   [1]   nvidia *

+1 Same for me here.
Comment 6 Jan Ziak (atomsymbol) 2018-09-24 09:17:49 UTC
Reemerging app-eselect/eselect-opencl resolved the issue on my machine. Please confirm.
Comment 7 Enne Eziarc 2018-10-12 01:11:35 UTC
(In reply to Jan Ziak (http://atom-symbol.net) from comment #6)
> Reemerging app-eselect/eselect-opencl resolved the issue on my machine.
> Please confirm.

Seems to have fixed the problem for me (ffmpeg 4.0.2).
Comment 8 jospezial 2018-10-13 15:48:56 UTC
eselect opencl list
Available OpenCL implementations:
  [1]   mesa *
  [2]   ocl-icd
jlgentoo ~ # eselect opencl set 2
Switching to ocl-icd OpenCL interface... done
jlgentoo ~ # eselect opencl set 1
!!! Error: The mesa OpenCL implementation doesn't seem to provide
!!! Error: libOpenCL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenCL implementation.
!!! Error: Selected OpenCL implementation incomplete.
exiting



(In reply to Jan Ziak (http://atom-symbol.net) from comment #6)
> Reemerging app-eselect/eselect-opencl resolved the issue on my machine.
> Please confirm.

That removed the mesa entry.

Calculating dependencies... done!
[ebuild   R    ] app-eselect/eselect-opencl-1.1.0-r4::gentoo  0 KiB
[ebuild   R   *] media-libs/mesa-9999::gentoo  USE="classic d3d9 dri3 egl gallium gbm llvm lm_sensors opencl vaapi vdpau vulkan wayland xvmc -debug -gles1 -gles2 -osmesa -pax_kernel -pic (-selinux) -test -unwind -valgrind -xa" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="r600 radeon radeonsi (-freedreno) -i915 -i965 (-imx) -intel -nouveau -r100 -r200 -r300 (-vc4) -virgl (-vivante) -vmware" 0 KiB
[ebuild   R   #] media-video/ffmpeg-9999:0/56.58.58::gentoo  USE="X alsa bluray bzip2 cdio encode fdk fontconfig gme gpl gsm hardcoded-tables iconv jack jpeg2k ladspa libaom libass libcaca libdrm libressl librtmp libv4l lv2 lzma modplug mp3 network openal opencl opengl openh264 openssl opus postproc pulseaudio rubberband sdl speex ssh svg theora threads truetype twolame v4l vaapi vdpau vorbis vpx wavpack webp x264 x265 xcb xvid zlib zvbi (-altivec) -amr -amrenc (-appkit) -bs2b -chromaprint -chromium -codec2 -cpudetection -debug -doc -flite -frei0r -fribidi -gcrypt -gmp -gnutls -iec61883 -ieee1394 -kvazaar -libilbc -libsoxr (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -oss -pic -samba -snappy -static-libs -test -zeromq -zimg" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3 -3dnow -3dnowext -aes -avx -avx2 -fma3 -fma4 -sse4_1 -sse4_2 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher" VIDEO_CARDS="-nvidia" 0 KiB
Comment 9 jospezial 2018-10-31 12:20:06 UTC
fixed with
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=60b2ce2f2263283cefbdec34b620aca439212315

"media-libs/mesa: Add MULTILIB_USEDEP to ocl-icd
Closes: https://github.com/gentoo/gentoo/pull/10209"
Comment 10 Alexis Ballier gentoo-dev 2019-02-13 15:15:51 UTC
(In reply to jospezial from comment #9)
> fixed with
> https://gitweb.gentoo.org/repo/gentoo.git/commit/
> ?id=60b2ce2f2263283cefbdec34b620aca439212315
> 
> "media-libs/mesa: Add MULTILIB_USEDEP to ocl-icd
> Closes: https://github.com/gentoo/gentoo/pull/10209"

closing then