Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 656684 - net-analyzer/wireshark-2.6.1[qt5] with dev-qt/*-5.11.0_rc2 - .../work/wireshark-2.6.1/ui/qt/packet_format_group_box.cpp:21:18: error: aggregate ‘QStyleOption style_opt’ has incomplete type and cannot be defined
Summary: net-analyzer/wireshark-2.6.1[qt5] with dev-qt/*-5.11.0_rc2 - .../work/wiresha...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords: PATCH
: 656832 (view as bug list)
Depends on:
Blocks: qt-5.11
  Show dependency tree
 
Reported: 2018-05-27 14:15 UTC by Markus Rathgeb
Modified: 2018-06-04 16:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
wireshark-2.6.0-r2-qt-5.11.patch (wireshark-2.6.0-r2-qt-5.11.patch,1.18 KB, patch)
2018-05-27 14:15 UTC, Markus Rathgeb
Details | Diff
wireshark-2.6.1-qt-5.11.patch (wireshark-2.6.1-qt-5.11.patch,1.17 KB, patch)
2018-05-30 15:51 UTC, Markus Rathgeb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Rathgeb 2018-05-27 14:15:41 UTC
Created attachment 533524 [details, diff]
wireshark-2.6.0-r2-qt-5.11.patch

The build fails because of using incomplete type QStyleOption.
After this has been fixes there is another one.

Qt version: 5.11.0_rc2
Comment 1 Andreas Sturmlechner gentoo-dev 2018-05-27 17:28:14 UTC
(In reply to Markus Rathgeb from comment #0)
> The build fails because of using incomplete type QStyleOption.
> After this has been fixes there is another one.
I'm confused, is this patch not complete?
Comment 2 Markus Rathgeb 2018-05-27 22:15:35 UTC
It is complete, it fixes two files (the first error and the second one that you will realize if the first one has been fixed and the build stops at the other one).
Sorry for the confusion, just want to state that you will only see the first one in the build log (and so I did not attach one).
Comment 3 Markus Rathgeb 2018-05-30 15:51:09 UTC
Created attachment 534070 [details, diff]
wireshark-2.6.1-qt-5.11.patch
Comment 4 Markus Rathgeb 2018-05-30 15:54:37 UTC
It seems this has already been solved in upstream master.
https://code.wireshark.org/review/#/c/27145/

Can you add the patch for 2.6.1 to tree?
Comment 5 Markus Rathgeb 2018-06-04 11:34:45 UTC
Has been fixed by https://github.com/gentoo/gentoo/commit/bd310499ec0055ecb7fb91b69cffa1fabdfe02ba

A similar issue has been reported here #656832
Comment 6 Jeroen Roovers gentoo-dev 2018-06-04 16:36:08 UTC
*** Bug 656832 has been marked as a duplicate of this bug. ***