Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 656174 - dev-libs/poco-1.4.6_p4-r1 : /.../pcre.h:325:33: error: conflicting declaration typedef struct real_pcre8_or_16 pcre
Summary: dev-libs/poco-1.4.6_p4-r1 : /.../pcre.h:325:33: error: conflicting declaratio...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: David
URL:
Whiteboard:
Keywords:
Depends on: 609252
Blocks:
  Show dependency tree
 
Reported: 2018-05-20 17:53 UTC by Toralf Förster
Modified: 2021-03-10 00:19 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.10 KB, text/plain)
2018-05-20 17:53 UTC, Toralf Förster
Details
dev-libs:poco-1.4.6_p4-r1:20180520-174022.log (dev-libs:poco-1.4.6_p4-r1:20180520-174022.log,354.30 KB, text/plain)
2018-05-20 17:53 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,77.45 KB, text/plain)
2018-05-20 17:53 UTC, Toralf Förster
Details
environment (environment,94.99 KB, text/plain)
2018-05-20 17:53 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,11.25 KB, application/x-bzip)
2018-05-20 17:53 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,26.51 KB, application/x-bzip)
2018-05-20 17:53 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-05-20 17:53:39 UTC
In file included from src/RegularExpression.cpp:41:0:
/usr/include/pcre.h:325:33: error: conflicting declaration ‘typedef struct real_pcre8_or_16 pcre’
 typedef struct real_pcre8_or_16 pcre;
                                 ^~~~
In file included from src/RegularExpression.cpp:37:0:

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-hardened_20180519-101508

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)
  [3]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *



emerge -qpv dev-libs/poco
[ebuild  N    ] dev-libs/poco-1.4.6_p4-r1  USE="ssl -doc -examples -iodbc -libressl -mysql -odbc -sqlite {-test}"
Comment 1 Toralf Förster gentoo-dev 2018-05-20 17:53:41 UTC
Created attachment 532348 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-05-20 17:53:44 UTC
Created attachment 532350 [details]
dev-libs:poco-1.4.6_p4-r1:20180520-174022.log
Comment 3 Toralf Förster gentoo-dev 2018-05-20 17:53:47 UTC
Created attachment 532352 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2018-05-20 17:53:50 UTC
Created attachment 532354 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2018-05-20 17:53:53 UTC
Created attachment 532356 [details]
etc.portage.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-05-20 17:53:56 UTC
Created attachment 532358 [details]
temp.tbz2
Comment 7 Sammy Pfeiffer 2018-12-30 12:47:22 UTC
I confirm I'm having the same problem.

I'm having this version pulled cause 1.9.0 is conflicting:

emerge =dev-libs/poco-1.9.0 --backtrack=30 --verbose-conflicts

 * IMPORTANT: 13 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies  ... .... done!
[ebuild     UD ] dev-libs/openssl-1.0.2q [1.1.0j] USE="sslv3%* tls-heartbeat* -gmp% -kerberos% -sslv2%" 
[ebuild  N     ] dev-libs/poco-1.9.0  USE="crypto data file2pagecompiler json mongodb net pagecompiler ssl util xml zip -7z -apache -cppparser -examples -iodbc -libressl -mysql -odbc -pdf -pocodoc -sqlite -test" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2q:0/0::gentoo, ebuild scheduled for merge) pulled in by
    <dev-libs/openssl-1.1.0:0 required by (dev-libs/poco-1.9.0:0/0::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^^^                                                                           
    <dev-libs/openssl-1.1.0:0[bindist=] required by (net-misc/openssh-7.9_p1-r1:0/0::gentoo, installed)
    ^                 ^^^^^^^                                                                           

  (dev-libs/openssl-1.1.0j:0/1.1::gentoo, installed) pulled in by
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.3:0/13::gentoo, installed)
                    ^^^^^^^                                                                                
    dev-libs/openssl:0/1.1= required by (dev-vcs/git-2.20.1:0/0::gentoo, installed)
                    ^^^^^^^                                                         
    dev-libs/openssl:0/1.1= required by (net-misc/wget-1.20.1:0/0::gentoo, installed)
                    ^^^^^^^                                                           
    dev-libs/openssl:0/1.1= required by (net-misc/openssh-7.9_p1-r1:0/0::gentoo, installed)
                    ^^^^^^^                                                                 
    dev-libs/openssl:0/1.1= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
                    ^^^^^^^                                                                  
    dev-libs/openssl:0/1.1= required by (dev-lang/python-3.6.6:3.6/3.6m::gentoo, installed)
                    ^^^^^^^                                                                 
    dev-libs/openssl:0/1.1= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
                    ^^^^^^^                                                                 
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (net-misc/curl-7.63.0-r1:0/0::gentoo, installed)
                    ^^^^^^^                                                                             
    dev-libs/openssl:0/1.1=[abi_x86_64(-)] required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
                    ^^^^^^^
Comment 8 concavemail 2019-01-10 01:48:37 UTC
I was able to make progress by downgrading libpcre to 8.41-r1. However, this leads to a new error regarding an incomplete type with EVP_CIPHER_CTX which I have failed to hunt down.
Comment 9 concavemail 2019-01-10 01:49:04 UTC
I was able to make progress by downgrading libpcre to 8.41-r1. However, this leads to a new error regarding an incomplete type with EVP_CIPHER_CTX which I have failed to hunt down.
Comment 10 concavemail 2019-01-10 05:41:35 UTC
In my case, modifying the poco-1.9.0 ebuild to allow openssl-1.1.x allowed poco-1.9.0 to satisfy the dependencies which were locking me to 1.4.6. This solved my issues, in case this helps anyone else.
Comment 11 Martin Cyr 2019-03-18 21:09:46 UTC
(In reply to concavemail from comment #10)
> In my case, modifying the poco-1.9.0 ebuild to allow openssl-1.1.x allowed
> poco-1.9.0 to satisfy the dependencies which were locking me to 1.4.6. This
> solved my issues, in case this helps anyone else.

I can also confirm that this did allow a successful build of dev-libs/poco-1.9.0-r1 against dev-libs/openssl-1.1.0j-r1.
Comment 12 Oleg 2019-03-26 19:03:34 UTC
Got same error for media-libs/opencollada-1.6.58 and dev-libs/libpcre-8.42