Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 65504 - When installing dbus 0.22-r1 with qt in the USE flags it fails
Summary: When installing dbus 0.22-r1 with qt in the USE flags it fails
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: foser (RETIRED)
Depends on:
Blocks: 66864
  Show dependency tree
Reported: 2004-09-27 01:57 UTC by Greg
Modified: 2004-12-29 10:40 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

adds kdelibs to a list of QT use flag requirements (dbus-0.22-r1.ebuild.diff,88 bytes, patch)
2004-10-02 03:02 UTC, Andrew Luecke
Details | Diff
The config.log of the failed building (config.log,73.84 KB, text/plain)
2004-10-02 05:08 UTC, Andrew Luecke
dbus-0.22-qt.patch (dbus-0.22-qt.patch,2.14 KB, patch)
2004-12-13 05:16 UTC, Heinrich Wendel (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg 2004-09-27 01:57:27 UTC
While trying to install dbus 0.22-r1 with qt in the USE flags, during the configure step of the ebuild it fails complaining that qt development libraries arn't installed. dbus compiles if qt is removed from the USE flags.

Reproducible: Always
Steps to Reproduce:
1.USE="qt" emerge dbus

Actual Results:  
checking for moc... /usr/qt/3/bin/moc
checking for qglobal.h... found
configure: WARNING: Qt development libraries not found
configure: error: Qt integration explicitly required, and Qt libraries not found
!!! ERROR: sys-apps/dbus-0.22-r1 failed.
!!! Function econf, Line 441, Exitcode 1
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

Expected Results:  
dbus installs with qt bindings

Portage 2.0.51_rc1 (default-x86-2004.2, gcc-3.4.2, glibc-,
System uname: 2.6.8-gentoo-r4 i686 Celeron (Coppermine)
Gentoo Base System version 1.5.3
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-march=pentium3 -O3 -fforce-addr -falign-functions=4
-fprefetch-loop-arrays -mfpmath=sse,387 -pipe -fomit-frame-pointer
-funroll-loops -fstack-protector"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium3 -O3 -fforce-addr -falign-functions=4
-fprefetch-loop-arrays -mfpmath=sse,387 -pipe -fomit-frame-pointer
-funroll-loops -fstack-protector"
FEATURES="autoaddcvs ccache sandbox"
USE="3dfx X Xaw3d aalib aim alsa amd apm audiofile avi bdf berkdb bidi
bitmap-fonts bonobo bootsplash cdparanoia cdr cdrom chroot cjk codecs crypt cups
curl curlwrappers directfb divx4linux djbfft doc dts dv dvd dvdr dvdread edl eds
encode erandom esd ethereal evo exif f77 faac faad fam fbcon ffmpeg fftw flac
flash foomaticdb freetype fs ftp gcj gdbm geoip ggi gif gimp gimpprint gnome
gnutls gphoto2 gpm graphviz gs gstreamer gtk gtk2 gtkhtml guile hal iconv icq
icu idea imagemagick imap imlib imlib2 intl ipv6 irda irmc j2ee jabber java
javacomm javadoc javamail javascript jbig jce jikes jp2 jpeg junit kerberos lcms
libcaca libg++ libwww live lzo lzw lzw-tiff m17n-lib mad matroska mdb mikmod
mime ming mmx mng monkey mono motif mozilla moznoirc moznomail mozp3p mozsvg mp3
mpeg mpeg4 mplayer msn ncurses net network nls nntp nptl ntlm objc offensive
oggvorbis opengl oscar oss pam pcmcia pdf pdflib perl png pnp python qt
quicktime quotes readline rtc samba sdl server silc slang sndfile snmp soap
sockets speedo speex spell sse ssl svg svga tcltk tcpd theora tidy tiff timidity
transcode truetype trusted unicode usb uudeview v4l v4l2 vim vim-with-x wifi wmf
wxwindows x86 xchatdccserver xml xml2 xmms xpm xprint xrandr xsl xv xvid xvmc
yahoo yv12 zlib"
Comment 1 foser (RETIRED) gentoo-dev 2004-09-27 08:38:57 UTC
dunno, you do have qt installed ?

post the config.log of the failing configure...
Comment 2 Andrew Luecke 2004-10-02 02:42:55 UTC
Kdelibs needs to be set as a dependency for the qt use flag. After emerging kdelibs, it worked for me. 

Comment 3 Andrew Luecke 2004-10-02 03:02:57 UTC
Created attachment 40912 [details, diff]
adds kdelibs to a list of QT use flag requirements
Comment 4 Andrew Luecke 2004-10-02 03:05:12 UTC
added a patch, my first attempt at bug fixing in gentoo.

When the QT use flag is enabled, KDElibs is required.

I have tested this patch with kdelibs enabled, disabled, and toggling the qt use flag. It fixes the problem
Comment 5 foser (RETIRED) gentoo-dev 2004-10-02 04:35:13 UTC
could someone of the KDE team check & confirm ? It seems odd to me it would need kdelibs.
Comment 6 Andrew Luecke 2004-10-02 05:08:40 UTC
Created attachment 40917 [details]
The config.log of the failed building

This is my config.log for when before I installed kdelibs it failed which may
help diagnose what exactly in kdelibs it seems to need
Comment 7 Gregorio Guidi (RETIRED) gentoo-dev 2004-10-02 07:04:20 UTC

 if test -n "$QTDIR" -a -f "$QTDIR/include/qglobal.h"; then
 if test x"$have_qt" = x"yes"; then
    AC_MSG_RESULT([not found])

 dnl linking to kdecore will give us a bit of help from libtool
 if (! kde-config >& /dev/null); then
     kdelibs=`kde-config --install lib --expandvars 2>/dev/null`
     if test -z $kdelibs -o ! -f $kdelibs/; then

 if test x$have_qt = xno ; then
     AC_MSG_WARN([Qt development libraries not found])

kdelibs is not used in any way, it should be asked to the freedesktop guys why
they don't just do something like
Comment 8 Greg Kroah-Hartman (RETIRED) gentoo-dev 2004-10-07 14:33:05 UTC
I can confirm this bug is there, and merging kdelibs fixes it...
Comment 9 Thomas Matthijs (RETIRED) gentoo-dev 2004-10-09 03:18:41 UTC
failed for me with kdelibs(3.3.0) installed, investigating
Comment 10 Thomas Matthijs (RETIRED) gentoo-dev 2004-10-09 04:48:08 UTC
hmm, worked after remering kdelibs
Comment 11 foser (RETIRED) gentoo-dev 2004-10-09 05:27:53 UTC
i think comment #7 is on the right track, but i have no qt atm so I can't really check myself. The direction imho to go is not adding a kdelibs dep when it is only needed for the configure script, but to fix the configure script itself. If someone could do the works there, it would be appreciated.
Comment 12 Gregorio Guidi (RETIRED) gentoo-dev 2004-10-09 06:55:09 UTC
Someone with a freedesktop bugzilla account can also add a comment here:
Comment 13 foser (RETIRED) gentoo-dev 2004-10-15 09:15:33 UTC
disabling the qt bindings for now, waiting for an acceptable patch.
Comment 14 foser (RETIRED) gentoo-dev 2004-10-27 08:35:11 UTC
took the easy way out here, but apperantly theres not much animo to get it fixed.
Comment 15 Simone Gotti (RETIRED) gentoo-dev 2004-11-05 03:53:23 UTC
I think that the unique use of the is the fact that is difficult to know where libqt-mt is installed, (if QTDIR is defined like in gentoo it's easy...).

So the author speeded up things linking to libkdecore (that is linked to libqt-mt) because kde-config report easily its location.

A good patch can be a better qt check like the one (very big) that is done inside the kdepackages.
Comment 16 Heinrich Wendel (RETIRED) gentoo-dev 2004-12-13 05:16:15 UTC
Created attachment 45903 [details, diff]

I attached a patch to enable the qt bindings with a fixed and some
updates from cvs, i think this patch is important because kde-3.4_alpha1 can
make use of dbus when the qt bindings are installed
Comment 17 Heinrich Wendel (RETIRED) gentoo-dev 2004-12-13 07:16:25 UTC
I attached a patch to enable the qt bindings with a fixed and some
updates from cvs, i think this patch is important because kde-3.4_alpha1 can
make use of dbus when the qt bindings are installed
Comment 18 Heinrich Wendel (RETIRED) gentoo-dev 2004-12-29 10:40:33 UTC
commited the patch