Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 654528 - arm stages critically outdated
Summary: arm stages critically outdated
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Stages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
: 654994 (view as bug list)
Depends on:
Blocks: glibc-2.26-stable
  Show dependency tree
 
Reported: 2018-05-01 12:55 UTC by Andreas K. Hüttel
Modified: 2018-11-26 19:02 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel archtester gentoo-dev 2018-05-01 12:55:57 UTC
The last published arm stages (even autobuilds) are from 2016, and still contain gcc-4. 

This gcc does not build recent glibc releases (>=2.26) anymore.
Comment 1 Michael 'veremitz' Everitt 2018-05-02 03:44:26 UTC
Releases available at https://files.emjay-embedded.co.uk/unofficial-gentoo/arm-stages/ contain gcc-6.4.0-r1 currently.

RESO:FIXED
Comment 2 Daniel Cordero 2018-05-02 12:34:22 UTC
The armv7a_hardfp stage3 (dated 2016-11-29) contains a populated ./tmp/stage1root.

This:
1) wastes disk space (when uncompressed);
2) prevents using the stage3 tarball as a catalyst seed stage to build a newer stage1, due to conflicts with the old version of sandbox and stable versions in a current portage tree.
Comment 3 Michael 'veremitz' Everitt 2018-05-02 12:51:12 UTC
(In reply to Daniel Cordero from comment #2)
> The armv7a_hardfp stage3 (dated 2016-11-29) contains a populated
> ./tmp/stage1root.
> 
> This:
> 1) wastes disk space (when uncompressed);
> 2) prevents using the stage3 tarball as a catalyst seed stage to build a
> newer stage1, due to conflicts with the old version of sandbox and stable
> versions in a current portage tree.

99% sure this has been fixed on one of the many updates to catalyst, and /tmp is completely cleaned out. It shouldn't even reach the stage 2 let alone the 3!!
Comment 4 Harri Nieminen (Moiman) 2018-05-05 19:18:23 UTC
*** Bug 654994 has been marked as a duplicate of this bug. ***
Comment 5 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-11-26 19:02:41 UTC
we have newer at distfiles.g.o as I see this