Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 654404 - media-video/harvid-0.8.2 : ffdecoder.c:321:21: error: invalid initializer
Summary: media-video/harvid-0.8.2 : ffdecoder.c:321:21: error: invalid initializer
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-30 08:27 UTC by Toralf Förster
Modified: 2018-04-30 19:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.34 KB, text/plain)
2018-04-30 08:27 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,195.78 KB, text/plain)
2018-04-30 08:28 UTC, Toralf Förster
Details
environment (environment,72.63 KB, text/plain)
2018-04-30 08:28 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,13.33 KB, application/x-bzip)
2018-04-30 08:28 UTC, Toralf Förster
Details
media-video:harvid-0.8.2:20180430-082355.log (media-video:harvid-0.8.2:20180430-082355.log,7.25 KB, text/plain)
2018-04-30 08:28 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,18.98 KB, application/x-bzip)
2018-04-30 08:28 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-04-30 08:27:55 UTC
                     ^~~~~~~~~~~~~~~~~~~~~~~~~~
                     av_stream_get_side_data
ffdecoder.c:321:21: error: invalid initializer
ffdecoder.c: In function ‘ff_open_movie’:
ffdecoder.c:410:5: warning: ‘codec’ is deprecated [-Wdeprecated-declarations]
     if(ff->pFormatCtx->streams[i]->codec->codec_type == AVMEDIA_TYPE_VIDEO)

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0_ffmpeg4_20180425-210301

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   pypy3 (fallback)
  [5]   pypy (fallback)
Available Ruby profiles:
  [1]   ruby23 (with Rubygems) *
java-config:
The following VMs are available for generation-2:


emerge -qpv media-video/harvid
[ebuild  N    ] media-video/harvid-0.8.2  USE="libav"
Comment 1 Toralf Förster gentoo-dev 2018-04-30 08:27:58 UTC
Created attachment 529050 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-04-30 08:28:02 UTC
Created attachment 529052 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-04-30 08:28:05 UTC
Created attachment 529054 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-04-30 08:28:08 UTC
Created attachment 529056 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-04-30 08:28:11 UTC
Created attachment 529058 [details]
media-video:harvid-0.8.2:20180430-082355.log
Comment 6 Toralf Förster gentoo-dev 2018-04-30 08:28:14 UTC
Created attachment 529060 [details]
temp.tbz2
Comment 7 Alexis Ballier gentoo-dev 2018-04-30 19:16:48 UTC
USE=libav