Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 65347 - ALSA upgrade breaks rhythmbox-0.8.5
Summary: ALSA upgrade breaks rhythmbox-0.8.5
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2004-09-25 13:27 UTC by Chris Rebert
Modified: 2004-11-10 10:41 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

output from rhythmbox in debug mode (rhythmlog,60.50 KB, text/plain)
2004-09-25 13:31 UTC, Chris Rebert

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Rebert 2004-09-25 13:27:08 UTC
Upgrading ALSA and it's associated packages breaks rhythmbox. I've tried reemerging rhythmbox but that still doesn't fix it.

Reproducible: Always
Steps to Reproduce:
1. Check that the following packages are at these versions:

2. Install rhythmbox-0.8.5
3. Upgrade the aformentioned packages to these versions:
4. Run rhythmbox and try to play an audio file or playlist
Actual Results:  
rhythmbox crashes, on console, error is "Segmentation fault"

Expected Results:  
it should have played the file/playlist successfully

Portage 2.0.50-r11 (default-x86-2004.0, gcc-3.3.4, glibc-, 2.6.
System uname: 2.6.8-gentoo-r1 i686 AMD Athlon(tm) XP
Gentoo Base System version 1.4.16
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -fprefetch-loop-arrays -
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2
/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/
config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/shar
e/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf
/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -fprefetch-loop-arrays
FEATURES="autoaddcvs ccache sandbox sfperms userpriv usersandbox"
USE="X acl acpi alsa apm avi berkdb bitmap-fonts bonobo bzlib calendar caps cddb
 cdr chroot clanJavaScript clanVoice crypt ctype cups curl curlwrappers dba dbm
dbx dga divx4linux droproot dv dvd dvdr encode esd exif fam flac flatfile foomat
icdb fs ftp gd gdbm gif gimp gimpprint gmp gnome gnomedb gnutls gphoto2 gpm gstr
eamer gtk gtk2 gtkhtml guile iconv ieee1394 imagemagick imap imlib inifile ipv6
jabber java jbig jce jp2 jpeg ladcca lcms libg++ libwww lzw mad maildir mbox md5
sum mhash mikmod mime mmx mmx2 mng mozilla moznocompose moznoirc moznomail mozp3
p mozsvg mpeg mpi music native ncurses network nls no_wxgtk1 nocd nomac odbc ogg
vorbis opengl oss pam pcntl pcre pdf pdflib perl png posix ppds python quicktime
 radeon readline recode rtc sasl scanner sdl session sftplogging skey slang slp
smime sockets speex spell sse sse2 ssl svg svga sysvipc tcltk tcpd tetex theora
tidy tiff truetype unicode usb v4l2 video_cards_radeon wmf wxwin x86 xml2 xmlrpc
 xpm xprint xsl xv xvid xvmc zlib"
Comment 1 Chris Rebert 2004-09-25 13:31:50 UTC
Created attachment 40407 [details]
output from rhythmbox in debug mode
Comment 2 Chris Rebert 2004-09-25 13:49:15 UTC
reemerging gstreamer, gst-plugins-alsa, and gst-plugins-oss doesn't fix the problem either.
Comment 3 foser (RETIRED) gentoo-dev 2004-09-27 08:47:51 UTC
alsa API/ABI breakage. sound herd, can't 1.0.6 stay be ~arch until this gets fixed ? It's impossible to keep up with those surfs (hell its supposed to be a stable series).
Comment 4 Jeremy Huddleston (RETIRED) gentoo-dev 2004-09-27 21:27:34 UTC
foser:  I've put alsa-lib-1.0.6 back into ~arch until we can figure this out... but I am not entirely certain it is a problem with the public ALSA API changing... does rhythmbox mess with hidden internals that it shouldn't be?
Comment 5 Daniel Schindler 2004-09-28 01:54:24 UTC
it works with gstreamer 0.85 and gst-plugins-alsa 0.83
Comment 6 foser (RETIRED) gentoo-dev 2004-09-28 08:06:50 UTC
can the reporter or anyone that can reproduce post the exact output ?

@ Jeremy : well, it's gstreamer then, not rhythmbox. I'm not sure it's alsa breakage at this point, but it's not unlikely seeing it's history. 
Comment 7 Eric Hustvedt 2004-09-28 12:29:48 UTC
I have had a similar crash with monkey-bubble 0.3.2, which I was able to strace back to gstreamer's initialization.

Is it actually possible for open source developers to ever maintain a stable API? Better yet, could they design the API before coding the software?
Comment 8 John Heinig 2004-09-28 15:25:29 UTC
Actually designing a well thought out API that meets all the needs of the community is very difficult to do before you actually start doing the coding once you get beyond a simple interface.
Comment 9 Chris Rebert 2004-09-28 17:13:26 UTC
workin on it, recompiling alsa-* and going to run gst-launch-ext-0.8 /home/USERNAME/Music/SONG.flac
w/ AUDIOSINK = "alsasink" in ~.gst  Wish me luck!
Comment 10 Chris Rebert 2004-09-28 19:19:11 UTC
emerged synced, did below, and no error!
reemerged gstreamer, gst-plugins-alsa, and rhythmbox, and it all still works!
I'm stumped, but happy :-)
Comment 11 Eric Hustvedt 2004-09-28 20:08:43 UTC
I looked at the ALSA CVS repository, and the only change that I could see that might screw with things outside of the library involves the emu10k hwdep stuff. Basically, it looks like they added a bunch of stuff for the Audigy 2, and the CVS commit message mentions that it will break binary compatibility.

Why they didn't mention that in the release announcement/notes is beyond me.
Comment 12 foser (RETIRED) gentoo-dev 2004-09-29 02:24:24 UTC
do you have that (#11) for sound hardware Chris ?
Comment 13 Eric Hustvedt 2004-09-29 10:55:56 UTC
Here's the link to the CVS log for the appropriate file in ALSA's CVS repository:
Comment 14 Chris Rebert 2004-09-29 17:03:31 UTC
Yes, i use the Creative Labs Sound Blaster Audigy 2 soundcard. Perhaps alsa is/was only broken for that card?
Comment 15 Jeremy Huddleston (RETIRED) gentoo-dev 2004-10-11 02:44:49 UTC
so to confirm, Chris, after upgrading to alsa-lib-1.0.6 and reemerging the gst-plugin-alsa, it worked fine for you?
Comment 16 Chris Rebert 2004-10-11 16:40:16 UTC
Actually, I don't know what did it exactly, but I'd guess it was the upgrade to media-libs/gstreamer-0.8.5
Comment 17 foser (RETIRED) gentoo-dev 2004-10-12 08:52:57 UTC
if its really the alsi abi breakage (as it seems now only with specific hardware), then only the plugin should be rebuilt. This only clashes with comment #2, but the plugin is the only thing linking to alsa libs directly.
Comment 18 Jeremy Huddleston (RETIRED) gentoo-dev 2004-10-12 12:24:20 UTC
I'm going to close this on the assumption that it was the ABI breakaga as all signs point to that.  I'll add einfo to the alsa-lib ebuild and keep it in ~arch for a bit longer to make sure nothing else crops up from this ABI breakage.
Comment 19 Eric Hustvedt 2004-11-09 01:30:05 UTC
Hrmm... I'm stumped on this one. I just re-upgraded to 1.0.6 and all my alsa-lib dependent packages broke, in one way or another. On a whim, I created a .asoundrc file which pointed the default pcm device to hw 0,0 and it worked. In my strace of monkey-bubble, the only material difference was an attempt to open /dev/snd/controlC0 read only, as a means of testing for existence, and then closing and re-opening read-write.
Comment 20 David Grant 2004-11-10 08:14:37 UTC
So what should I do after emerging the new alsa-lib?  The einfo is a bit confusing.
Comment 21 Jeremy Huddleston (RETIRED) gentoo-dev 2004-11-10 10:41:43 UTC
if you use emu10k1, re-emerge everything that links against alsa-lib