Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 652926 - net-print/hplip-3.18.6 stable request
Summary: net-print/hplip-3.18.6 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Daniel Pielmeier
URL:
Whiteboard: Was: net-print/hplip-3.18.3 : prnt/.....
Keywords:
Depends on:
Blocks: gcc-7 gcc-7-stable
  Show dependency tree
 
Reported: 2018-04-10 16:13 UTC by Toralf Förster
Modified: 2018-09-18 01:18 UTC (History)
3 users (show)

See Also:
Package list:
net-print/hplip-3.18.6
Runtime testing required: ---
stable-bot: sanity-check+


Attachments
emerge-info.txt (emerge-info.txt,16.02 KB, text/plain)
2018-04-10 16:13 UTC, Toralf Förster
no flags Details
emerge-history.txt (emerge-history.txt,106.02 KB, text/plain)
2018-04-10 16:13 UTC, Toralf Förster
no flags Details
environment (environment,137.33 KB, text/plain)
2018-04-10 16:13 UTC, Toralf Förster
no flags Details
etc.portage.tbz2 (etc.portage.tbz2,11.86 KB, application/x-bzip)
2018-04-10 16:13 UTC, Toralf Förster
no flags Details
logs.tbz2 (logs.tbz2,10.79 KB, application/x-bzip)
2018-04-10 16:13 UTC, Toralf Förster
no flags Details
net-print:hplip-3.18.3:20180410-085452.log (net-print:hplip-3.18.3:20180410-085452.log,425.72 KB, text/plain)
2018-04-10 16:13 UTC, Toralf Förster
no flags Details
temp.tbz2 (temp.tbz2,44.47 KB, application/x-bzip)
2018-04-10 16:14 UTC, Toralf Förster
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2018-04-10 16:13:38 UTC
prnt/hpcups/genPCLm.cpp: In function ‘boolean writeOutputFile(int, ubyte*, char*)’:
prnt/hpcups/genPCLm.cpp:353:10: error: cannot convert ‘bool’ to ‘boolean’ in return
   return true;
          ^~~~
prnt/hpcups/genPCLm.cpp:367:13: error: cannot convert ‘bool’ to ‘boolean’ in return

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-developer_libressl-test_20180406-190612

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python2.7 (fallback)

java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.7.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpv net-print/hplip
[ebuild  N    ] net-print/hplip-3.18.3  USE="X hpcups libressl policykit qt5 snmp -doc -fax -hpijs -kde -libusb0 -minimal -parport -scanner -static-ppds" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
Comment 1 Toralf Förster gentoo-dev 2018-04-10 16:13:41 UTC
Created attachment 527064 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2018-04-10 16:13:45 UTC
Created attachment 527066 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2018-04-10 16:13:48 UTC
Created attachment 527068 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2018-04-10 16:13:50 UTC
Created attachment 527070 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2018-04-10 16:13:53 UTC
Created attachment 527072 [details]
logs.tbz2
Comment 6 Toralf Förster gentoo-dev 2018-04-10 16:13:56 UTC
Created attachment 527074 [details]
net-print:hplip-3.18.3:20180410-085452.log
Comment 7 Toralf Förster gentoo-dev 2018-04-10 16:14:00 UTC
Created attachment 527076 [details]
temp.tbz2
Comment 8 Daniel Pielmeier gentoo-dev 2018-04-23 19:21:03 UTC
I can not reproduce this with gcc-6.4.0-r1 so I suspect this is an issue with gcc-7.3.
Comment 9 Manfred Knick 2018-04-24 12:07:10 UTC
Hi, Toralf, Daniel,

# equery list hplip gcc

     [IP-] [  ] net-print/hplip-3.18.3-r1:0

     [IP-] [  ] sys-devel/gcc-7.3.0-r1:7.3.0


Re-building ("single-shot")

     [ebuild   R   ~] net-print/hplip-3.18.3-r1 

just WORKSFORME.

Unfortunately, atm, I don't have any HP actively running any more;
if desperately needed for differential analysis,
I could re-animate an old HP OfficeJet 600a
to test print / scan.


USE=
"X fax hpcups hpijs policykit qt5 scanner snmp -doc -kde -libressl -libusb0 -minimal -parport -static-ppds" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
Comment 10 Pacho Ramos gentoo-dev 2018-05-24 15:05:46 UTC
is this valid with 3.18.4?
Comment 11 Manfred Knick 2018-05-24 18:06:38 UTC
(In reply to Pacho Ramos from comment #10)
> is this valid with 3.18.4?
Atm,
  (net-print/hplip-3.18.4:0/0::gentoo, ebuild scheduled for merge) conflicts with
    ~net-print/hplip-3.18.3 required by (net-print/hplip-plugin-3.18.3:0/0::
                                                               gentoo, installed)
Comment 12 Manfred Knick 2018-05-25 08:35:33 UTC
(follow-up to comment #11)

# grep hplip ../package.use

  net-print/hplip    fax scanner snmp hpijs libnotify

# equery list net-print/hplip net-print/hplip-plugin

  [IP-] [  ] net-print/hplip-3.18.4:0
  [IP-] [  ] net-print/hplip-plugin-3.18.4:0

Both emerged successfully without any problems.
Comment 13 Pacho Ramos gentoo-dev 2018-05-25 16:20:18 UTC
Then probably that newer versions could be stabilized for gcc7 stabilization
Comment 14 Manfred Knick 2018-06-19 09:34:04 UTC
Pacho,
for "net-print/hplip-3.18.6", 
there is no corresponding "net-print/hplip-plugin-3.18.6" in tree;
only for .4 and .5 yet.
Comment 15 Manfred Knick 2018-06-19 09:45:22 UTC
CONFIRMATION:

[IP-] [  ] net-print/hplip-3.18.5:0
[IP-] [  ] net-print/hplip-plugin-3.18.5:0

emerge without any problem (amd64).
Comment 16 Manfred Knick 2018-06-19 09:51:16 UTC
(ADDENDUM to comment #14)

> there is no corresponding "net-print/hplip-plugin-3.18.6" in tree;
The needed version has been released upstream:

[ https://developers.hp.com/hp-linux-imaging-and-printing/gethplip ]

AFAICS from a quick look into hplip-plugin-3.18.5.ebuild,
simple copy-rename should be sufficient.
Comment 17 Thomas Deutschmann gentoo-dev 2018-06-19 12:56:28 UTC
x86 stable
Comment 18 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2018-06-23 14:05:59 UTC
amd64 stable
Comment 19 Manfred Knick 2018-06-26 09:02:34 UTC
(CORRECTION concerning my comment #16)

> The needed version has been released upstream:
https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

[ ]	hplip-3.18.6-plugin.run         25-Jun-2018 14:21
[TXT]	hplip-3.18.6-plugin.run.asc     25-Jun-2018 14:21
Comment 20 Daniel Pielmeier gentoo-dev 2018-06-30 08:47:20 UTC
@arch teams: Please continue stabilising hplip. I will not let the stabilisation progress slow down because of the plugins. hplip supports almost 2650 printers and only around 150 require the plugin [1]. hplip does not depend on hplip-plugin but the other way round. hplip-plugin is a testing only package. Users who unmask hplip-plugin should also be capable of masking hplip versions accordingly to have a working system.

Thanks in advance.

[1] https://developers.hp.com/hp-linux-imaging-and-printing/supported_devices/index
Comment 21 Markus Meier gentoo-dev 2018-07-08 10:46:25 UTC
arm stable
Comment 22 Matt Turner gentoo-dev 2018-09-18 01:18:54 UTC
ppc/ppc64 stable