Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 652842 - sys-firmware/ipxe [+binary +efi]: pre-built ipxe.efi not working in amd64 systems
Summary: sys-firmware/ipxe [+binary +efi]: pre-built ipxe.efi not working in amd64 sys...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Matthias Maier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-09 09:40 UTC by Tomohide Ishimaru
Modified: 2019-07-28 20:19 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomohide Ishimaru 2018-04-09 09:40:18 UTC
I used pre-built ipxe.efi for EFI-based pxe chainloading with dnsmasq+qemu(x86_64)+ovmf. 
Transferring file by tftp had succeeded, but ipxe.efi had not worked.
I compiled ipxe locally, used it instead of pre-built one, and then it worked fine.
I think pre-built one is x86 format compiled with BIN=bin-efi option. My locally build is compiled with BIN=bin-x86_64-efi.
Comment 1 Matthias Maier gentoo-dev 2019-07-28 20:14:21 UTC
Would you mind testing 1.0.0_p20190728 ?
Comment 2 Larry the Git Cow gentoo-dev 2019-07-28 20:19:59 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=c382bb6c08797635ad8d0bf1ec3b6263524850a7

commit c382bb6c08797635ad8d0bf1ec3b6263524850a7
Author:     Matthias Maier <tamiko@gentoo.org>
AuthorDate: 2019-07-28 20:15:23 +0000
Commit:     Matthias Maier <tamiko@gentoo.org>
CommitDate: 2019-07-28 20:19:41 +0000

    sys-firmware/ipxe: version bump to 1.0.0_p20190728
    
    Bug: https://bugs.gentoo.org/652842
    Package-Manager: Portage-2.3.69, Repoman-2.3.16
    Signed-off-by: Matthias Maier <tamiko@gentoo.org>

 sys-firmware/ipxe/Manifest                    |   2 +
 sys-firmware/ipxe/ipxe-1.0.0_p20190728.ebuild | 119 ++++++++++++++++++++++++++
 2 files changed, 121 insertions(+)