Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 651722 - =sys-process/atop-2.3.0 with sys-libs/ncurses 6.1 - atop output is corrupted
Summary: =sys-process/atop-2.3.0 with sys-libs/ncurses 6.1 - atop output is corrupted
Status: RESOLVED DUPLICATE of bug 648338
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Blocks: ncurses-6.1
  Show dependency tree
Reported: 2018-03-27 14:41 UTC by Vincent de Phily
Modified: 2018-05-23 18:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Vincent de Phily 2018-03-27 14:41:16 UTC
atop output is messed up (text at wrong positions, old text not deleted...) when running with ncurses 6.1-r2. Tried recompiling both packages.

atop works fine with ncurses 6.0.

# emerge --info
Portage 2.3.24 (python 3.5.4-final-0, default/linux/amd64/17.0/hardened, gcc-6.4.0, glibc-2.25-r10, 4.15.12-gentoo x86_64)
System uname: Linux-4.15.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-4800MQ_CPU_@_2.70GHz-with-gentoo-2.4.1
KiB Mem:     8126784 total,    583512 free
KiB Swap:    4095996 total,   4032524 free
Timestamp of repository gentoo: Tue, 27 Mar 2018 14:00:01 +0000
Head commit of repository gentoo: dfe0b3060c6b82f617fb5f818ed2e181dae7d2ed
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.15::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no

    location: /home/work/c/ebuilds
    masters: gentoo
    priority: 0

ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x google-chrome"
CFLAGS="-Os -march=native -pipe"
CONFIG_PROTECT="/etc /opt/zookeeper-bin/conf /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-Os -march=native -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict strict-keepdir unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="                  "
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-s -j5 -l6"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X aac acl activities akonadi alsa amd64 apache2 apng avahi bash-completion brightness-control btrfs bzip2 cdda cddb crash-reporter crypt cups cxx dbus declarative dvd ebook egl elogind emacs encode epub erlang exif ffmpeg flac fontconfig go gstreamer gudev hardened iconv icu ipv6 jit jpeg jpeg2k json kde kdepim kwallet lto lzma marble mng mp3 mpeg mplayer mtp multilib mysql ncurses nls nptl ogg openexr opengl openmp openssl opus otr pam pcre pdf pgo pie plasma pm-utils png policykit postgres printsupport prison pulseaudio python qrcode qt5 readline rust samba scanner script sddm seccomp semantic-desktop shapefile silk spatialite speex sql sqlite ssl ssp startup-notification svg sysstat system-cairo system-harfbuzz system-icu system-jpeg system-libevent system-libvpx system-llvm system-sqlite taglib theora threads tiff truetype udisks unicode upnp usb v4l video vnc vorbis wayland webkit wifi x264 xattr xcb xcomposite xmp xtpax xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python3_5" QEMU_USER_TARGETS="x86_64" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2018-03-28 06:44:31 UTC
Which terminal emulator do you use?
Comment 2 Vincent de Phily 2018-03-29 15:24:19 UTC
My original test terminals were konsole-17.12.3 and yakuake (uses the konsole component underneath, AFAIK). 

I've now tried with xterm-327, xfce4-terminal-0.8.6. and x11-terms/cool-retro-term-1.0.1. None of those trigger the bug, so it does look terminal-specific as well as being tied to the ncurses version.

In all these terminals, I have either $TERM=xterm or $TERM=xterm-256colors.

Exporting TERM=konsole in the konsole shell fixes the atop behaviour.

I couldn't find any place where I'd have configured that away from the default (I use bash and KDE), so for the moment I'm assuming that "TERM=xterm" is set by konsole.

I'm not sure who's at fault here:
 * did I configure a bad TERM somewhere ?
 * does konsole deviate from normal xterm behaviour but fail to set TERM=konsole ?
 * should ncurse have kept the konsole-compatible behaviour of TERM=xterm that it had in 6.0 ?

I'm glad I found the `export TERM=konsole` workaround (even though I'm not sure where it should be applied), but I'm also waiting on #651720 before unmasking ncurses-6.1 on my machine.
Comment 3 Ortwin Glueck 2018-04-06 12:20:39 UTC
Same here, and upstream bug:
Comment 4 Pacho Ramos gentoo-dev 2018-05-23 18:24:58 UTC

*** This bug has been marked as a duplicate of bug 648338 ***